Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Using 'geo.enabled' to configure geolation for all sites - no "user set" appears that I can toggle.

  • 14 replies
  • 1 has this problem
  • 246 views
  • Last reply by McCoy

more options

Hi,

On Firefox 65.0.1, out of nowhere, one of my sites is saying:

"You have denied sharing of your location in your browser. Please change your browser settings if you want to share location". I have been using the site for years and haven't changed any settings - in my Firefox preferences my "permissions/access your location" is still set to "allowed". I contacted the site and they said:

"How do I turn on location sharing in Firefox? Configure access settings for all sites 1. Enter the command about:config in the browser's address bar. 2. In the window that appears, click I'll be careful, I promise!. 3. Enter geo.enabled in the Search line. 4. To allow location to be determined for all sites, right-click “user set” and choose Toggle."

But there is no "user set" to toggle. The only words that appear are "Preference Name" "geo.enabled" "Status" "default" "Type" "boolean" "Value" and "true" (again, couldn't attach image here?).

Help!

Chosen solution

I don't know if this will help, but have you enabled "Location Services" on your Mac  ?

See these search results .....

(I don't get that message on that site, but that could be because I'm not signed in)

Read this answer in context 👍 1

All Replies (14)

more options

You would have to check the permissions.default.geo pref.

You can also click the Settings button in "Options/Preferences -> Privacy & Security -> Permissions > Location" and check the Block setting at the bottom.

more options

This did not fix. I checked the "Block new requests asking to access your location" (this was the only box at the bottom to check), saved, restarted Firefox and the problem is still there. I then went back, unchecked, saved, restarted and the problem is still there. Any other thoughts would be greatly appreciated. Also, since I have been instructed several times to toggle "user set" I have to wonder, why is "user set" not showing up as it obviously has for those folks instructing me to toggle it?

more options

Hello westvillageman,

In addition to the above - another thing you could do :

When you're on that site, click on the 'i' in a circle, next to the padlock at the left side of the address bar.

Then click on the little black arrow on the dropdown and then on "More Information", which will take you to "Page Info".

Click on the 'Permissions" tab and scroll down to "Access Your Location". Uncheck "Use Default" and check "Allow".

Then close and restart Firefox.

more options

I have done this and it says "allowed". I unchecked it, restarted then clicked allowed again, restarted and the problem still persists. Also, there is no 'more information'. When I click on the 'i' in the circle I get this:

more options

User set doesn't mean that much because it is possible to override a default setting if you know how to do this. I do that for some prefs, so if I would use another or new profile then I do not need to change a lot of prefs. A pref appears as user set if this pref is defined in one of the files that set default values for pref of if it is a hidden pref that only appears when it gets a specific value and thus gets visible. For the latter type for instance "update" in the search bar top see prefs that set a last update time.

Did you check the above mentioned permission.default setting(s)?


Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
more options

westvillageman said

I have done this and it says "allowed". I unchecked it, restarted then clicked allowed again, restarted and the problem still persists. Also, there is no 'more information'. When I click on the 'i' in the circle I get this:

You probably missed the part in my post where I said :

Then click on the little black arrow on the dropdown and then on "More Information", which will take you to "Page Info".

(and then you will see the "Permissions" tab ..... )

The "little black arrow" is to the right of "Connection".

more options

OK, re: your "User set doesn't mean that much . . . " response - wow. I consider myself of decent intellect but that was almost like hearing Mandarin. I read it three times and just straight up can't suss out what you mean. lol. Sorry, man. I am so appreciative of your help so please don't give up on me. I fear I may be one of those "layman's terms" people. I'm going to reread and gonna read through the two support links but I swear, the more detailed these things get, the more lost I feel. #toomuchinformation

Re: black arrow/more info - I got to that and "use default" was already unchecked and "allow" was already checked. So I changed them, rechecked them and am gonna restart Firefox after I send this message.

more options

Still saying:

"You have denied sharing of your location in your browser. Please change your browser settings if you want to share location"

Another question while I try to read through this stuff again:

Why would this suddenly change on my Mac/Firefox? Could it be the last Firefox update? Is this occurring with others?

more options

You can select the default setting for sharing the location. That should make Firefox ask for permission. Also look for the special icon on the location bar and notice a notch (dot) on the Control Center 'i' icon when you have made changes to permission settings for this tab.

more options

I did that and Firefox did ask for permission, which I clicked (also clicked 'remember this decision') and then I restarted Firefox and I got the same message.

more options

Did it work that first time?

Did you allow sharing location for this session or did you make an allow exception if you check this on the Options/Preferences page?

If it didn't last after restarting Firefox then something seems to be wrong with files that store permissions in the profile folder.

There is software like Advanced SystemCare with its Surfing Protection feature that can protect files in the Firefox profile folder against changes. If you have such software or use other cleanup software then check the settings or uninstall this software.

more options

Chosen Solution

I don't know if this will help, but have you enabled "Location Services" on your Mac  ?

See these search results .....

(I don't get that message on that site, but that could be because I'm not signed in)

Modified by McCoy

more options

McCoy - you're a star!! This the simple fix I was hoping for and is exactly what was needed. I know about location services but I never go in and tweak or change things because I did that long ago setting up things the way I like but yeah, this totally fixed the issue. BUT, the question still begs to be answered:

How and why did this suddenly change in my settings since I didn not change it?

cor-el - thanks so much for all your thoughtful suggestions.

Phew!!

Modified by westvillageman

more options

I sure am glad that changing the location services setting fixed
the problem  !

Why the setting changed without you doing anything : I really wouldn't know (sorry .... )

Maybe you could ask here :

https://support.apple.com/en-us/HT204690

(unless somebody else here knows the answer)