X
Tap here to go to the mobile version of the site.
An updated version of Firefox is available to address the issues with Add-ons disabled or fail to install on Firefox. You can download the update for your OS here: https://www.mozilla.org/firefox/new/ For Known Issues and Workarounds, please check out the update at https://support.mozilla.org/kb/add-ons-disabled-or-fail-to-install-firefox

Support Forum

Firefox tabs crash constantly

Posted

I have recently updated Windows 10 to it's last version, including the Media Feature Pack. Since then certain tabs started crashing on load. This includes all youtube videos I tried and this mozilla support forum. I have updated my graphics drivers and dis/re-enabled WebGL. Also started Firefox/Windows in SafeMode but the crashes still happen.

I have also downgraded Firefox: v63.0.3 - crashes still happened v62.0.3 - crashes stopped happening, (other problems arose)

I have generated a couple crash reports and added them below: Youtube: bp-740a0912-50f7-4234-af35-202060190221 2/21/2019, 8:47 AM bp-f530a04b-cee6-4d11-8bf6-9dd7f0190221 2/21/2019, 8:47 AM bp-cebd2e73-2cc0-4704-a11e-f60f00190221 2/21/2019, 8:47 AM

Mozilla Support forum: (https://support.mozilla.org/en-US/kb/firefox-crashes-troubleshoot-prevent-and-get-help) bp-241d2629-d475-40da-b441-3d8a10190221 2/21/2019, 8:48 AM

I have recently updated Windows 10 to it's last version, including the Media Feature Pack. Since then certain tabs started crashing on load. This includes all youtube videos I tried and this mozilla support forum. I have updated my graphics drivers and dis/re-enabled WebGL. Also started Firefox/Windows in SafeMode but the crashes still happen. I have also downgraded Firefox: v63.0.3 - crashes still happened v62.0.3 - crashes stopped happening, (other problems arose) I have generated a couple crash reports and added them below: Youtube: bp-740a0912-50f7-4234-af35-202060190221 2/21/2019, 8:47 AM bp-f530a04b-cee6-4d11-8bf6-9dd7f0190221 2/21/2019, 8:47 AM bp-cebd2e73-2cc0-4704-a11e-f60f00190221 2/21/2019, 8:47 AM Mozilla Support forum: (https://support.mozilla.org/en-US/kb/firefox-crashes-troubleshoot-prevent-and-get-help) bp-241d2629-d475-40da-b441-3d8a10190221 2/21/2019, 8:48 AM

Modified by characterValidation

Chosen solution

hi, this should be a workaround to avoid the tab crashes: enter about:config into the firefox address bar (confirm the info message in case it shows up) & search for the preference named media.wmf.vp9.enabled. double-click it and change its value to false, then restart firefox once.

Read this answer in context 1
Quote

Additional System Details

Installed Plug-ins

Firefox Multi-Account Containers Ghostery - Privacy Ad Blocker Tree Style Tab uBlock Origin

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/72.0.3626.109 Safari/537.36

More Information

WestEnd
  • Top 10 Contributor
59 solutions 5125 answers

What media pak? Firefox doesn't install media pack. And how did you update firefox and how was Win10 update?

What media pak? Firefox doesn't install media pack. And how did you update firefox and how was Win10 update?
Was this helpful to you? 0
Quote

Question owner

I had problems with the Windows 10 update from the update center so I downloaded the Windows 10 Media Creation Tool and did the update through this. This finally worked to get Windows 10 Pro N 1809. Because Windows 10 N Version doesn't come with codecs I have to Install the Windows Media Feature Pack to add these (Be able to watch H264 Videos and such) Firefox updates itself in the background. Just prompting me to restart to finish it.

The downgrades I did by simply installing the older version in the default directory (didn't turn the auto update off though, so it automatically updated to the latest again)

I had problems with the Windows 10 update from the update center so I downloaded the Windows 10 Media Creation Tool and did the update through this. This finally worked to get Windows 10 Pro N 1809. Because Windows 10 N Version doesn't come with codecs I have to Install the Windows Media Feature Pack to add these (Be able to watch H264 Videos and such) Firefox updates itself in the background. Just prompting me to restart to finish it. The downgrades I did by simply installing the older version in the default directory (didn't turn the auto update off though, so it automatically updated to the latest again)
Was this helpful to you?
Quote
philipp
  • Top 25 Contributor
  • Moderator
5246 solutions 23210 answers

Chosen Solution

hi, this should be a workaround to avoid the tab crashes: enter about:config into the firefox address bar (confirm the info message in case it shows up) & search for the preference named media.wmf.vp9.enabled. double-click it and change its value to false, then restart firefox once.

hi, this should be a workaround to avoid the tab crashes: enter '''about:config''' into the firefox address bar (confirm the info message in case it shows up) & search for the preference named '''media.wmf.vp9.enabled'''. double-click it and change its value to '''false''', then restart firefox once.
Was this helpful to you? 1
Quote

Question owner

Seems to have worked. thank you!

Seems to have worked. thank you!
Was this helpful to you?
Quote
iboone 0 solutions 1 answers

I had the same problem... tabs would crash independently.

HOW TO FIX TABS CRASHING IN FIREFOX?

Not fixing my problem

  1. 64 bit version : yes
  2. drivers fix? try to update my nvidia drivers (gtx 960 gpu on dual screen), it didn't fix the problem.
  3. hardware fix? checking RAM memory with memtest or windows RAM testing, no problem found.
  4. hardware acceleration fix? try to disable hardware acceleration, it didn't fix the problem.
  5. vp9 fix? try to change media.wmf.vp9.enabled, seems more stable, but it didn't fix the problem. in fact this solution works for some people because it reduces ram and cpu usage. some people have reported high usage in cpu/ram while having vp9 activated.

Check out the committed memory

finally solution was in using process explorer to find out that firefox was using a lot of memory (but not physical memory, but what is called "system commit" which is the committed memory).

I have 8Gb of physical RAM.

Each tab would increase commited memory usage Without firefox executed, my committed memory was 4Gb but each time I opened a new tab, it would take at least 300mb to 500mb more each. It could reach quickly more than 8Gb. Reaching 8Gb, it would start to be unstable. And around 9/10 Gb of committed memory, tabs would start to have display issues (square, black square, etc..). Videos would crash too. And sometimes I would get a black screen or screen would lost connection.

You can also see this limit in checking the Performances (Alt+Ctr+Del - Tasks / Performance).

Enabling Virtual Memory and setting it large enough

my virtual memory was not enabled in windows 10. i have enabled it and make it big enough. To do that, increase the minimum virtual memory and make a maximum 3 or 4 times bigger. When you will check the commited value (Altr Contr Del - Tasks / Performance), the commited value max would increase too.

Installing Autodiscard plugins

I have also installed the Autodiscard tabs plugins, which help me reduce firefox memory usage.

since then, my firefox is definitely more stable. no more crash. hardware acceleration is on enabled. no problem at all.

Conclusion 1. Firefox is huge in RAM usage especially in multi tabs, multitask environment.

2. Multitasking users like me should definitely upgrade to more RAM such as 16gb of physical RAM.

I had the same problem... tabs would crash independently. '''HOW TO FIX TABS CRASHING IN FIREFOX?''' '''Not fixing my problem''' # '''64 bit version''' : yes # '''drivers fix?''' try to update my nvidia drivers (gtx 960 gpu on dual screen), it didn't fix the problem. # '''hardware fix?''' checking RAM memory with memtest or windows RAM testing, no problem found. # '''hardware acceleration fix?''' try to disable hardware acceleration, it didn't fix the problem. # '''vp9 fix?''' try to change media.wmf.vp9.enabled, seems more stable, but it didn't fix the problem. in fact this solution works for some people because it reduces ram and cpu usage. some people have reported high usage in cpu/ram while having vp9 activated. '''Check out the committed memory''' finally solution was in using process explorer to find out that firefox was using a lot of memory (but not physical memory, but what is called "system commit" which is the committed memory). I have 8Gb of physical RAM. '''Each tab would increase commited memory usage''' Without firefox executed, my committed memory was 4Gb but each time I opened a new tab, it would take at least 300mb to 500mb more each. It could reach quickly more than 8Gb. Reaching 8Gb, it would start to be unstable. And around 9/10 Gb of committed memory, tabs would start to have display issues (square, black square, etc..). Videos would crash too. And sometimes I would get a black screen or screen would lost connection. You can also see this limit in checking the Performances (Alt+Ctr+Del - Tasks / Performance). '''Enabling Virtual Memory and setting it large enough''' my virtual memory was not enabled in windows 10. i have enabled it and make it big enough. To do that, increase the minimum virtual memory and make a maximum 3 or 4 times bigger. When you will check the commited value (Altr Contr Del - Tasks / Performance), the commited value max would increase too. '''Installing Autodiscard plugins''' I have also installed the Autodiscard tabs plugins, which help me reduce firefox memory usage. since then, my firefox is definitely more stable. no more crash. hardware acceleration is on enabled. no problem at all. '''Conclusion''' 1. Firefox is huge in RAM usage especially in multi tabs, multitask environment. 2. Multitasking users like me should definitely upgrade to more RAM such as 16gb of physical RAM.

Modified by iboone

Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.