X
Tap here to go to the mobile version of the site.
An updated version of Firefox is available to address the issues with Add-ons disabled or fail to install on Firefox. You can download the update for your OS here: https://www.mozilla.org/firefox/new/ For Known Issues and Workarounds, please check out the update at https://support.mozilla.org/kb/add-ons-disabled-or-fail-to-install-firefox

Support Forum

When I type a URL in the address field why is a search box opeing up below?

Posted

As I enter a web address into the address field, just below a search block opens up. I already have a search option available next to the address field. How can I turn off the extra search information block?

As I enter a web address into the address field, just below a search block opens up. I already have a search option available next to the address field. How can I turn off the extra search information block?

Chosen solution

You can set keyword.enabled to false on the about:config page to disable search in the location bar and possibly use code in userChrome.css to hide items in the location bar drop-down list.

You can remove the search engine bar in the address bar drop down list by setting this pref to false on the about:config page.

  • browser.urlbar.oneOffSearches = false

You can use code in userChrome.css remove all suggestions from the address bar drop down list.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

/* remove all items from the urlbar drop down */
#PopupAutoCompleteRichResult {display:none !important;}
Read this answer in context 1
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:65.0) Gecko/20100101 Firefox/65.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
17105 solutions 154480 answers

See the settings for the address bar in "Options/Preferences -> Search".

See the settings for the address bar in "Options/Preferences -> Search".

Modified by cor-el

Was this helpful to you? 1
Quote
McCoy
  • Top 10 Contributor
398 solutions 3508 answers

Helpful Reply

Hello numbat,

In addition to the above :

Would you please do this :

3-bar menu => Options => Privacy & Security => under 'Address Bar':

uncheck the three options.


Just in case you are also getting a bar, bar, listing all available search engines, would you please do this :

Type in the address bar about:config and press Enter (promise to be careful, if asked)

Type in the search bar and look for the preference :

browser.urlbar.OneOffSearches

and set its value to false

Then close and restart Firefox.

Note: that preference was disabled, but works again today.

Hello numbat, In addition to the above : Would you please do this : 3-bar menu => Options => Privacy & Security => under 'Address Bar': uncheck the three options. -------------------------------------------------------------------------------------------- Just in case you are also getting a bar, bar, listing all available search engines, would you please do this : Type in the address bar '''about:config''' and press Enter (promise to be careful, if asked) Type in the search bar and look for the preference : '''browser.urlbar.OneOffSearches''' and set its value to '''false''' Then close and restart Firefox. '''Note''': that preference was disabled, but works again today.
Was this helpful to you? 2
Quote

Question owner

Have tried the two above suggestions. The search bar with a list of suggested search engines no longer appears, but I still get a new bar opening that mimics what I am typing and appends "- Visit". See attached image. Should I remove and re-install Firefox?

Have tried the two above suggestions. The search bar with a list of suggested search engines no longer appears, but I still get a new bar opening that mimics what I am typing and appends "- Visit". See attached image. Should I remove and re-install Firefox?
Was this helpful to you? 0
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17105 solutions 154480 answers

You can add code to the userChrome.css file below the default @namespace line.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

/* remove all items from the urlbar drop down */
#PopupAutoCompleteRichResult {display:none!important;}

It is not that difficult to create userChrome.css if you have never used it.

The first step is to open the "Help -> Troubleshooting Information" page and find the button to access the profile folder.

You can find this button under the "Application Basics" section as "Profile Folder -> Open Folder". If you click this button then you open the profile folder in the Windows File Explorer. You need to create a folder with the name chrome in this folder (name is all lowercase). In the chrome folder you need to create a text file with the name userChrome.css (name is case sensitive). In this userChrome.css text file you paste the text posted.

In Windows saving the file is usually the only time things get more complicated because Windows can silently add a .txt file extension and you end up with a file named userChrome.css.txt. To avoid this you need to make sure to select "All files" in the dialog to save the file in the text editor using "Save File as".

You need to close and restart Firefox when you create or modify the userChrome.css file.

You can add code to the <b>userChrome.css</b> file below the default @namespace line. *http://kb.mozillazine.org/userChrome.css *https://www.userchrome.org/how-create-userchrome-css.html <hr> <pre><nowiki>@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */ /* remove all items from the urlbar drop down */ #PopupAutoCompleteRichResult {display:none!important;} </nowiki></pre> ---- It is not that difficult to create userChrome.css if you have never used it. The first step is to open the "Help -> Troubleshooting Information" page and find the button to access the profile folder. *https://support.mozilla.org/en-US/kb/use-troubleshooting-information-page-fix-firefox You can find this button under the "Application Basics" section as "Profile Folder -> Open Folder". If you click this button then you open the profile folder in the Windows File Explorer. You need to create a folder with the name <u>chrome</u> in this folder (name is all lowercase). In the <b>chrome</b> folder you need to create a text file with the name <u>userChrome.css</u> (name is case sensitive). In this userChrome.css text file you paste the text posted. In Windows saving the file is usually the only time things get more complicated because Windows can silently add a .txt file extension and you end up with a file named <i>userChrome.css.txt</i>. To avoid this you need to make sure to select "All files" in the dialog to save the file in the text editor using "Save File as". You need to close and restart Firefox when you create or modify the userChrome.css file.
Was this helpful to you?
Quote

Question owner

My apologies to all. I have failed to see what the real problem is. I failed to notice that the URL address field now has the heading "Search with Wikipedia (en) or enter address". This is the default configuration found at Tools->Options->Search->Default Search Engine. There is no option to change this from search or address to just address and use the search window to the right as the actual search function. Is there anyway to change the original address bar back to being just an address bar?

My apologies to all. I have failed to see what the real problem is. I failed to notice that the URL address field now has the heading "Search with Wikipedia (en) or enter address". This is the default configuration found at Tools->Options->Search->Default Search Engine. There is no option to change this from search or address to just address and use the search window to the right as the actual search function. Is there anyway to change the original address bar back to being just an address bar?
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17105 solutions 154480 answers

Chosen Solution

You can set keyword.enabled to false on the about:config page to disable search in the location bar and possibly use code in userChrome.css to hide items in the location bar drop-down list.

You can remove the search engine bar in the address bar drop down list by setting this pref to false on the about:config page.

  • browser.urlbar.oneOffSearches = false

You can use code in userChrome.css remove all suggestions from the address bar drop down list.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

/* remove all items from the urlbar drop down */
#PopupAutoCompleteRichResult {display:none !important;}
You can set <b>keyword.enabled</b> to false on the <b>about:config</b> page to disable search in the location bar and possibly use code in userChrome.css to hide items in the location bar drop-down list. You can remove the search engine bar in the address bar drop down list by setting this pref to false on the about:config page. * browser.urlbar.oneOffSearches = false You can use code in userChrome.css remove all suggestions from the address bar drop down list. *http://kb.mozillazine.org/userChrome.css *https://www.userchrome.org/how-create-userchrome-css.html *https://www.userchrome.org/what-is-userchrome-css.html <hr> <pre><nowiki>@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */ /* remove all items from the urlbar drop down */ #PopupAutoCompleteRichResult {display:none !important;} </nowiki></pre>
Was this helpful to you? 1
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17105 solutions 154480 answers

You can remove the search engine bar in the address bar drop down list by setting this pref to false on the about:config page.

  • browser.urlbar.oneOffSearches = false

You can use code in userChrome.css remove all suggestions from the address bar drop down list.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

/* remove all items from the urlbar drop down */
#PopupAutoCompleteRichResult {display:none !important;}
You can remove the search engine bar in the address bar drop down list by setting this pref to false on the about:config page. *browser.urlbar.oneOffSearches = false You can use code in userChrome.css remove all suggestions from the address bar drop down list. *http://kb.mozillazine.org/userChrome.css *https://www.userchrome.org/how-create-userchrome-css.html *https://www.userchrome.org/what-is-userchrome-css.html <hr> <pre><nowiki>@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */ /* remove all items from the urlbar drop down */ #PopupAutoCompleteRichResult {display:none !important;} </nowiki></pre>
Was this helpful to you? 1
Quote

Question owner

Thank you all for your input. For me the best option was to set keyword.enabled to false. This eliminated the search bar with all the search engine options and made the web page less busy. I don't trust my own programming skills right now to attempt to modify the userChrome.css file. Perhaps at a later date.

Thank you all for your input. For me the best option was to set keyword.enabled to false. This eliminated the search bar with all the search engine options and made the web page less busy. I don't trust my own programming skills right now to attempt to modify the userChrome.css file. Perhaps at a later date.
Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
398 solutions 3508 answers

numbat said

For me the best option was to set keyword.enabled to false. This eliminated the search bar with all the search engine options and made the web page less busy.

That's weird, cause you mentioned earlier that the second part of my post took care of that ...... Setting "keyword.ebabled" to "false" won't eliminate the search engine options, nor does it disable the 'Visit' bar.

''numbat [[#answer-1194744|said]]'' <blockquote> For me the best option was to set keyword.enabled to false. This eliminated the search bar with all the search engine options and made the web page less busy. </blockquote> That's weird, cause you mentioned earlier that the second part of my post took care of that ...... Setting "keyword.ebabled" to "false" won't eliminate the search '''engine''' options, nor does it disable the 'Visit' bar.

Modified by McCoy

Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.