Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Auto-Completion on URLs not working on certain domains

more options

Issue is related to an existing issue located in a thread at , but seeing as I have to create a new issue just to get the information I had that could contain a reason for it happening, the reply I attempted to leave in that thread is in this new one instead...

Original attempted reply: Same situation, but I believe I know what causes the problem (or at least what caused it in my case). I was trying to remove a URL that kept popping up that was no longer valid (related to Twitch usernames, seeing as users can change their usernames, which also changes their channel profile), rather than deleting the URL from my history, I instead attempted to use the "Forget About This Site" option in Firefox on the History listing; this not only caused the URL itself from auto-filling, but the entire domain... I don't particularly want to have to restore thousands of Bookmarks after uninstalling & reinstalling Firefox, so I'd sooner just post the details here & see if there is a way to reverse the "Forget About This Site" function where it's been misused in the past (in the mean time I'm just clicking on the correct links from my history in the drop-down history while typing it, but URL auto-completion for StreamLabs remains broken, those URLs changing along with Twitch usernames, explaining how URLs can be invalidated after a Twitch username change).

All Replies (2)

more options

WonderGamer said

Auto-Completion on URLs not working on certain domains...

Have you tried playing with the Address/URL Box and Search Options? My settings are in the attached images, below.


more options

I don't really like searching from the address bar, so I have those functions in your first screenshot disabled. As for what is allowed in the address bar, all of what you have is your second screenshot is still allowed, however the previous setting on that page show that I only allow "Remember browsing and download history", I have the other options disabled & the browser only goes into Private browsing mode when I manually put it into it. I've noticed other domains are also included that are not auto-completing, however regarding streamlabs, the 3rd screenshot I've provided will show what is happening. The 4th screenshot shows the option that I believe may be responsible for it happening (using this option not knowing what it would do, rather than just deleting the URL from my history so the address bar wouldn't continue auto-completing a URL that was no longer valid after a Twitch name change).

Note that I've had to revert back to Firefox v64.0.2 (64-bit) through a system restore on my main computer (reverting back almost 2 weeks, then patching back up, not doing the patch on Firefox), v65.0 was causing it to crash every time I closed the browser on my main computer (not my laptop, it still has the latest version, but I've had to do a system restore on that computer due to a Windows Update causing the display functions to screw up; that update from Microsoft has been hidden so I don't install it again), both computers are running Windows 7 Ultimate 64-bit; I won't be updating to the most recent version of Firefox on my main computer until I see a new version has been pushed on my laptop (Mozilla already has a plethora of crash reports I've made after the patch on my main computer, didn't need to continue sending them after reverting back through the system restore). The biggest problem with the crashes was that cookies weren't getting saved and/or weren't being allowed to load on some sites, I was literally having to get a new phone call & authorization key through both of my Google accounts every time I started Firefox back up...