Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Youtube won't load videos.

  • 8 replies
  • 3 have this problem
  • 769 views
  • Last reply by McCoy

more options

When trying to play videos using Firefox, I get an error on YouTube saying "Your browser does not recognize any of the video formats available". I get this for about 50% of videos I try to play. This also happens to be after a clean installation of windows onto an SSD, where it was working prior to the new SSD. Things I've tried: -Restarting Firefox in safe mode without add-ons (Failed) -Turning off Hardware Acceleration (Failed) -Reinstalling Firefox completely (Failed) -Getting Adobe Flash player (Failed) -Using Google Chrome to play the same video (Passed, Chrome will play anything, Firefox will not) I'm running out of ideas to try and seriously need help, as it's bothering me that nothing's working!

Chosen solution

Hello SnowLily,

Should none of the above solve the problem : maybe you could consider switching to the (stable) regular release Firefox version, which is now 65.0.

In other threads (like on reddit) I noticed that making that switch is what did the trick for others - worth a try .....

Read this answer in context 👍 1

All Replies (8)

more options

Link to the video problem in question? And have you tried it in safe mode?

Modified by WestEnd

more options

I have tried Safe Mode already, it didn't work. If I understand what you're asking for a link to, there's a screenshot of the issue.

more options

Is this with all YouTube links? What about other websites?

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

more options

FredMcD said

Is this with all YouTube links? What about other websites? Start Firefox in Safe Mode {web link} A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

Using safe mode does not fix the issue, and it isn't just YouTube, Twitch.tv, the live streaming site's screen is gray instead of showing the video.

more options

Start your Computer in safe mode with network support. Then start Firefox. Try Secure websites. Is the problem still there?

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia

more options

Chosen Solution

Hello SnowLily,

Should none of the above solve the problem : maybe you could consider switching to the (stable) regular release Firefox version, which is now 65.0.

In other threads (like on reddit) I noticed that making that switch is what did the trick for others - worth a try .....

more options

McCoy said

Hello SnowLily, Should none of the above solve the problem : maybe you could consider switching to the (stable) regular release Firefox version, which is now 65.0. In other threads (like on reddit) I noticed that making that switch is what did the trick for others - worth a try .....

That definitely was it, wow I wouldn't have guessed that, thank you so much! <3

more options

SnowLily said

That definitely was it, wow I wouldn't have guessed that, thank you so much! <3

My pleasure, SnowLily - I'm glad you got things working again  !