X
Tap here to go to the mobile version of the site.

Support Forum

Japanese characters are not showing in Firefox

Posted

I am having a problem with viewing Japanese page like www.yahoo.co.jp in Firefox. Japanese characters are showing as square boxes with hex code and unreadable. But in other browsers IE and Chrome, Japanese characters are displaying correctly. I had already tried refresh Firefox and change font for Japanese but it didn't work.

The following are system information :

 OS:Windows 7 32bit
 System Locale:English(US)
 Firefox ESR 60.2.2 en-us

Please. Can anyone help me to solve this problem?

I am having a problem with viewing Japanese page like www.yahoo.co.jp in Firefox. Japanese characters are showing as square boxes with hex code and unreadable. But in other browsers IE and Chrome, Japanese characters are displaying correctly. I had already tried refresh Firefox and change font for Japanese but it didn't work. The following are system information : OS:Windows 7 32bit System Locale:English(US) Firefox ESR 60.2.2 en-us Please. Can anyone help me to solve this problem?
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0

More Information

FredMcD
  • Top 10 Contributor
4025 solutions 56245 answers

Sounds like an issue with fonts.

Type about:preferences#content<enter> in the address bar. Across from fonts and colors, press the Advanced button. On the bottom, turn on Allow Web Sites To Choose Their Own.

Fonts Information - Detected via Flash http://browserspy.dk/fonts-flash.php?detail=1

Sounds like an issue with fonts. Type '''about:preferences#content'''<enter> in the address bar. Across from '''fonts and colors,''' press the '''Advanced''' button. On the bottom, turn on '''Allow Web Sites To Choose Their Own.''' Fonts Information - Detected via Flash http://browserspy.dk/fonts-flash.php?detail=1
Was this helpful to you?
Quote

Helpful Reply

FredMcD Thank you for your solution. Allow Web Sites To Choose Their Own setting is already on by default but that didn't work. I had already tried on and off with above setting. Is there any other solution for this? Thanks.

FredMcD Thank you for your solution. '''Allow Web Sites To Choose Their Own''' setting is already on by default but that didn't work. I had already tried on and off with above setting. Is there any other solution for this? Thanks.
Was this helpful to you? 1
Quote
FredMcD
  • Top 10 Contributor
4025 solutions 56245 answers

I called for more help. Did you check out the fonts link?

I called for more help. Did you check out the fonts link?
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
16991 solutions 153418 answers

What font is Firefox trying to use if you check this in the Font Inspector?

You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected.

You can check the font used for selected text in the Font tab in the right pane of the Inspector.

Note that this is not about the font-family CSS rule, but about the font that Firefox actually uses as shown in the Font tab.

What font is Firefox trying to use if you check this in the Font Inspector? You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected. *"3-bar" menu button or Tools -> Web Developer *https://developer.mozilla.org/en-US/Tools/Page_Inspector You can check the font used for selected text in the Font tab in the right pane of the Inspector. Note that this is not about the font-family CSS rule, but about the font that Firefox actually uses as shown in the Font tab. *https://developer.mozilla.org/en-US/Tools/Page_Inspector/How_to/View_fonts
Was this helpful to you?
Quote

Question owner

Hi cor-el

I uploaded image for Inspector window. Can you check and suggest for the solution?

Hi cor-el I uploaded image for Inspector window. Can you check and suggest for the solution?
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
16991 solutions 153418 answers

You need to right-click in an area where you see the boxed characters to open the Inspector with this element selected. The screenshot shows the font used by default in the HTML tag. So could you provide anther screenshot.

You need to right-click in an area where you see the boxed characters to open the Inspector with this element selected. The screenshot shows the font used by default in the HTML tag. So could you provide anther screenshot.
Was this helpful to you?
Quote

Question owner

It is displaying like this.See the image.

It is displaying like this.See the image.
Was this helpful to you?
Quote

Question owner

Japanese font <title> tag is displaying correctly and not in body part. Is there any suggestion with this?

Japanese font <title> tag is displaying correctly and not in body part. Is there any suggestion with this?
Was this helpful to you?
Quote

Question owner

FredMcD said

I called for more help. Did you check out the fonts link?

cor-el said

You need to right-click in an area where you see the boxed characters to open the Inspector with this element selected. The screenshot shows the font used by default in the HTML tag. So could you provide anther screenshot.

Hi cor-el Is there any suggestion with the image I uploaded?

''FredMcD [[#answer-1191990|said]]'' <blockquote> I called for more help. Did you check out the fonts link? </blockquote> ''cor-el [[#answer-1192305|said]]'' <blockquote> You need to right-click in an area where you see the boxed characters to open the Inspector with this element selected. The screenshot shows the font used by default in the HTML tag. So could you provide anther screenshot. </blockquote> Hi cor-el Is there any suggestion with the image I uploaded?
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
16991 solutions 153418 answers

That screenshot shows that Firefox is using the Arial font. I don't know if that font includes Japanese glyphs, but if it isn't working then I assume that the answer is 'no'.

The website specifies this font-family for the body if I check this in the Inspector, so Arial is part of the list:

body {
	font-family: MS PGothic,Arial,Hiragino Kaku Gothic ProN,Osaka,sans-serif;
	line-height: 1.22;
}

For me Firefox uses Droid Sans Japanese on Linux.

That screenshot shows that Firefox is using the Arial font. I don't know if that font includes Japanese glyphs, but if it isn't working then I assume that the answer is 'no'. The website specifies this font-family for the body if I check this in the Inspector, so Arial is part of the list: <pre><nowiki>body { font-family: MS PGothic,Arial,Hiragino Kaku Gothic ProN,Osaka,sans-serif; line-height: 1.22; }</nowiki></pre> For me Firefox uses Droid Sans Japanese on Linux.
Was this helpful to you?
Quote

Question owner

cor-el said

That screenshot shows that Firefox is using the Arial font. I don't know if that font includes Japanese glyphs, but if it isn't working then I assume that the answer is 'no'. The website specifies this font-family for the body if I check this in the Inspector, so Arial is part of the list:
body {
	font-family: MS PGothic,Arial,Hiragino Kaku Gothic ProN,Osaka,sans-serif;
	line-height: 1.22;
}

For me Firefox uses Droid Sans Japanese on Linux.

Thank you taking your time for this. Is this problem in the Firefox or OS? Japanese is displaying correctly in Chrome,IE and other software like outlook. What is the difference between Firefox and other browsers? Is there any setting to display Japanese in Firefox if font is not detected automatically? Is there any other ways to find out the problem? Can you suggest all possible solution to solve this problem ?

''cor-el [[#answer-1194104|said]]'' <blockquote> That screenshot shows that Firefox is using the Arial font. I don't know if that font includes Japanese glyphs, but if it isn't working then I assume that the answer is 'no'. The website specifies this font-family for the body if I check this in the Inspector, so Arial is part of the list: <pre><nowiki>body { font-family: MS PGothic,Arial,Hiragino Kaku Gothic ProN,Osaka,sans-serif; line-height: 1.22; }</nowiki></pre> For me Firefox uses Droid Sans Japanese on Linux. </blockquote> Thank you taking your time for this. Is this problem in the Firefox or OS? Japanese is displaying correctly in Chrome,IE and other software like outlook. What is the difference between Firefox and other browsers? Is there any setting to display Japanese in Firefox if font is not detected automatically? Is there any other ways to find out the problem? Can you suggest all possible solution to solve this problem ?
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
16991 solutions 153418 answers

What font(s) are the other browsers using for the Japanese text?

What font(s) are the other browsers using for the Japanese text?
Was this helpful to you?
Quote

Question owner

cor-el said

What font(s) are the other browsers using for the Japanese text?

I uploaded images for Chrome and IE setting. Can you take a look at that?

''cor-el [[#answer-1194111|said]]'' <blockquote> What font(s) are the other browsers using for the Japanese text? </blockquote> I uploaded images for Chrome and IE setting. Can you take a look at that?
Was this helpful to you?
Quote

Question owner

Hi cor-el Can you check the browser setting from my uploaded images? Is there any suggestion for that?

Hi cor-el Can you check the browser setting from my uploaded images? Is there any suggestion for that?
Was this helpful to you?
Quote
AndRo Marian 2 solutions 26 answers

Have your windows the font "MS PGothic" installed ? I get the version 60.5.1 on Windows 10 and its works fine.

Have your windows the font "MS PGothic" installed ? I get the version 60.5.1 on Windows 10 and its works fine.

Modified by AndRo Marian

Was this helpful to you?
Quote

Question owner

AndRo Marian said

Have your windows the font "MS PGothic" installed ? I get the version 60.5.1 on Windows 10 and its works fine.

Yes, "MS PGothic" is installed in my windows. By the way, my windows is 7 32bit.

''AndRo Marian [[#answer-1196644|said]]'' <blockquote> Have your windows the font "MS PGothic" installed ? I get the version 60.5.1 on Windows 10 and its works fine. </blockquote> Yes, "MS PGothic" is installed in my windows. By the way, my windows is 7 32bit.
Was this helpful to you?
Quote

Question owner

FredMcD said

I called for more help. Did you check out the fonts link?

Hi FredMcD

Unfortunately, I can't check out the fonts link for security reasons. I uploaded captured images of font list. Can you check and suggest any solution?

''FredMcD [[#answer-1191990|said]]'' <blockquote> I called for more help. Did you check out the fonts link? </blockquote> Hi FredMcD Unfortunately, I can't check out the fonts link for security reasons. I uploaded captured images of font list. Can you check and suggest any solution?
Was this helpful to you?
Quote

Question owner

Japanese fonts are already installed in my computer but why can't I see in Firefox? Which setting should I change in Firefox to display Japanese font correctly? Does anyone has a solution with this problem?

Japanese fonts are already installed in my computer but why can't I see in Firefox? Which setting should I change in Firefox to display Japanese font correctly? Does anyone has a solution with this problem?
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
16991 solutions 153418 answers

It is possible that Firefox has a problem with the number of fonts you have installed or that some font cause problems.

Do other (CJK) Unicode blocks that should work display properly?

It is possible that Firefox has a problem with the number of fonts you have installed or that some font cause problems. Do other (CJK) Unicode blocks that should work display properly? *https://en.wikipedia.org/wiki/Category:Unicode_blocks
Was this helpful to you?
Quote

Question owner

cor-el said

It is possible that Firefox has a problem with the number of fonts you have installed or that some font cause problems. Do other (CJK) Unicode blocks that should work display properly?

Sorry, I don't know how to check other (CJK) Unicode blocks display properly. Can you tell me how?

''cor-el [[#answer-1198535|said]]'' <blockquote> It is possible that Firefox has a problem with the number of fonts you have installed or that some font cause problems. Do other (CJK) Unicode blocks that should work display properly? *https://en.wikipedia.org/wiki/Category:Unicode_blocks </blockquote> Sorry, I don't know how to check other (CJK) Unicode blocks display properly. Can you tell me how?
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.