X
Tap here to go to the mobile version of the site.
An updated version of Firefox is available to address the issues with Add-ons disabled or fail to install on Firefox. You can download the update for your OS here: https://www.mozilla.org/firefox/new/ For Known Issues and Workarounds, please check out the update at https://support.mozilla.org/kb/add-ons-disabled-or-fail-to-install-firefox

Support Forum

Firefox won't automatically open .pls file

Posted

Using High Criteria Total Recorder, a job starts and downloads a file *.pls but Firefox will not permit it be automatically opened every time, the 'Do this automatically every time for files like this' is grayed out. Here is the link:

http://veniceclassicradio.eu/live1/128.pls

Using High Criteria Total Recorder, a job starts and downloads a file *.pls but Firefox will not permit it be automatically opened every time, the 'Do this automatically every time for files like this' is grayed out. Here is the link: http://veniceclassicradio.eu/live1/128.pls

Chosen solution

As a workaround, you can define a new content type using my extension here:

https://addons.mozilla.org/firefox/addon/content-type-fixer/

Here's how:

(1) Turn on listening by clicking its button (Zzzz disappears and a yellow burst appears on the button)

(2) Start the download again, you can cancel out of the Open/Save dialog

(3) Click the toolbar button and click Add/Edit Content Types

(4) A tab will appear with a table showing your download request. Click Add for the .pls file and assign a content-type (the fictitious one usually is fine).

The table will show that row is now obsolete. Ignore that.

You can close this tab.

(5) Try the download again and you should now be able to define a persistent behavior (check the box).

Does that work on yours?

You can disable the extension when you are not downloading .pls files. Click the button and then click Stop Listening/Clear Log.

Read this answer in context 1
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:64.0) Gecko/20100101 Firefox/64.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
17107 solutions 154497 answers

This file is send as a generic content type and in such a case it isn't possible to select this choice.

  • Content-Type application/octet-stream
This file is send as a generic content type and in such a case it isn't possible to select this choice. *Content-Type application/octet-stream
Was this helpful to you? 0
Quote

Question owner

The reply: "it isn't possible to select this choice" is unhelpful because Google Chrome permits a user to select 'this choice' for this file type. Sorry Firefox, this is lame of you and your agent who provided the answer.

The reply: "it isn't possible to select this choice" is unhelpful because Google Chrome permits a user to select 'this choice' for this file type. Sorry Firefox, this is lame of you and your agent who provided the answer.
Was this helpful to you? 0
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17107 solutions 154497 answers

Firefox needs a valid content-type send by the server for an automatic action. The file extension is only used as a fallback and in that case Firefox will offer to open the file in the default application for this file extension. This has always been the case and is done for security reasons because a website (or a post on a website) can easily spoof the file extension.

Firefox needs a valid content-type send by the server for an automatic action. The file extension is only used as a fallback and in that case Firefox will offer to open the file in the default application for this file extension. This has always been the case and is done for security reasons because a website (or a post on a website) can easily spoof the file extension. *https://support.mozilla.org/en-US/kb/change-firefox-behavior-when-open-file
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8326 solutions 68158 answers

Chosen Solution

As a workaround, you can define a new content type using my extension here:

https://addons.mozilla.org/firefox/addon/content-type-fixer/

Here's how:

(1) Turn on listening by clicking its button (Zzzz disappears and a yellow burst appears on the button)

(2) Start the download again, you can cancel out of the Open/Save dialog

(3) Click the toolbar button and click Add/Edit Content Types

(4) A tab will appear with a table showing your download request. Click Add for the .pls file and assign a content-type (the fictitious one usually is fine).

The table will show that row is now obsolete. Ignore that.

You can close this tab.

(5) Try the download again and you should now be able to define a persistent behavior (check the box).

Does that work on yours?

You can disable the extension when you are not downloading .pls files. Click the button and then click Stop Listening/Clear Log.

As a workaround, you can define a new content type using my extension here: https://addons.mozilla.org/firefox/addon/content-type-fixer/ Here's how: (1) Turn on listening by clicking its button (Zzzz disappears and a yellow burst appears on the button) (2) Start the download again, you can cancel out of the Open/Save dialog (3) Click the toolbar button and click Add/Edit Content Types (4) A tab will appear with a table showing your download request. Click Add for the .pls file and assign a content-type (the fictitious one usually is fine). The table will show that row is now obsolete. Ignore that. You can close this tab. (5) Try the download again and you should now be able to define a persistent behavior (check the box). Does that work on yours? You can disable the extension when you are not downloading .pls files. Click the button and then click Stop Listening/Clear Log.
Was this helpful to you? 1
Quote

Question owner

ThorntonTarr said

Using High Criteria Total Recorder, a job starts and downloads a file *.pls but Firefox will not permit it be automatically opened every time, the 'Do this automatically every time for files like this' is grayed out. Here is the link: http://veniceclassicradio.eu/live1/128.pls

Brilliant, this works perfectly. I understand the security aspect but it would have been easier to ask a security related exception question instead of this add-on. However, I am good to go. cheers

''ThorntonTarr [[#question-1247067|said]]'' <blockquote> Using High Criteria Total Recorder, a job starts and downloads a file *.pls but Firefox will not permit it be automatically opened every time, the 'Do this automatically every time for files like this' is grayed out. Here is the link: http://veniceclassicradio.eu/live1/128.pls </blockquote> Brilliant, this works perfectly. I understand the security aspect but it would have been easier to ask a security related exception question instead of this add-on. However, I am good to go. cheers
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.