X
Tap here to go to the mobile version of the site.

Support Forum

Firefox and Thunderbird no touchpad scrolling. Non-Mozilla works

Posted

Dell XPS Laptop with Synaptics touchpad on WIndows 7. Two finger touchpad page scrolling works outside of mozilla just fine. Tried restarting FF in safe mode but nothing changed.

Dell XPS Laptop with Synaptics touchpad on WIndows 7. Two finger touchpad page scrolling works outside of mozilla just fine. Tried restarting FF in safe mode but nothing changed.

Chosen solution

Hello parkker,

Would you try this : using RegEdit create a DWORD entry called "UseScrollCursor" and set its value to 0 (= zero) in :

[HKEY_LOCAL_MACHINE\SOFTWARE\Synaptics\SynTPEnh] "UseScrollCursor"=dword:00000000

If that doesn't make a difference, would you try this :

Type in the address bar about:config and press Enter (promise to be careful, if asked)

Type in the serach bar ui.trackpoint

and look for the preference :

ui.trackpoint_hack.enabled

and set its value to 1 (default is "-1")

Then close and restart Firefox.

Any luck  ?

Read this answer in context 1

Additional System Details

Application

  • Firefox 64.0.2
  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:64.0) Gecko/20100101 Firefox/64.0
  • Support URL: https://support.mozilla.org/1/firefox/64.0.2/WINNT/en-US/

Extensions

  • Adblock Plus 3.4.2 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}) (Inactive)
  • Easy Screenshot 3.57 (easyscreenshot@mozillaonline.com) (Inactive)
  • Forecastfox (fix version) 4.20 (forecastfox@s3_fix_version) (Inactive)
  • LastPass: Free Password Manager 4.21.0.4 (support@lastpass.com) (Inactive)
  • YouTube High Definition 63.1.5 ({7b1bf0b6-a1b9-42b0-b75d-252036438bdc}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics Family
  • adapterDescription2: NVIDIA GeForce GT 550M
  • adapterDeviceID: 0x0116
  • adapterDeviceID2: 0x1246
  • adapterDrivers: igdumd64 igd10umd64 igd10umd64 igdumdx32 igd10umd32 igd10umd32
  • adapterDrivers2: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterRAM: Unknown
  • adapterRAM2: 1024
  • adapterSubsysID: 05711028
  • adapterSubsysID2: 05711028
  • adapterVendorID: 0x8086
  • adapterVendorID2: 0x10de
  • contentUsesTiling: False
  • crashGuards: []
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: True
  • directWriteVersion: 6.1.7601.17514
  • driverDate: 7-19-2011
  • driverDate2: 5-17-2017
  • driverVersion: 8.15.10.2455
  • driverVersion2: 22.21.13.8233
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'blocked', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'blocked', u'message': u'Acceleration blocked by safe-mode', u'type': u'runtime'}], u'name': u'HW_COMPOSITING'}, {u'status': u'unavailable', u'description': u'Direct3D11 Compositing', u'log': [{u'status': u'unavailable', u'message': u'Hardware compositing is disabled', u'type': u'default'}], u'name': u'D3D11_COMPOSITING'}, {u'status': u'unavailable', u'description': u'Direct2D', u'log': [{u'status': u'unavailable', u'message': u'Direct2D requires Direct3D 11 compositing', u'type': u'default'}], u'name': u'DIRECT2D'}, {u'status': u'disabled', u'description': u'Direct3D11 hardware ANGLE', u'log': [{u'status': u'unavailable', u'message': u'D3D11 compositing is disabled', u'type': u'default'}, {u'status': u'disabled', u'message': u'D3D11 compositing is disabled', u'type': u'env'}], u'name': u'D3D11_HW_ANGLE'}, {u'status': u'blocked', u'description': u'GPU Process', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'blocked', u'message': u'Safe-mode is enabled', u'type': u'runtime'}], u'name': u'GPU_PROCESS'}, {u'status': u'unavailable', u'description': u'WebRender', u'log': [{u'status': u'opt-in', u'message': u'WebRender is an opt-in feature', u'type': u'default'}, {u'status': u'unavailable', u'message': u'ANGLE is disabled', u'type': u'runtime'}], u'name': u'WEBRENDER'}, {u'status': u'blocked', u'description': u'WebRender qualified', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'blocked', u'message': u'No qualified hardware', u'type': u'env'}], u'name': u'WEBRENDER_QUALIFIED'}, {u'status': u'blocked', u'description': u'Off Main Thread Painting', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'blocked', u'message': u'OMTP blocked by safe-mode', u'type': u'runtime'}], u'name': u'OMTP'}]}
  • info: {u'ApzWheelInput': 1, u'ApzDragInput': 1, u'ApzKeyboardInput': 1, u'ApzAutoscrollInput': 1, u'AzureFallbackCanvasBackend': u'cairo', u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'skia', u'AzureContentBackend': u'skia'}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • offMainThreadPaintEnabled: False
  • offMainThreadPaintWorkerCount: 0
  • usesTiling: False
  • webgl1DriverExtensions: -
  • webgl1Extensions: -
  • webgl1Renderer: WebGL is currently disabled.
  • webgl1Version: -
  • webgl1WSIInfo: -
  • webgl2DriverExtensions: -
  • webgl2Extensions: -
  • webgl2Renderer: WebGL is currently disabled.
  • webgl2Version: -
  • webgl2WSIInfo: -
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic
  • windowUsingAdvancedLayers: False

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
McCoy
  • Top 10 Contributor
468 solutions 4252 answers

Chosen Solution

Hello parkker,

Would you try this : using RegEdit create a DWORD entry called "UseScrollCursor" and set its value to 0 (= zero) in :

[HKEY_LOCAL_MACHINE\SOFTWARE\Synaptics\SynTPEnh] "UseScrollCursor"=dword:00000000

If that doesn't make a difference, would you try this :

Type in the address bar about:config and press Enter (promise to be careful, if asked)

Type in the serach bar ui.trackpoint

and look for the preference :

ui.trackpoint_hack.enabled

and set its value to 1 (default is "-1")

Then close and restart Firefox.

Any luck  ?

Hello parkker, Would you try this : using RegEdit create a DWORD entry called "UseScrollCursor" and set its value to 0 (= zero) in : [HKEY_LOCAL_MACHINE\SOFTWARE\Synaptics\SynTPEnh] "UseScrollCursor"=dword:00000000 If that doesn't make a difference, would you try this : Type in the address bar '''about:config''' and press Enter (promise to be careful, if asked) Type in the serach bar '''ui.trackpoint''' and look for the preference : '''ui.trackpoint_hack.enabled''' and set its value to '''1''' (default is "-1") Then close and restart Firefox. Any luck ?

Question owner

Hi McCoy you saved the day for me with that regedit entry! did not have to implement the second potential solution you mentioned. Been fighting this problem for awhile with no luck until now.

Warmest Regards,

parkker

Hi McCoy you saved the day for me with that regedit entry! did not have to implement the second potential solution you mentioned. Been fighting this problem for awhile with no luck until now. Warmest Regards, parkker

Modified by parkker

McCoy
  • Top 10 Contributor
468 solutions 4252 answers

I'm glad that worked - well done  !

I'm glad that worked - well done !
bon2x03 0 solutions 1 answers

McCoy said

Hello parkker, Would you try this : using RegEdit create a DWORD entry called "UseScrollCursor" and set its value to 0 (= zero) in : [HKEY_LOCAL_MACHINE\SOFTWARE\Synaptics\SynTPEnh] "UseScrollCursor"=dword:00000000 If that doesn't make a difference, would you try this : Type in the address bar about:config and press Enter (promise to be careful, if asked) Type in the serach bar ui.trackpoint and look for the preference : ui.trackpoint_hack.enabled and set its value to 1 (default is "-1") Then close and restart Firefox. Any luck  ?



Hi mozillians, I tried this solution for my Lenovo YOGA 710. At first it worked perfectly, but after I turned on my laptop again it did not work. As of posting, its still not working. I tried checking if the settings I changed in the browser and registry reverted but it did not. I tried opening similar websites in different browser and the websites just scrolled fine using the 2 finger gesture. Anybody had persistent issue like this? Thanks.

''McCoy [[#answer-1188340|said]]'' <blockquote> Hello parkker, Would you try this : using RegEdit create a DWORD entry called "UseScrollCursor" and set its value to 0 (= zero) in : [HKEY_LOCAL_MACHINE\SOFTWARE\Synaptics\SynTPEnh] "UseScrollCursor"=dword:00000000 If that doesn't make a difference, would you try this : Type in the address bar '''about:config''' and press Enter (promise to be careful, if asked) Type in the serach bar '''ui.trackpoint''' and look for the preference : '''ui.trackpoint_hack.enabled''' and set its value to '''1''' (default is "-1") Then close and restart Firefox. Any luck ? </blockquote> Hi mozillians, I tried this solution for my Lenovo YOGA 710. At first it worked perfectly, but after I turned on my laptop again it did not work. As of posting, its still not working. I tried checking if the settings I changed in the browser and registry reverted but it did not. I tried opening similar websites in different browser and the websites just scrolled fine using the 2 finger gesture. Anybody had persistent issue like this? Thanks.

Modified by bon2x03