X
Tap here to go to the mobile version of the site.

Support Forum

Shockwave games work in EDGE not in Firefox.

Posted

This url works in FireFox and in EDGE. http://www.shockwave.com/gamelanding/dailydiff.jsp These urls start and then stick on "Loading" http://www.shockwave.com/gamelanding/wordroundupfrenzy.jsp http://www.shockwave.com/gamelanding/picturiffic.jsp

In the attached screen image the blue bar blinks saying "Loading" I am using Windows 10 64 bit with Firefox 64.0. Checked for windows and Firefox updates. Updated Java. removed and reinstalled Shockwave and FlashPlayer. Removed and added Firefox to Windows Defender.

On this support page when I click the button to automatically add troubleshooting information, all the details disappear.

This url works in FireFox and in EDGE. http://www.shockwave.com/gamelanding/dailydiff.jsp These urls start and then stick on "Loading" http://www.shockwave.com/gamelanding/wordroundupfrenzy.jsp http://www.shockwave.com/gamelanding/picturiffic.jsp In the attached screen image the blue bar blinks saying "Loading" I am using Windows 10 64 bit with Firefox 64.0. Checked for windows and Firefox updates. Updated Java. removed and reinstalled Shockwave and FlashPlayer. Removed and added Firefox to Windows Defender. On this support page when I click the button to automatically add troubleshooting information, all the details disappear.
Attached screenshots

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:64.0) Gecko/20100101 Firefox/64.0

More Information

WestEnd 60 solutions 5387 answers

I don't see it saying "loading". So where are you seeing that?

Clicking from ff it says "Run Addobe"

And Edges says "Please Update/Enable Your Flash Player"

And my Flash are updateo date so wonder what kind custom Flash they are using? And my Flash and Shockwave are the up to date as well.

I don't see it saying "loading". So where are you seeing that? Clicking from ff it says "Run Addobe" And Edges says "Please Update/Enable Your Flash Player" And my Flash are updateo date so wonder what kind custom Flash they are using? And my Flash and Shockwave are the up to date as well.

Modified by WestEnd

Question owner

It says "Loading" in the blue bar of and on -- blinking.

It just did not snip at teh right time to see the words in the blue bar.

It says "Loading" in the blue bar of and on -- blinking. It just did not snip at teh right time to see the words in the blue bar.
James
  • Top 25 Contributor
  • Moderator
1600 solutions 11312 answers

ArtKendall said

I am using Windows 10 64 bit with Firefox 64.0. Checked for windows and Firefox updates. Updated Java. removed and reinstalled Shockwave and FlashPlayer.

Firefox since 52.0 and later including the current 64.0 only allows the Flash Player Plugin (may be refereed to by old name of Shockwave Flash) from Adobe to run in Firefox.

Other NPAPI Plugins like Java from Oracle and the Shockwave (for director) Player from Adobe will not run in Firefox. https://support.mozilla.org/en-US/kb/npapi-plugins

Only IE on Windows really allows the Java and Shockwave (for director) Player Plugins to run still.

''ArtKendall [[#question-1246104|said]]'' <blockquote> I am using Windows 10 64 bit with Firefox 64.0. Checked for windows and Firefox updates. Updated Java. removed and reinstalled Shockwave and FlashPlayer. </blockquote> Firefox since 52.0 and later including the current 64.0 only allows the Flash Player Plugin (may be refereed to by old name of Shockwave Flash) from Adobe to run in Firefox. Other NPAPI Plugins like Java from Oracle and the Shockwave (for director) Player from Adobe will not run in Firefox. https://support.mozilla.org/en-US/kb/npapi-plugins Only IE on Windows really allows the Java and Shockwave (for director) Player Plugins to run still.
jscher2000
  • Top 10 Contributor
8783 solutions 71816 answers

Thank goodness for the "mute" button! The word frenzy game does complete loading for me in Firefox 64.

If a site is generally known to work in Firefox, these are standard suggestions to try when it stops working normally:

Double-check content blockers: Firefox's Content Blocking feature and extensions that counter ads and tracking may break websites that embed third party content (meaning, from a secondary server).

(A) Do you see a shield icon toward the left end of the address bar, near the lock icon? More info on managing the Tracking Protection feature in this article: What happened to Tracking Protection?.

(B) Extensions such as Adblock Plus, Blur, Disconnect, Ghostery, NoScript, Privacy Badger, uBlock Origin or uMatrix should provide toolbar buttons to manage blocked content in a page. There may or may not be a number on the icon indicating the number of blocked items; you may need to click the button to see what's going on and test whether you need to make an exception for this site.

Cache and Cookies: When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click (on Mac Ctrl+click) a blank area of the page and choose View Page Info > Security > "Clear Cookies and Site Data"
  • (menu bar) Tools > Page Info > Security > "Clear Cookies and Site Data"
  • click the padlock or "i" icon in the address bar, then the ">" button, then More Information, and finally the "Clear Cookies and Site Data" button

In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites.

Then try reloading the page. Does that help?

Testing in Firefox's Safe Mode: In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

Thank goodness for the "mute" button! The word frenzy game does complete loading for me in Firefox 64. If a site is generally known to work in Firefox, these are standard suggestions to try when it stops working normally: '''Double-check content blockers:''' Firefox's Content Blocking feature and extensions that counter ads and tracking may break websites that embed third party content (meaning, from a secondary server). (A) Do you see a shield icon toward the left end of the address bar, near the lock icon? More info on managing the Tracking Protection feature in this article: [[Tracking Protection]]. (B) Extensions such as Adblock Plus, Blur, Disconnect, Ghostery, NoScript, Privacy Badger, uBlock Origin or uMatrix should provide toolbar buttons to manage blocked content in a page. There may or may not be a number on the icon indicating the number of blocked items; you may need to click the button to see what's going on and test whether you need to make an exception for this site. '''Cache and Cookies:''' When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site. (1) Clear Firefox's Cache See: [[How to clear the Firefox cache]] If you have a large hard drive, this might take a few minutes. (2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either: * right-click (on Mac Ctrl+click) a blank area of the page and choose View Page Info > Security > "Clear Cookies and Site Data" * (menu bar) Tools > Page Info > Security > "Clear Cookies and Site Data" * click the padlock or "i" icon in the address bar, then the ">" button, then More Information, and finally the "Clear Cookies and Site Data" button In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites. Then try reloading the page. Does that help? '''Testing in Firefox's Safe Mode:''' In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem. ''If Firefox is not running:'' Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.) ''If Firefox is running:'' You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" Help > Restart with Add-ons Disabled * (menu bar) Help menu > Restart with Add-ons Disabled and OK the restart. ''Both scenarios:'' A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Any improvement?
cor-el
  • Top 10 Contributor
  • Moderator
17564 solutions 158859 answers

The games load for me as well using the Shockwave Flash plugin.

I do see a notch on the Control Center 'i' icon indicating you have made some changes to default permissions. You can click the icon to see what permissions have been modified.

Maybe also check the permissions and storage for Flash via the Windows Control Panel.


You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox from this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data from that website will be saved once again.

The games load for me as well using the Shockwave Flash plugin. I do see a notch on the Control Center 'i' icon indicating you have made some changes to default permissions. You can click the icon to see what permissions have been modified. Maybe also check the permissions and storage for Flash via the Windows Control Panel. *https://www.macromedia.com/support/documentation/en/flashplayer/help/help02.html ---- You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History"). Using "Forget About This Site" will remove all data stored in Firefox from this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note. You can't recover from this 'forget' unless you have a backup of involved files. If you revisit a 'forgotten' website then data from that website will be saved once again. *https://support.mozilla.org/en-US/kb/delete-browsing-search-download-history-firefox