Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Google News rendering issues

  • 3 replies
  • 1 has this problem
  • 862 views
  • Last reply by jscher2000

more options

Hello community,

I am new to Firefox, well the last time I used it was before Chrome was introduced so its been a very long time coming. Google Chrome has been having serious issues for me lately and I was getting no help in their community forums, so after a Month of zero help I decided to try the new FF Quantum 63. However, after setting it up and trying my favorite Google News website I instantly discovered the first FF issue. All the text on the left is messed up. I tried Opera, Vivaldi, Chrome, Edge and all of those work just fine with Google News, but Firefox is broken somehow. I am hopeful its just a simple button I can click somewhere, but then again I know better. Below is the screen grab of how Firefox renders the page.

https://i.imgur.com/gqgTt9N.png

OS: Windows 10 1809 Brand new 2018 AMD Ryzen 5 2600X system with 16GB of ram. The only addons are Zoom Page ME, Stylus and FVD Speed Dial so far but more will need to be added.

Any ideas on how to fix this rendering issue? Or is Quantum just so new that it is still suffering from teething pains and I need to be patient?

Chosen solution

Hi SkOrPn, thanks for the screenshot.

What you're seeing are the text labels for missing icons. This can occur when the downloadable font used for those icons is blocked somehow.

This could be caused by Firefox not strictly following the fonts set by the page. You could check that setting here:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

A bit down the page under

Language and Appearance > Fonts & Colors

click the Advanced button. Make sure you have a checkmark in the box next to "Allow pages to choose their own fonts".

You might need to reload the page that isn't displaying correctly.

Was that it?

Read this answer in context 👍 1

All Replies (3)

more options

Chosen Solution

Hi SkOrPn, thanks for the screenshot.

What you're seeing are the text labels for missing icons. This can occur when the downloadable font used for those icons is blocked somehow.

This could be caused by Firefox not strictly following the fonts set by the page. You could check that setting here:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

A bit down the page under

Language and Appearance > Fonts & Colors

click the Advanced button. Make sure you have a checkmark in the box next to "Allow pages to choose their own fonts".

You might need to reload the page that isn't displaying correctly.

Was that it?

more options

@jscher2000,

Yes thank you that was it. So it was my error, not Firefox's.... VERY good news. Earlier today I was trying to match my settings from Chrome, and in order to be able to read anything on my 27" 1440p display I needed zoom level to be between 110-120% and fonts set to large. But Firefox doesn't seem to allow this natively defaulted, so my friend suggested I use a add-on to accomplish it called Zoom Page WE, and during that setup I unchecked that box thinking I needed to disallow websites to use their own fonts. So that was the issue. Thank you very much for your quick reply, that is better support than what I get at the Chrome support forums.

Best Regards Rod

Modified by SkOrPn

more options

Hi Rod, I'm glad to hear that worked, and "welcome home."