X
Tap here to go to the mobile version of the site.

Support Forum

Some webpages are not loading completely using Firefox, but loading just fine with Safari. Help, please?!

Posted

Certain websites will load partially in Firefox but some pieces will be missing (e.g. I click "sign in" on a website, and I get a mostly blank screen). It looks like the wepage is trying to load, at least in some instances (e.g. I'll see a header at the top of the page, but then it goes away after a second). Most vexing at the moment, part of the website I use to order items at work is not loading correctly. None of these issues exist while using Safari. I've tried: clearing history, mucking with the DNS settings, adjusting the proxy settings, re-installing Firefox. None of these seem to be fixing the problem, although reinstalling Firefox means that now one or two webpages now work correctly that didn't work previously (I think?). I would say that this started to happen after I updated to the latest version of Firefox, but can't be 100% sure of that. I'd really appreciate advice on how to get Firefox working again, since it is my preferred browser!

Certain websites will load partially in Firefox but some pieces will be missing (e.g. I click "sign in" on a website, and I get a mostly blank screen). It looks like the wepage is trying to load, at least in some instances (e.g. I'll see a header at the top of the page, but then it goes away after a second). Most vexing at the moment, part of the website I use to order items at work is not loading correctly. None of these issues exist while using Safari. I've tried: clearing history, mucking with the DNS settings, adjusting the proxy settings, re-installing Firefox. None of these seem to be fixing the problem, although reinstalling Firefox means that now one or two webpages now work correctly that didn't work previously (I think?). I would say that this started to happen after I updated to the latest version of Firefox, but can't be 100% sure of that. I'd really appreciate advice on how to get Firefox working again, since it is my preferred browser!

Chosen solution

Thanks for reporting which extension caused your issue.

Read this answer in context 0
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 31.0 r0

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:63.0) Gecko/20100101 Firefox/63.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
16995 solutions 153444 answers

Helpful Reply

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block (wanted) content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block (wanted) content.

Firefox shows the shield icon at the left end of the location/address bar in case Content Blocking is blocking content.

  • click the shield icon for more detail and possibly disable the protection

You can check the Web Console about what content is blocked


You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" from websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Manage Data

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block (wanted) content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block (wanted) content. *make sure your extensions and filters are updated to the latest version *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems Firefox shows the shield icon at the left end of the location/address bar in case Content Blocking is blocking content. *click the shield icon for more detail and possibly disable the protection You can check the Web Console about what content is blocked *"3-bar" menu button or Tools -> Web Developer *https://support.mozilla.org/en-US/kb/tracking-protection *https://support.mozilla.org/en-US/kb/content-blocking ---- You can try these steps in case of issues with web pages: You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files. *hold down the Shift key and left-click the Reload button *press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux) *press "Command + Shift + R" (Mac) Clear the Cache and remove the Cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences). "Remove the Cookies" from websites that cause problems: *Options/Preferences -> Privacy & Security<br>Cookies and Site Data -> Manage Data "Clear the Cache": *Options/Preferences -> Privacy & Security<br>Cookies and Site Data -> Clear Data -> Cached Web Content: Clear Start Firefox in <u>Safe Mode</u> to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if <u>hardware acceleration</u> is is causing the problem. *switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance *do NOT click the "Refresh Firefox" button on the Safe Mode start window *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems
Was this helpful to you? 1
Quote

Question owner

Re-starting Firefox in Safe mode fixed the problem. Thanks! A bit more mucking around suggests that it seems to be the Mind the Time add-on that is causing the problem. I guess I will have to look for another add-on that tracks how much time I spend on particular websites

Re-starting Firefox in Safe mode fixed the problem. Thanks! A bit more mucking around suggests that it seems to be the Mind the Time add-on that is causing the problem. I guess I will have to look for another add-on that tracks how much time I spend on particular websites
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
16995 solutions 153444 answers

Chosen Solution

Thanks for reporting which extension caused your issue.

Thanks for reporting which extension caused your issue.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.