Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

every firefox session ends with a new window with an erroneous whatsapp:// protocol url

  • 5 replies
  • 1 has this problem
  • 112 views
  • Last reply by FredMcD

more options

I tested a link in Firefox where the URL was started https://wa.me/123456789, which redirects to whatsapp://send?phone=123456789&text=&source=&data=. Of course, Firefox does not understand that protocol and displays the message "The address wasn’t understood". (Apparently Chrome does understand it - but that it NOT the point of my question.)

HOWEVER, since then, when every single session with Firefox is closed, a new Firefox window opens displaying once again the URL whatsapp://send?phone=123456789&text=&source=&data= and the message "The address wasn't understood".

I am trying to understand this bizarre, repetitive behavior and how to eliminate it.

Chosen solution

That's a new one on me. I called for more help.

Have you tried removing the sessionstore files?

Read this answer in context 👍 0

All Replies (5)

more options

Are you saying the page comes up when you close Firefox, or when you open it later?

You may have corrupt sessionstore [v56] sessionstore.jsonlz4 file(s). Delete all sessionstore* files and the sessionstore-backups folder.

Type about:support<enter> in the address bar.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Linux: Under the page logo on the left side, you will see Application Basics. Under this find Profile Directory. To its right press the button Open Directory.

Locate the above file. Then rename or delete it. Restart Firefox.

more options

The page comes up when I close Firefox, not when I open it.

more options

Chosen Solution

That's a new one on me. I called for more help.

Have you tried removing the sessionstore files?

more options

Removing the sessionstore files resolves the problem. But it would be nice to understand what caused it in the first place.

more options

I asked someone to look at this.