X
Tap here to go to the mobile version of the site.
An updated version of Firefox is available to address the issues with Add-ons disabled or fail to install on Firefox. You can download the update for your OS here: https://www.mozilla.org/firefox/new/ For Known Issues and Workarounds, please check out the update at https://support.mozilla.org/kb/add-ons-disabled-or-fail-to-install-firefox

Support Forum

How can I get me Firefox History browser to start saving pages again

Posted

Yesterday, my Firefox History browser stopped saving almost all pages. The only pages it does save are ones like this: Firefox pages. I have no idea why it's doing this; I haven't been doing anything differently. I'm using an old Macbook - Mac OS X 10.6.8 - if that's relevant. I'm like a 95-year-old from the early 90s when it comes to technology, so please dumb it way down. Thanks.

Yesterday, my Firefox History browser stopped saving almost all pages. The only pages it does save are ones like this: Firefox pages. I have no idea why it's doing this; I haven't been doing anything differently. I'm using an old Macbook - Mac OS X 10.6.8 - if that's relevant. I'm like a 95-year-old from the early 90s when it comes to technology, so please dumb it way down. Thanks.

Chosen solution

Thanks, man, but the problem has magically gone away on its own. I understand nothing. Thanks so much for the suggestions, though. I really appreciate your taking the time.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Displays Java applet content, or a placeholder if Java is not installed.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • Shockwave Flash 31.0 r0
  • 5.1.50901.0
  • iPhoto6

Application

  • Firefox 48.0.2
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:48.0) Gecko/20100101 Firefox/48.0
  • Support URL: https://support.mozilla.org/1/firefox/48.0.2/Darwin/en-US/

Extensions

  • Firefox Hello 1.4.4 (loop@mozilla.org)
  • Multi-process staged rollout 1.1 (e10srollout@mozilla.org)
  • Pocket 1.0.4 (firefox@getpocket.com)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription:
  • adapterDeviceID: 0x0863
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x10de
  • driverDate:
  • driverVersion:
  • info: {u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'skia'}
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: Yes
  • webglRenderer: NVIDIA Corporation -- NVIDIA GeForce 9400M OpenGL Engine
  • windowLayerManagerRemote: True
  • windowLayerManagerType: OpenGL

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
FredMcD
  • Top 10 Contributor
4076 solutions 56869 answers

Helpful Reply

See if this helps;

You may be in Private Browsing mode or told Firefox not to remember.

Type about:preferences#privacy<enter> in the address bar. The button next to History, select Use Custom Settings.

Turn off Always Use Private Browsing Mode Turn on Remember My Browsing And Download History At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on ONLY Cache and Form And Search History leaving the others off.

See if this helps; You may be in Private Browsing mode or told Firefox not to remember. Type '''about:preferences#privacy'''<enter> in the address bar. The button next to '''History, ''' select '''Use Custom Settings. ''' Turn off '''Always Use Private Browsing Mode''' Turn on '''Remember My Browsing And Download History''' At the bottom of the page, turn on '''Clear History When Firefox Closes. ''' At the far right, press the '''Settings''' button. Turn on ONLY '''Cache''' and '''Form And Search History''' leaving the others off.

Chosen Solution

Thanks, man, but the problem has magically gone away on its own. I understand nothing. Thanks so much for the suggestions, though. I really appreciate your taking the time.

Thanks, man, but the problem has magically gone away on its own. I understand nothing. Thanks so much for the suggestions, though. I really appreciate your taking the time.

Modified by froggs

FredMcD
  • Top 10 Contributor
4076 solutions 56869 answers

Good luck. If the problem returns. please post a new question.

Good luck. If the problem returns. please post a new question.