X
Tap here to go to the mobile version of the site.

Support Forum

Firefox Preferences menu : can only access General

Posted

Hi all,

I have Firefox 63.0.1 installed on my Mac and I'm unable to get to the submenus in the Preferences.

All I can access is Preferences > General.

Clicking on the the other submenus Home, Privacy and Security, etc. shows the appropriate link in the navbar (about:preferences#home, about:preferences#privacy) but it remains on the General screen.

I've tried disabling my add-ons (uBlock, htpps everywhere and a couple of others) and restarting the browser, but nothing changes.

As a result, at the moment I'm unable to access my privacy settings. Something I'd quite like to be able to do.

I also seem to be unable to upload screengrabs showing the menus. The spinning upload icon has been running for 2-3 minutes now for a 100K file...

Hi all, I have Firefox 63.0.1 installed on my Mac and I'm unable to get to the submenus in the Preferences. All I can access is Preferences > General. Clicking on the the other submenus Home, Privacy and Security, etc. shows the appropriate link in the navbar (about:preferences#home, about:preferences#privacy) but it remains on the General screen. I've tried disabling my add-ons (uBlock, htpps everywhere and a couple of others) and restarting the browser, but nothing changes. As a result, at the moment I'm unable to access my privacy settings. Something I'd quite like to be able to do. I also seem to be unable to upload screengrabs showing the menus. The spinning upload icon has been running for 2-3 minutes now for a 100K file...

Chosen solution

So, the initial Safe Mode approach didn't work.

I tried installing the version of Firefox from the link (which, weirdly, insisted the version installed on my Mac was a newer version). I then restarted, etc., and that didn't work either.

I uninstalled all my add-ons and tried again. That didn't work.

Finally, in desperation I tried Refresh when starting in Safe Mode (since I'd already removed all the add-ons and it saves bookmarks, and so on).

The Refresh approach worked.

Thanks again for your help.

Read this answer in context 0
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 31.0 r0

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:63.0) Gecko/20100101 Firefox/63.0

More Information

Question owner

It's now allowed me to upload a screengrab showing the problem.

It's now allowed me to upload a screengrab showing the problem.
Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
3765 solutions 52009 answers

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


If the above does not help,

Let’s do a full clean re-install;

Download Firefox For All languages And Systems {web link}

Save the file. Then Close Firefox.

Using your file browser, open the Programs Folder on your computer.

Windows: C:\Program Files C:\Program Files (x86)

Mac: Open the "Applications" folder. https://support.mozilla.org/en-US/kb/how-download-and-install-firefox-mac

Linux: Check your user manual. If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it. See Install Firefox on Linux; https://support.mozilla.org/en-US/kb/install-firefox-linux

If you downloaded and installed the binary package from the Firefox download page, simply remove the folder Firefox in your home directory. http://www.mozilla.org/firefox#desktop ++++++++++++++++++++++++++++ Look for, and remove any Mozilla or Firefox program folders. Do not remove the Mozilla Thunderbird folder if there is one.

Do Not remove any profile folders.

After rebooting the computer, run a registry scanner if you have one. Then run the installer. +++++++++++++++++++++++++++ If there is a problem, start your Computer in safe mode and try again.

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode This shows how to Start all Computers in Safe Mode; Free Online Encyclopedia

[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there? -------------- If the above does not help, Let’s do a full clean re-install; [http://www.mozilla.org/en-US/firefox/all/ Download Firefox For All languages And Systems] {web link} Save the file. Then '''Close Firefox. ''' Using your file browser, open the '''Programs Folder''' on your computer. '''Windows: ''' C:\Program Files C:\Program Files (x86) '''Mac: ''' Open the ''' "Applications" ''' folder. https://support.mozilla.org/en-US/kb/how-download-and-install-firefox-mac '''Linux: ''' Check your user manual. If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it. See Install Firefox on Linux; https://support.mozilla.org/en-US/kb/install-firefox-linux If you downloaded and installed the binary package from the Firefox download page, simply remove the folder Firefox in your home directory. http://www.mozilla.org/firefox#desktop ++++++++++++++++++++++++++++ Look for, and remove any '''Mozilla''' or '''Firefox''' program folders. Do not remove the '''Mozilla Thunderbird''' folder if there is one. '''Do Not''' remove any profile folders. After rebooting the computer, run a registry scanner if you have one. Then run the installer. +++++++++++++++++++++++++++ If there is a problem, start your '''Computer''' in safe mode and try again. http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode This shows how to Start all Computers in Safe Mode; Free Online Encyclopedia
Was this helpful to you?
Quote

Question owner

Thanks, FredMcD. I'll give those a try.

Thanks, FredMcD. I'll give those a try.
Was this helpful to you?
Quote

Chosen Solution

So, the initial Safe Mode approach didn't work.

I tried installing the version of Firefox from the link (which, weirdly, insisted the version installed on my Mac was a newer version). I then restarted, etc., and that didn't work either.

I uninstalled all my add-ons and tried again. That didn't work.

Finally, in desperation I tried Refresh when starting in Safe Mode (since I'd already removed all the add-ons and it saves bookmarks, and so on).

The Refresh approach worked.

Thanks again for your help.

So, the initial Safe Mode approach didn't work. I tried installing the version of Firefox from the link (which, weirdly, insisted the version installed on my Mac was a newer version). I then restarted, etc., and that didn't work either. I uninstalled all my add-ons and tried again. That didn't work. Finally, in desperation I tried Refresh when starting in Safe Mode (since I'd already removed all the add-ons and it saves bookmarks, and so on). The Refresh approach worked. Thanks again for your help.
Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
3765 solutions 52009 answers

That was very good work. Well done.

That was very good work. Well done.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.