X
Tap here to go to the mobile version of the site.

Support Forum

GitHub no longer supports old versions of Firefox

Posted

I am using Firefox 56 and getting this message

I wanted to post a workaround for any having same problem

using browser console

   Services.prefs.setCharPref('general.useragent.override', 'Mozilla (rv:32) Gecko/0 Firefox/59');
I am using Firefox 56 and getting this message I wanted to post a workaround for any having same problem using browser console Services.prefs.setCharPref('general.useragent.override', 'Mozilla (rv:32) Gecko/0 Firefox/59');

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0

More Information

WestEnd 60 solutions 5387 answers

Screenshot of the actual error message? GitHub is a open source software site.

Screenshot of the actual error message? GitHub is a open source software site.

Question owner

i am not posting a screenshot

anyone using firefox 58 or earlier can easily see the problem

i am not posting a screenshot anyone using firefox 58 or earlier can easily see the problem
WestEnd 60 solutions 5387 answers

svnpenn said

i am not posting a screenshot anyone using firefox 58 or earlier can easily see the problem

Then that isn't supported anymore to get help. One has to move to FF63.0.1 to get updated help.

''svnpenn [[#answer-1170605|said]]'' <blockquote> i am not posting a screenshot anyone using firefox 58 or earlier can easily see the problem </blockquote> Then that isn't supported anymore to get help. One has to move to FF63.0.1 to get updated help.
cor-el
  • Top 10 Contributor
  • Moderator
17541 solutions 158619 answers

Note that the 'rv' version and Firefox are normally set to the same Firefox version.

  • Services.prefs.setCharPref('general.useragent.override', ' Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0');

Another possibility is to override the user agent only for a specific domain to Firefox 59.

Note that the 'rv' version and Firefox are normally set to the same Firefox version. *Services.prefs.setCharPref('general.useragent.override', ' Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0'); Another possibility is to override the user agent only for a specific domain to Firefox 59. *general.useragent.override.github.com = (rv:|Firefox/)\d{2}#$159
James
  • Top 25 Contributor
  • Moderator
1598 solutions 11291 answers

cor-el said

Note that the 'rv' version and Firefox are normally set to the same Firefox version.

Good point as the "Mozilla (rv:32) Gecko/0 Firefox/59" is not a proper UA like "Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0" is.


WestEnd said

GitHub is a open source software site.

I would think the OP knows what GitHub is about in use.

WestEnd said

Then that isn't supported anymore to get help. One has to move to FF63.0.1 to get updated help.

Or you could pay attention to the OP in that the UA was not proper.

''cor-el [[#answer-1170839|said]]'' <blockquote> Note that the 'rv' version and Firefox are normally set to the same Firefox version. </blockquote> Good point as the "Mozilla (rv:32) Gecko/0 Firefox/59" is not a proper UA like "Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0" is. ''WestEnd [[#answer-1170604|said]]'' <blockquote> GitHub is a open source software site. </blockquote> I would think the OP knows what GitHub is about in use. ''WestEnd [[#answer-1170780|said]]'' <blockquote>Then that isn't supported anymore to get help. One has to move to FF63.0.1 to get updated help. </blockquote> Or you could pay attention to the OP in that the UA was not proper.