X
Tap here to go to the mobile version of the site.

Support Forum

'media.autoplay.enabled' setting no longer stops video auto-play (version 63.0).

Posted

Hi. I just noticed that my browser had auto-updated itself to version 63.0, and now, videos on Youtube and news sites auto-play, even though I have it disabled in About:Config. Until today, all html5 videos were being blocked just fine by that setting. Why is this happening and what can I do to re-block videos from auto-playing?

Hi. I just noticed that my browser had auto-updated itself to version 63.0, and now, videos on Youtube and news sites auto-play, even though I have it disabled in About:Config. Until today, all html5 videos were being blocked just fine by that setting. Why is this happening and what can I do to re-block videos from auto-playing?

Chosen solution

Hi maxquordlepleen, the settings have evolved.

The old media.autoplay.enabled preference has been replaced by several new ones. Let's give this a try:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste autop and pause while the list is filtered

To set your preferred behavior:

Block autoplay by default

  • Double-click the media.autoplay.default preference and set it to 1
  • *Edit* Some people suggest you also: Double-click the media.autoplay.allow-muted preference to switch the value from true to false

=> Does that work for you?

Allow autoplay by default (default for Release)

  • Double-click the media.autoplay.default preference and set it to 0 (or right-click > Reset)

Ask on a site-by-site basis (default for "Nightly")

  • Double-click the media.autoplay.default preference and set it to 2
  • Double-click the media.autoplay.ask-permission preference to switch the value from false to true
  • Double-click the media.autoplay.enabled.user-gestures-needed preference to switch the value from false to true

I'm sure we'll learn more about the interaction of these various preference and what sites can bypass them as more users begin to run Firefox 63.

Read this answer in context 5
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 31.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0

More Information

jscher2000
  • Top 10 Contributor
7921 solutions 64630 answers

Chosen Solution

Hi maxquordlepleen, the settings have evolved.

The old media.autoplay.enabled preference has been replaced by several new ones. Let's give this a try:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste autop and pause while the list is filtered

To set your preferred behavior:

Block autoplay by default

  • Double-click the media.autoplay.default preference and set it to 1
  • *Edit* Some people suggest you also: Double-click the media.autoplay.allow-muted preference to switch the value from true to false

=> Does that work for you?

Allow autoplay by default (default for Release)

  • Double-click the media.autoplay.default preference and set it to 0 (or right-click > Reset)

Ask on a site-by-site basis (default for "Nightly")

  • Double-click the media.autoplay.default preference and set it to 2
  • Double-click the media.autoplay.ask-permission preference to switch the value from false to true
  • Double-click the media.autoplay.enabled.user-gestures-needed preference to switch the value from false to true

I'm sure we'll learn more about the interaction of these various preference and what sites can bypass them as more users begin to run Firefox 63.

Hi maxquordlepleen, the settings have evolved. The old '''media.autoplay.enabled''' preference has been replaced by several new ones. Let's give this a try: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''autop''' and pause while the list is filtered To set your preferred behavior: '''''Block autoplay by default''''' * Double-click the '''media.autoplay.default''' preference and set it to '''1''' * *Edit* ''Some people suggest you also:'' Double-click the '''media.autoplay.allow-muted''' preference to switch the value from true to false => ''Does that work for you?'' '''''Allow autoplay by default''''' (default for Release) * Double-click the '''media.autoplay.default''' preference and set it to '''0''' (or right-click > Reset) '''''Ask on a site-by-site basis''''' (default for "Nightly") * Double-click the '''media.autoplay.default''' preference and set it to '''2''' * Double-click the '''media.autoplay.ask-permission''' preference to switch the value from false to true * Double-click the '''media.autoplay.enabled.user-gestures-needed''' preference to switch the value from false to true I'm sure we'll learn more about the interaction of these various preference and what sites can bypass them as more users begin to run Firefox 63.

Modified by jscher2000

Was this helpful to you? 5
Quote

Question owner

jscher2000, thank you! That worked.

I find it very annoying and disruptive, videos loading and browser settings evolving without permission.

If it ain't broke, don't fix it, Mozilla. Leave my bloody browser alone.

jscher2000, thank you! That worked. I find it very annoying and disruptive, videos loading and browser settings evolving without permission. If it ain't broke, don't fix it, Mozilla. Leave my bloody browser alone.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
16698 solutions 151028 answers

See also:

When these two prefs (or at least user-gestures-needed) are true then there is also a setting available in "Options/Preferences -> Privacy & Security -> Permissions" and you can inspect and modify the exceptions.

  • media.autoplay.enabled.user-gestures-needed = true
  • media.autoplay.ask-permission = true
See also: *https://support.mozilla.org/en-US/kb/block-autoplay When these two prefs (or at least user-gestures-needed) are true then there is also a setting available in "Options/Preferences -> Privacy & Security -> Permissions" and you can inspect and modify the exceptions. *media.autoplay.enabled.user-gestures-needed = true *media.autoplay.ask-permission = true

Modified by cor-el

Was this helpful to you? 1
Quote
jscher2000
  • Top 10 Contributor
7921 solutions 64630 answers

We can hope that work on this new site-permission-based approach will be completed soon, maybe by Firefox 64, so we'll have a section on the Options page to manage video, muted video, web audio, etc.

Meanwhile, would you be willing to mark my earlier reply as the solution? That will enable this thread for Google search so more users can find it without having to post a question.

We can hope that work on this new site-permission-based approach will be completed soon, maybe by Firefox 64, so we'll have a section on the Options page to manage video, muted video, web audio, etc. Meanwhile, would you be willing to mark [https://support.mozilla.org/questions/1238033#answer-1166388 my earlier reply] as the solution? That will enable this thread for Google search so more users can find it without having to post a question.
Was this helpful to you?
Quote

Helpful Reply

cor-el said

See also: When these two prefs (or at least user-gestures-needed) are true then there is also a setting available in "Options/Preferences -> Privacy & Security -> Permissions" and you can inspect and modify the exceptions.
  • media.autoplay.enabled.user-gestures-needed = true
  • media.autoplay.ask-permission = true

cor-el, thank you as well.

Wow! Why is 'media.autoplay.enabled.user-gestures-needed' not enabled by default?!

With vast array of security and privacy threats, intrusive ads, video ads (I detest those with a passion), sudden loud videos, plugins and other junk that litter the Web, and load without users' knowledge and/or permission, 'media.autoplay.enabled.user-gestures-needed' is exactly the kind of setting that should prominently displayed and easily accessible in Options and the File Menu, not buried away in the millions of config settings! Do the developers of this browser want things to auto-load for users without permission? I certainly don't.

I want all the best possible security settings visible without having to register and dig through forums and pages for these simple things.

In this era of ad-blocking, I'd've thought video blocking - with a click-to-play setting like Flashblock had - would be an obvious one to have high in the list of prorities for a decent Web browser. It's not asking for much.

''cor-el [[#answer-1166395|said]]'' <blockquote> See also: *https://support.mozilla.org/en-US/kb/block-autoplay When these two prefs (or at least user-gestures-needed) are true then there is also a setting available in "Options/Preferences -> Privacy & Security -> Permissions" and you can inspect and modify the exceptions. *media.autoplay.enabled.user-gestures-needed = true *media.autoplay.ask-permission = true </blockquote> '''cor-el, thank you as well.''' Wow! Why is 'media.autoplay.enabled.user-gestures-needed' not enabled by default?! With vast array of security and privacy threats, intrusive ads, video ads (I detest those with a passion), sudden loud videos, plugins and other junk that litter the Web, and load without users' knowledge and/or permission, 'media.autoplay.enabled.user-gestures-needed' is '''exactly''' the kind of setting that should '''prominently displayed''' and '''easily accessible''' in '''Options '''and the '''File Menu''', not buried away in the millions of config settings! Do the developers of this browser '''want''' things to auto-load for users without permission? '''I''' certainly don't. I want all the best possible security settings visible without having to register and dig through forums and pages for these simple things. In this era of ad-blocking, I'd've thought video blocking - with a click-to-play setting like Flashblock had - would be an obvious one to have high in the list of prorities for a decent Web browser. It's not asking for much.
Was this helpful to you? 1
Quote
cor-el
  • Top 10 Contributor
  • Moderator
16698 solutions 151028 answers

media.autoplay.enabled.user-gestures-needed is disabled by default in Firefox release versions and is currently only enabled in Firefox Nightly builds for testing. This usually indicates that the feature is still under development and not finished sufficiently for release builds.

<b>media.autoplay.enabled.user-gestures-needed</b> is disabled by default in Firefox release versions and is currently only enabled in Firefox Nightly builds for testing. This usually indicates that the feature is still under development and not finished sufficiently for release builds.
Was this helpful to you?
Quote
ander111 0 solutions 9 answers

Thanks for such a quick reply to this. It worked!

Thanks for such a quick reply to this. It worked!
Was this helpful to you?
Quote
Bacchus66 0 solutions 3 answers

jscher2000 said

The old media.autoplay.enabled preference has been replaced by several new ones. Let's give this a try: (1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. Block autoplay by default
  • Double-click the media.autoplay.default preference and set it to 1
  • *Edit* Some people suggest you also: Double-click the media.autoplay.allow-muted preference to switch the value from true to false
=> Does that work for you? Allow autoplay by default (default for Release)
  • Double-click the media.autoplay.default preference and set it to 0 (or right-click > Reset)
Ask on a site-by-site basis (default for "Nightly")
  • Double-click the media.autoplay.default preference and set it to 2
  • Double-click the media.autoplay.ask-permission preference to switch the value from false to true
  • Double-click the media.autoplay.enabled.user-gestures-needed preference to switch the value from false to true

So the settings change, that happens. After all there seems to be more specific different options now.

OTOH, why the hell can't the update to use the new setting be smart enough to note that I had the autoplay turned off under the old setting and use that, instead of defaulting to play for everyone? Or at least prompt me about it? Or possibly show the setting in the options screen?

Seriously, this kind of annoying crap is what is going to push people away from firefox to other browsers. Stupid user interface tricks and breaking existing preferences in new versions is just no way to enhance the user experience.

''jscher2000 [[#answer-1166388|said]]'' <blockquote> The old '''media.autoplay.enabled''' preference has been replaced by several new ones. Let's give this a try: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. '''''Block autoplay by default''''' * Double-click the '''media.autoplay.default''' preference and set it to '''1''' * *Edit* ''Some people suggest you also:'' Double-click the '''media.autoplay.allow-muted''' preference to switch the value from true to false => ''Does that work for you?'' '''''Allow autoplay by default''''' (default for Release) * Double-click the '''media.autoplay.default''' preference and set it to '''0''' (or right-click > Reset) '''''Ask on a site-by-site basis''''' (default for "Nightly") * Double-click the '''media.autoplay.default''' preference and set it to '''2''' * Double-click the '''media.autoplay.ask-permission''' preference to switch the value from false to true * Double-click the '''media.autoplay.enabled.user-gestures-needed''' preference to switch the value from false to true </blockquote> So the settings change, that happens. After all there seems to be more specific different options now. OTOH, why the hell can't the update to use the new setting be smart enough to note that I had the autoplay turned off under the old setting and use that, instead of defaulting to play for everyone? Or at least prompt me about it? Or possibly show the setting in the options screen? Seriously, this kind of annoying crap is what is going to push people away from firefox to other browsers. Stupid user interface tricks and breaking existing preferences in new versions is just no way to enhance the user experience.
Was this helpful to you? 1
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.