Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Autoplay

  • 2 replies
  • 2 have this problem
  • 26 views
  • Last reply by cor-el

more options

I have Auto play disabled, along with all options to disable Auto play even when sound is off! I understand Mozilla chose not to block all auto play videos and they have there reasons for that. I have tweaked a few settings in about:config, I cannot remember which ones though.

My issue is with some websites, YouTube being the main one I use. When I open a channels page sometimes the intro to there page Auto plays with sound. If I open the page in a new tab auto play will not happen. I have just checked.. Autoplay is not disabled if I am currently viewing a YouTube page and open a video.

So obviously YouTube is recognizing I am viewing the current page and is overriding any setting I have. YouTube will not auto-play any other videos only these intro videos on users home channel page.

I cannot seem to block YouTube videos Auto-playing on my android phone with Firefox, however that is a whole different issue.

What I want is a global option where I can stop ALL videos from Auto-playing until I press a play button. I know I am not alone in wanting this.

I have Auto play disabled, along with all options to disable Auto play even when sound is off! I understand Mozilla chose not to block all auto play videos and they have there reasons for that. I have tweaked a few settings in about:config, I cannot remember which ones though. My issue is with some websites, YouTube being the main one I use. When I open a channels page sometimes the intro to there page Auto plays with sound. If I open the page in a new tab auto play will not happen. I have just checked.. Autoplay is not disabled if I am currently viewing a YouTube page and open a video. So obviously YouTube is recognizing I am viewing the current page and is overriding any setting I have. YouTube will not auto-play any other videos only these intro videos on users home channel page. I cannot seem to block YouTube videos Auto-playing on my android phone with Firefox, however that is a whole different issue. What I want is a global option where I can stop ALL videos from Auto-playing until I press a play button. I know I am not alone in wanting this.

Modified by user1533805

All Replies (2)

more options

Try adjusting in media.autoplay.block-event.enabled to true about:config

more options

You can also check other media.autoplay prefs on the about:config page.

  • media.autoplay.default = 5
  • media.autoplay.enabled.user-gestures-needed = true

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.