Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Google search engine doesn't work anymore with newest Firefox version

more options

The same issue has already been discussed here:

Since this week I use Windows 10 (replacing Vista) and after a short while I could google anything through my Firefox browser. I just get a blank screen. So I've looked for solutions and I've followed the description below ( even seemed to work until the next update):

"Try to rename/remove search.json.mozlz4 in the Firefox profile folder with Firefox closed. You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page. • Help -> Troubleshooting Information -> Profile Directory: Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder • Boot the computer in Windows Safe mode with network support to see if that has effect in case security software (Avira) is causing problems. •"

Well, after the most recent update today, it is now obvious that this solution is of little use because the same problem has returned and "search.json.mozlz4 " has been reinstalled back in its place again.

I don't think it is a good practice if one has to remove the file again after every update.

So, what can be really done about this?


All Replies (20)

more options

The problem remains unsolved.

Any help in sight?


more options

sehnsuchtshfafen_fox said

The problem remains unsolved. Any help in sight? No?

Hello sehnsuchtsfafen_fox,

You say that you upgraded from Windows Vista to Windows 10 - according to your system details (to the right of your original post) you were using Vista when you posted this question. Can you confirm that  ?

Also : are you still using the ESR version of Firefox  ?

more options

I did the upgrade first on my laptop where the problem occured as described above. I've posted this issue on my at the time not yet upgraded PC.

Right after the laptop uprgade (ie. clean installation of W10) I've also installed the latest firefox version (not any older one).

The problem occurs with this newest firefox version as far as I can tell, and, automatic updates reverse the firefox profile, ie. the file "search.json.mozlz4" gets back in its place.

On last Sunday I've made a clean installation of W10 on my old PC (the one I'm using right now) and I've put every application on it, too. Today I've had this firefox/search engine issue again on this PC.

So, yes, I confirm, it happens on both, PC and Laptop, with W10 and the newest firefox.

Thanks McCoy for taking the time ansering me!

more options

Thank you for confirming that you now are using Windows 10.

But one more question remains unanswered though : Are you still using Firefox ESR version  ?

I'm asking, because your system details show that you have quite a few plugins installed, among which :

Google Update and : Google Updater plugin

And I wonder if those plugins might be causing this problem .....

(just a stab in the dark though ..... )

more options

sehnsuchtshfafen_fox said

The problem occurs with this newest firefox version as far as I can tell, and, automatic updates reverse the firefox profile, ie. the file "search.json.mozlz4" gets back in its place.

On that point: when Firefox starts up, if the search.json.mozlz4 file is missing, it will be rebuilt. Removing the file is only a way to flush bad data and start again.

If you are using the "Remove" button for built-in search engines -- the one below the "One off Search engines" box on the Options page -- it is not completely surprising for those to reappear after the next update. Instead of using Remove, you can hide them by clearing the check mark in the first column of the box.

more options


After Vista, no ESR anymore.

With W10 I went up to Quantum. I'm using Firefox Quantum 62.03 (32-bit) now.

I hope that does answer your question.

more options

sehnsuchtshfafen_fox said

@McCoy After Vista, no ESR anymore. With W10 I went up to Quantum. I'm using Firefox Quantum 62.03 (32-bit) now. I hope that does answer your question.

Yes, it sure does - thank you  !

Can't be any of those plugins then - oh well, it was just a stab in the dark .....

more options

Would you take a look at this please and see if maybe something there applies to your situation  ?

more options

@jscher2000 I'm not sure what you mean.

I don't have the intention to hide oder remove completely any of the search engines.

Usually, I use google.

I must admit that I don't even know what purpose the file "search.json.mozlz4" actually fullfills.

I've removed it in the profile folder because it has been suggested to those who have to deal with that problem.

more options

The search.json.mozlz4 file stores a list of your current Firefox search plugins, and which one is the default, and which of the others are enabled or disabled.

Of course, that is only for the address bar and other built-in search bars, and shouldn't affect what happens when you search on Google itself through their home page.

more options

@McCoy Thanks alot for the link, McCoy.

I'm checking it through. The problem hasn't reappeared so far. Just now, I'm running Malwarebytes.

It may take another day or two to report back to you as I'll have to see what happens next.

@jscher2000 Thank you very much for your input!

more options

sehnsuchtshfafen_fox said

@McCoy It may take another day or two to report back to you as I'll have to see what happens next.

Take all the time you need  !

Should the problem return, maybe you could try this :

But fingers crossed that everything's okay now ......

more options

I've checked the site you've linked above.

(By the way, at least one link there - YouTube - doesn't work anymore. So, the site seems a bit dated now.)

Malwarebytes detected 19 files on my PC and 18 on my laptop. I've deleted these right after the scan has been finished. But it didn't help to solve the search engine problem.

That problem reappeared after a couple of days.

Now, there is indeed a slightly better solution that is furthermore even a bit easier to handle than just eleminating "search.json.mozlz4"'" from time to time:

Clear the browser cache.

So, after I've got the blank search engine page again I've cleared the cache (shift + refresh page). And, the search results appeared.

This works for a moment until the next blank search page pops up. All you have to do is clearing the cache again. I think it's the best that can be done until a new firefox version gets offered that won't have this issue anymore.

The Google search egine problem reappears mostly after long working sesseions on firefox.

more options

As a footnote, a "hard" reload bypasses the cache for the current page: Ctrl+Shift+r or Shift+click the reload button.

more options

Latest update:

I'm using Firefox Quantum 63.0.1 (32-Bit) now.

And, the work around with shift+reload doesn't work anymore either.

It seems to me the latest update with Firefox made it even worse. Why aren't there other users reporting the same problem I have when I want to use the Google search engine?

I need better help to solve this. Thanks in advance.

more options

Hi sehnsuchtshfafen_fox, please update me on what happens with Google in Firefox 63 on Windows 10. This is my understanding, and my current questions:

Google searches work normally for a while, but then at some point searches you enter in the address bar give you a blank results page.

(A) Can you see a Google URL in the address bar at that point, or is the bar blank, or does the bar show a different site address?

(B) If you go to Google's home page, will it load? Can you submit searches from Google's home page or do you get blank results that way as well?

more options


Thanks for taking your time to look into this!

Google searches work normally for a while, but then at some point searches you enter in the address bar give you a blank results page.


To your questions A and B:

A) Yes, I can. Like this for example:

B) would load. But if you enter a search phrase, like this "windows fotoanzeige windows 10" , I receive a blank page with this URL:

I've just reproduced the exact same problem with this search I had yesterday: shift+reload doesn't work neither way A nor B.


Now, the crazy thing is this. Yesterday after I've posted here my concerns about shift+reload, maybe an hour afterwards, I could use the search engine normally even though I didn't do anything to solve the issue I had.

I have no explanation for this.

more options

Hmm, if it's not a stuck file in the cache, the other thing that comes to mind is Firefox getting a blank file back from the server (or from an intermediary such as security software). That could cause Firefox to halt loading/rendering the page. Some sites do that if they suspect they are under attack, but Google usually sends the "unusual activity" CAPTCHA screen if it is suspicious of what it receives, so it doesn't seem like Google to just cut you off.

I don't know whether to suggest trying the Network Monitor. That's a panel of Firefox's developer tools that shows all the requests Firefox makes in a tab and what kind of response was received from the server. You could take a look at it when Google is working normally, and then when it stops working, take another look at see what is different.

To open the Network Monitor it the lower part of the tab, you can use either:

  • "3-bar" menu button > Web Developer > Network
  • (menu bar) Tools > Web Developer > Network
  • (Windows) Ctrl+Shift+e

When you reload the page, Firefox should start listing all the files it is requesting, along with information about whether the request was successful. (Suggestions are interesting on Google, you see a new request each time a letter is added to or removed from the query text.)

More info:

more options

Thanks alot for your information.

I'll look into it.

Just out of curiosity I've tried the Google search engine with Edge and Chrome.

Edge with Google (search through their homepage) produces the exact same blank site as with Firefox Quantum, and, shift+reload doesn't work either. This problem can be reproduced multiple times.

Search through Chrome with Google works fine.

I suspect that my antivirus protection through Bitdefender could cause the problem. Could that be the case?

more options

Hi sehnsuchtshfafen_fox, I'm not very familiar with how Bitdefender works. There is a feature that intercepts all your browsing which you could try disabling. Another user posted steps to disabling the "man in the middle" function so that browsers can connect directly; I haven't tried this myself:

Changing this setting (in this case for Total Security 2018) was done from the Bitdefender menu as follows:
  1. Select Protection from the listing on the left-hand side.
  2. Under Protection Features locate the Online Threat Prevention box (middle column, bottom item). Select Settings.
  3. Under Online Threat Prevention ensure that the Web Protection listing option is selected in the heading.
  4. Use the button on the right-hand side to turn off the Encrypted Web Scan option (third item in listing).
If you try that, does it make any difference?
  1. 1
  2. 2