X
Tap here to go to the mobile version of the site.

Support Forum

Visited page links not changing color, how can I fix this in settings?

Posted

Yesterday a Dell support tech wiped my browser history and all my visited page links reverted to default blue, so I went and clicked on all the links again so they turned purple (which as some users have remarked, is not that different from the blue and so it is hard to tell if the linked text is purple or blue on my monitor sometimes depending on the viewing angle).

Anyway, I went to my saved searches on Google and Craigslist and started clicking thru the new links of unvisited pages and I think I accidentally hit open link in private window or something when I right clicked (I am not sure) but now although my visited page links from yesterday in Google and Craigslist remain purple, the newly clicked page links are not turning color, and I am not sure if this is due to some setting in my browser that got changed or if it is a Firefox bug.

How do I go about troubleshooting and seeing if I can fix this, so I can determine if this is a bug I need to report or if I can get it to work again? And if I do get it to work again, can I change the text color of the visited page links? Thank you.

FYI I am running latest Firefox on Windows 10 64-bit, fully up to date with all apps as of this morning.

Yesterday a Dell support tech wiped my browser history and all my visited page links reverted to default blue, so I went and clicked on all the links again so they turned purple (which as some users have remarked, is not that different from the blue and so it is hard to tell if the linked text is purple or blue on my monitor sometimes depending on the viewing angle). Anyway, I went to my saved searches on Google and Craigslist and started clicking thru the new links of unvisited pages and I think I accidentally hit open link in private window or something when I right clicked (I am not sure) but now although my visited page links from yesterday in Google and Craigslist remain purple, the newly clicked page links are not turning color, and I am not sure if this is due to some setting in my browser that got changed or if it is a Firefox bug. How do I go about troubleshooting and seeing if I can fix this, so I can determine if this is a bug I need to report or if I can get it to work again? And if I do get it to work again, can I change the text color of the visited page links? Thank you. FYI I am running latest Firefox on Windows 10 64-bit, fully up to date with all apps as of this morning.

Chosen solution

Firstly, if you want to change the color of the visited links, you do this from the Firefox options. Open the Firefox options, click the General tab and find the Language And Appearance section. Then click the Colors button in that section.

This allows you to change the default visited link color. However, some websites have their own styling settings that will override the Firefox defaults, so not every website will display the visited link in the color that you have selected.

Now on to your problem.

If you think that you have entered a Private Browsing session, close Firefox entirely and then when you reopen Firefox, it will be back in normal mode. Private Browsing mode doesn't save any of your browsing information, which could be why your new links are not changing colors.

Hope this helps.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 31.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:62.0) Gecko/20100101 Firefox/62.0

More Information

Wesley Branton
  • Top 10 Contributor
695 solutions 5507 answers

Chosen Solution

Firstly, if you want to change the color of the visited links, you do this from the Firefox options. Open the Firefox options, click the General tab and find the Language And Appearance section. Then click the Colors button in that section.

This allows you to change the default visited link color. However, some websites have their own styling settings that will override the Firefox defaults, so not every website will display the visited link in the color that you have selected.

Now on to your problem.

If you think that you have entered a Private Browsing session, close Firefox entirely and then when you reopen Firefox, it will be back in normal mode. Private Browsing mode doesn't save any of your browsing information, which could be why your new links are not changing colors.

Hope this helps.

Firstly, if you want to change the color of the visited links, you do this from the Firefox options. Open the Firefox options, click the General tab and find the Language And Appearance section. Then click the Colors button in that section. This allows you to change the default visited link color. However, some websites have their own styling settings that will override the Firefox defaults, so not every website will display the visited link in the color that you have selected. Now on to your problem. If you think that you have entered a Private Browsing session, close Firefox entirely and then when you reopen Firefox, it will be back in normal mode. Private Browsing mode doesn't save any of your browsing information, which could be why your new links are not changing colors. Hope this helps.

Question owner

Thank you! All good now.

Thank you! All good now.