X
Tap here to go to the mobile version of the site.

Support Forum

Error 500 when trying to login to addons.mozilla.org

Posted

When I try to login to addons.mozilla.org I reproducably land on an error message on two different computers using windows 10 as well as ubuntu.

How can I fix this?

{"detail":"Internal Server Error"}


That's the header of the json-file I am redirected to:

Allow: GET, HEAD, OPTIONS Connection: keep-alive Content-Length: 34 Content-Security-Policy: script-src https://ssl.google-analytics.com/ga.js https://www.google.com/recaptcha/ https://www.gstatic.com/recaptcha/ https://addons.cdn.mozilla.net; style-src 'self' 'unsafe-inline' https://addons.cdn.mozilla.net; object-src 'none'; default-src 'self'; frame-src 'self' https://www.google.com/recaptcha/; img-src 'self' data: blob: https://ssl.google-analytics.com https://addons.cdn.mozilla.net https://static.addons.mozilla.net https://sentry.prod.mozaws.net; media-src https://videos.cdn.mozilla.net; child-src 'self' https://www.google.com/recaptcha/; connect-src 'self' https://sentry.prod.mozaws.net; font-src 'self' https://addons.cdn.mozilla.net; form-action 'self' https://developer.mozilla.org; base-uri 'self' https://addons.mozilla.org; report-uri /__cspreport__ Content-Type: application/json Date: Wed, 03 Oct 2018 13:23:48 GMT ETag: "bbd4deea1890a5557c134bbe54595034" Server: nginx X-AMO-Read-Only: false X-AMO-Request-ID: da91334e87ca457896aa43ff102be2c0 X-Frame-Options: DENY strict-transport-security: max-age=31536000 x-content-type-options: nosniff x-xss-protection: 1; mode=block

Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8 Accept-Encoding: gzip, deflate, br Accept-Language: en-US,en;q=0.5 Connection: keep-alive DNT: 1 Host: addons.mozilla.org Referer: https://accounts.firefox.com/ Upgrade-Insecure-Requests: 1 User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:62.0) Gecko/20100101 Firefox/62.0

When I try to login to addons.mozilla.org I reproducably land on an error message on two different computers using windows 10 as well as ubuntu. How can I fix this? {"detail":"Internal Server Error"} That's the header of the json-file I am redirected to: Allow: GET, HEAD, OPTIONS Connection: keep-alive Content-Length: 34 Content-Security-Policy: script-src https://ssl.google-analytics.com/ga.js https://www.google.com/recaptcha/ https://www.gstatic.com/recaptcha/ https://addons.cdn.mozilla.net; style-src 'self' 'unsafe-inline' https://addons.cdn.mozilla.net; object-src 'none'; default-src 'self'; frame-src 'self' https://www.google.com/recaptcha/; img-src 'self' data: blob: https://ssl.google-analytics.com https://addons.cdn.mozilla.net https://static.addons.mozilla.net https://sentry.prod.mozaws.net; media-src https://videos.cdn.mozilla.net; child-src 'self' https://www.google.com/recaptcha/; connect-src 'self' https://sentry.prod.mozaws.net; font-src 'self' https://addons.cdn.mozilla.net; form-action 'self' https://developer.mozilla.org; base-uri 'self' https://addons.mozilla.org; report-uri /__cspreport__ Content-Type: application/json Date: Wed, 03 Oct 2018 13:23:48 GMT ETag: "bbd4deea1890a5557c134bbe54595034" Server: nginx X-AMO-Read-Only: false X-AMO-Request-ID: da91334e87ca457896aa43ff102be2c0 X-Frame-Options: DENY strict-transport-security: max-age=31536000 x-content-type-options: nosniff x-xss-protection: 1; mode=block Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8 Accept-Encoding: gzip, deflate, br Accept-Language: en-US,en;q=0.5 Connection: keep-alive DNT: 1 Host: addons.mozilla.org Referer: https://accounts.firefox.com/ Upgrade-Insecure-Requests: 1 User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:62.0) Gecko/20100101 Firefox/62.0

Additional System Details

Installed Plug-ins

happens with plugin disabled.

Application

  • Firefox 62.0.2
  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:62.0) Gecko/20100101 Firefox/62.0
  • Support URL: https://support.mozilla.org/1/firefox/62.0.2/WINNT/en-US/

Extensions

  • Disconnect 5.18.21 (2.0@disconnect.me) (Inactive)
  • Evernote Web Clipper 6.13.2 ({E0B8C461-F8FB-49b4-8373-FE32E9252800}) (Inactive)
  • Facebook Container 1.3.1 (@contain-facebook) (Inactive)
  • Feedly Subscribe Button 0.9.0 ({a8ffd15d-67d0-427f-80ad-07a7d76431e1}) (Inactive)
  • Firefox Multi-Account Containers 6.0.0 (@testpilot-containers) (Inactive)
  • Foxit PDF Creator 8.1.80 (FFExtnHTML2PDF@foxitsoftware.com) (Inactive)
  • Foxit PDF Creator 9.2.0.0 (FireFoxNew-WebExtensions@foxitsoftware.com) (Inactive)
  • I don't care about cookies 2.9.1 (jid1-KKzOGWgsW3Ao4Q@jetpack) (Inactive)
  • LastPass: Free Password Manager 4.17.1.7 (support@lastpass.com) (Inactive)
  • OneNote Web Clipper 3.8.0 (Clipper@OneNote.com) (Inactive)
  • uBlock Origin 1.17.0 (uBlock0@raymondhill.net) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics 530
  • adapterDescription2:
  • adapterDeviceID: 0x1912
  • adapterDeviceID2:
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igd12umd64 igdumdim32 igd10iumd32 igd10iumd32 igd12umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 00000000
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • clearTypeParameters: Gamma: 2,2 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 100
  • contentUsesTiling: False
  • crashGuards: []
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: True
  • directWriteVersion: 10.0.17763.1
  • driverDate: 9-3-2018
  • driverDate2:
  • driverVersion: 25.20.100.6319
  • driverVersion2:
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'blocked', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'blocked', u'message': u'Acceleration blocked by safe-mode', u'type': u'runtime'}], u'name': u'HW_COMPOSITING'}, {u'status': u'unavailable', u'description': u'Direct3D11 Compositing', u'log': [{u'status': u'unavailable', u'message': u'Hardware compositing is disabled', u'type': u'default'}], u'name': u'D3D11_COMPOSITING'}, {u'status': u'unavailable', u'description': u'Direct2D', u'log': [{u'status': u'unavailable', u'message': u'Direct2D requires Direct3D 11 compositing', u'type': u'default'}], u'name': u'DIRECT2D'}, {u'status': u'disabled', u'description': u'Direct3D11 hardware ANGLE', u'log': [{u'status': u'unavailable', u'message': u'D3D11 compositing is disabled', u'type': u'default'}, {u'status': u'disabled', u'message': u'D3D11 compositing is disabled', u'type': u'env'}], u'name': u'D3D11_HW_ANGLE'}, {u'status': u'blocked', u'description': u'GPU Process', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'blocked', u'message': u'Safe-mode is enabled', u'type': u'runtime'}], u'name': u'GPU_PROCESS'}, {u'status': u'unavailable', u'description': u'WebRender', u'log': [{u'status': u'opt-in', u'message': u'WebRender is an opt-in feature', u'type': u'default'}, {u'status': u'unavailable', u'message': u'ANGLE is disabled', u'type': u'runtime'}], u'name': u'WEBRENDER'}, {u'status': u'blocked', u'description': u'Off Main Thread Painting', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'blocked', u'message': u'OMTP blocked by safe-mode', u'type': u'runtime'}], u'name': u'OMTP'}]}
  • info: {u'ApzWheelInput': 1, u'ApzDragInput': 1, u'ApzKeyboardInput': 1, u'ApzAutoscrollInput': 1, u'AzureFallbackCanvasBackend': u'cairo', u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'skia', u'AzureContentBackend': u'skia'}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • offMainThreadPaintEnabled: False
  • offMainThreadPaintWorkerCount: 0
  • usesTiling: False
  • webgl1DriverExtensions: -
  • webgl1Extensions: -
  • webgl1Renderer: WebGL is currently disabled.
  • webgl1Version: -
  • webgl1WSIInfo: -
  • webgl2DriverExtensions: -
  • webgl2Extensions: -
  • webgl2Renderer: WebGL is currently disabled.
  • webgl2Version: -
  • webgl2WSIInfo: -
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic
  • windowUsingAdvancedLayers: False

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
WestEnd
  • Top 25 Contributor
61 solutions 5340 answers

Do you have adblocker installed? And what A/V are you using?

Do you have adblocker installed? And what A/V are you using?

Question owner

Sorry, could you please explain A/V? I too have the problem with all addons disabled and do-not-track off.

Sorry, could you please explain A/V? I too have the problem with all addons disabled and do-not-track off.
FFus3r 50 solutions 757 answers

scan your system with:

use malwarebytes in safe mode and normal mode.

scan your system with: * https://www.malwarebytes.com/ * https://www.malwarebytes.com/adwcleaner/ * https://www.hitmanpro.com/en-us/hmp.aspx '''use malwarebytes in safe mode and normal mode.'''
cor-el
  • Top 10 Contributor
  • Moderator
17352 solutions 156837 answers

This issue can be caused by corrupted cookies or cookies that are blocked.

Clear the Cache and remove the Cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" from websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Manage Data

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox from this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data from that website will be saved once again.

This issue can be caused by corrupted cookies or cookies that are blocked. *check the permissions for the domain in the currently selected tab in "Tools -> Page Info -> Permissions" *https://support.mozilla.org/en-US/kb/fix-login-issues-on-websites-require-passwords Clear the Cache and remove the Cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences). "Remove the Cookies" from websites that cause problems: *Options/Preferences -> Privacy & Security<br>Cookies and Site Data -> Manage Data "Clear the Cache": *Options/Preferences -> Privacy & Security<br>Cookies and Site Data -> Clear Data -> Cached Web Content: Clear ---- You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History"). Using "Forget About This Site" will remove all data stored in Firefox from this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note. You can't recover from this 'forget' unless you have a backup of involved files. If you revisit a 'forgotten' website then data from that website will be saved once again. *https://support.mozilla.org/en-US/kb/delete-browsing-search-download-history-firefox