X
Tap here to go to the mobile version of the site.

Support Forum

Password manager not asking to remember proxy password

Posted

Recently I had to reset my general domain password (organization is split between production and general domain\network without domain trust, proxy is part of general network, I'm part of production so we have to authenticate to proxy). I have to do this every 6 months. After this last change, and after I input my credentials, Firefox 62.0.3 (and 62.0.2) no longer pops-out the "remember my password" option. 1. Option "Ask to save logins and passwords for websites" is on 2. Proxy is not on the list of exceptions 3. Yes, I have removed old authentication from the list of "Saved Logins" 4. Yes "Firefox will remember my History" If I input my new username and password (which is asked only once during session), Firefox works just fine until I close it. Next time it starts, Firefox once again asks for username and password and do not offer to "remember" this credentials.

Thank you.

Recently I had to reset my general domain password (organization is split between production and general domain\network without domain trust, proxy is part of general network, I'm part of production so we have to authenticate to proxy). I have to do this every 6 months. After this last change, and after I input my credentials, Firefox 62.0.3 (and 62.0.2) no longer pops-out the "remember my password" option. 1. Option "Ask to save logins and passwords for websites" is on 2. Proxy is not on the list of exceptions 3. Yes, I have removed old authentication from the list of "Saved Logins" 4. Yes "Firefox will remember my History" If I input my new username and password (which is asked only once during session), Firefox works just fine until I close it. Next time it starts, Firefox once again asks for username and password and do not offer to "remember" this credentials. Thank you.

Chosen solution

So I can definitely confirm that the problem here was/is startup page. If I set any startup page (custom, eg. Google or corporate Intranet, or standard Firefox startup page ... something that initiates the proxy authentication screen to pop-up) other then the "blank" startup page, Firefox refuses to show the "Remember my password" pop-up. If I set as startup the "blank" page and browse to some site manually, after I input the proxy authentication Firefox displays "Remember my password" pop-up like a charm.

Well, if nothing else helps we know deleting the "AppData\Roaming\Mozilla" and "AppData\Local\Mozilla" directories will :-) ...

Once again, thank you all for trying to help.

Read this answer in context 0

Additional System Details

Installed Plug-ins

Trend Micro Osprey

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/69.0.3497.100 Safari/537.36

More Information

cor-el
  • Top 10 Contributor
  • Moderator
17564 solutions 158859 answers

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
Start Firefox in <u>Safe Mode</u> to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if <u>hardware acceleration</u> is is causing the problem. *switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance *do NOT click the "Refresh Firefox" button on the Safe Mode start window *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems

Question owner

Sorry "cor-el" I should have been more specific. I already tried starting Firefox in "Safe mode" (I tried it once again just now ... didn't help). I double checked my themes but only theme I have is "Default". I tried turning off "hardware acceleration" upon your suggestion but it didn't help ... that pesky "remember my password" pop-up is still not showing up ... darnit.

Should I try "refreshing Firefox" maybe? I know you said not to do that but I'm asking :-) ?

Sorry "cor-el" I should have been more specific. I already tried starting Firefox in "Safe mode" (I tried it once again just now ... didn't help). I double checked my themes but only theme I have is "Default". I tried turning off "hardware acceleration" upon your suggestion but it didn't help ... that pesky "remember my password" pop-up is still not showing up ... darnit. Should I try "refreshing Firefox" maybe? I know you said not to do that but I'm asking :-) ?

Modified by toofat

FredMcD
  • Top 10 Contributor
4265 solutions 59803 answers

Warning: There are some web pages that do not allow browsers to record or fill in the log-in information.

But if you go to the Mozilla Add-ons Web Page {web Link} (There’s a lot of good stuff here) you can also try a Form Filling add-on.

'''Warning: ''' There are some web pages that do not allow browsers to record or fill in the log-in information. But if you go to the [https://addons.mozilla.org/en-US/firefox/ Mozilla Add-ons Web Page] {web Link} (There’s a lot of good stuff here) you can also try a '''Form Filling''' add-on.
McCoy
  • Top 10 Contributor
545 solutions 5143 answers

If you hadn't tried Safe Mode, I would suggest to disable "Trend Micro Osprey " that you have installed, and see if that would make a difference ......

If you hadn't tried Safe Mode, I would suggest to disable "Trend Micro Osprey " that you have installed, and see if that would make a difference ......
cor-el
  • Top 10 Contributor
  • Moderator
17564 solutions 158859 answers

If you have the "Trend Micro Password Manager" installed then try to uninstall this application via the Windows Control Panel.

If you have the "Trend Micro Password Manager" installed then try to uninstall this application via the Windows Control Panel. *[/questions/1203487] why does saved passwords Check box keep turning off?

Question owner

To "FredMcD" ... as I have mantioned before, it's not web pages I have trouble with, it's the proxy server. Firefox pops-up "remember my password" dialog for web pages just fine. It's proxy server credentials I have trouble with.

To "McCoy" ... I have tried Safe Mode. Please follow the conversation.

To "cor-el" ... Isn't it the point of Safe Mode that it turns off all the plugins and addons? Why should I uninstall it if it is turned off in Safe Mode (just asking more data before I take the step you are suggesting, I don't mean no disrespect)?

Sorry "cor-el" I'm an idiot (because I do not read correctly). No, I do not have TrendMicro Password Manager installed. TrendMicro Osprey extension is a part of our corporate antivirus (TrendMicro OfficeScan). It is installed as a part of Firefox for couple of years and I didn't notice any problems.

Thank you.

P.S. I have disabled "TrendMicro Osprey" plugin and tried again ... it didn't help. I tried unloading the TrendMicro OfficeScan AV ... it didn't help. I have chacked one more time that the pop-up comes just fine for webpages ... yes it does. It's only proxy I have trouble with and it started happening somewhere between two password changes (so in the last 3 months ... I do not know what version of Firefox I had installed 3 months ago but I can tell you this ... my Firefox is always updated, always).

To "FredMcD" ... as I have mantioned before, it's not web pages I have trouble with, it's the proxy server. Firefox pops-up "remember my password" dialog for web pages just fine. It's proxy server credentials I have trouble with. To "McCoy" ... I have tried Safe Mode. Please follow the conversation. To "cor-el" ... Isn't it the point of Safe Mode that it turns off all the plugins and addons? Why should I uninstall it if it is turned off in Safe Mode (just asking more data before I take the step you are suggesting, I don't mean no disrespect)? Sorry "cor-el" I'm an idiot (because I do not read correctly). No, I do not have TrendMicro Password Manager installed. TrendMicro Osprey extension is a part of our corporate antivirus (TrendMicro OfficeScan). It is installed as a part of Firefox for couple of years and I didn't notice any problems. Thank you. P.S. I have disabled "TrendMicro Osprey" plugin and tried again ... it didn't help. I tried unloading the TrendMicro OfficeScan AV ... it didn't help. I have chacked one more time that the pop-up comes just fine for webpages ... yes it does. It's only proxy I have trouble with and it started happening somewhere between two password changes (so in the last 3 months ... I do not know what version of Firefox I had installed 3 months ago but I can tell you this ... my Firefox is always updated, always).

Modified by toofat

FredMcD
  • Top 10 Contributor
4265 solutions 59803 answers

https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). If the problem goes away, that tells us one thing. If it does not, that tells us something else.

https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). If the problem goes away, that tells us one thing. If it does not, that tells us something else.
FFus3r 50 solutions 757 answers

about:preferences > security > Logins

turn on Remember Logins. to check the passwords you have listed, press Saved Logins.

Is the information still there?

'''about:preferences''' > '''security''' > '''Logins''' turn on '''Remember Logins'''. to check the passwords you have listed, press '''Saved Logins'''. Is the information still there?

Question owner

To "FredMcD" ... please follow the conversation. All of this has been done already.

To "FFus3r" ... please, please follow the conversation. As I have stated in my first post 1. Option "Ask to save logins and passwords for websites" is on, 3. Yes, I have removed old authentication from the list of "Saved Logins.

To "FredMcD" ... please follow the conversation. All of this has been done already. To "FFus3r" ... please, please follow the conversation. As I have stated in my first post '''1. Option "Ask to save logins and passwords for websites" is on''', '''3. Yes, I have removed old authentication from the list of "Saved Logins'''.

Question owner

I wanted to say this ... I install Firefox, I do not use any addons on my work computer (where this is happening), I do not change the look and feel of the Firefox and my Firefox is always auto-updating to the latest version. So it is basicaly clean as it can be. I used Firefox on my work computer for like 12-13 years now.

P.S. And no, I do not have Flash installed. If I have to use Flash i open the Chrome browser (which is rare).

I wanted to say this ... I install Firefox, I do not use any addons on my work computer (where this is happening), I do not change the look and feel of the Firefox and my Firefox is always auto-updating to the latest version. So it is basicaly clean as it can be. I used Firefox on my work computer for like 12-13 years now. P.S. And no, I do not have Flash installed. If I have to use Flash i open the Chrome browser (which is rare).

Modified by toofat

McCoy
  • Top 10 Contributor
545 solutions 5143 answers

toofat said

To "McCoy" ... I have tried Safe Mode. Please follow the conversation.

I said :

" If you hadn't tried Safe Mode, I would suggest to disable "Trend Micro Osprey " that you have installed, and see if that would make a difference ...... "

''toofat [[#answer-1161585|said]]'' <blockquote> To "McCoy" ... I have tried Safe Mode. Please follow the conversation. </blockquote> I said : " If you '''hadn't tried''' Safe Mode, I would suggest to disable "Trend Micro Osprey " that you have installed, and see if that would make a difference ...... "

Question owner

To "McCoy" ... I'm sorry, I didn't mean no disrespect. Try to understand that English is not my native tongue and sometimes my statements may seem rude, but it was not done on purpose.

To "McCoy" ... I'm sorry, I didn't mean no disrespect. Try to understand that English is not my native tongue and sometimes my statements may seem rude, but it was not done on purpose.
McCoy
  • Top 10 Contributor
545 solutions 5143 answers

toofat said

To "McCoy" ... I'm sorry, I didn't mean no disrespect. Try to understand that English is not my native tongue and sometimes my statements may seem rude, but it was not done on purpose.

It's all good - no worries ......

''toofat [[#answer-1161594|said]]'' <blockquote> To "McCoy" ... I'm sorry, I didn't mean no disrespect. Try to understand that English is not my native tongue and sometimes my statements may seem rude, but it was not done on purpose. </blockquote> It's all good - no worries ......
FFus3r 50 solutions 757 answers

see this page:


if it dod'nt help then your problem caused by autocomplete=off , see this page:

see this page: * https://www.werockyourweb.com/force-firefox-save-password/ ---------------------------- if it dod'nt help then your problem caused by autocomplete=off , see this page: * https://www.squarefree.com/bookmarklets/forms.html#remember_password

Question owner

To "FFus3r" ... first link didn't help because there are no "*.jar" files in my "AppData\Roaming\Mozilla" or "AppData\Local\Mozilla" folder. ... second link would probably help if I had problems with pop-up not showing for web pages. But I have a problem with pop-up not showing for the proxy.

I hate the bloody pop-up. Why couldn't they just put in a nice little checkbox on the authentication screen? Never mind. I'm giving up. I'll reset Firefox and see if that helps. If not, well hello Google Chrome you ungodly peace of shit.

To "FFus3r" ... first link didn't help because there are no "*.jar" files in my "AppData\Roaming\Mozilla" or "AppData\Local\Mozilla" folder. ... second link would probably help if I had problems with pop-up not showing for web pages. But I have a problem with pop-up not showing for the proxy. I hate the bloody pop-up. Why couldn't they just put in a nice little checkbox on the authentication screen? Never mind. I'm giving up. I'll reset Firefox and see if that helps. If not, well hello Google Chrome you ungodly peace of shit.

Question owner

Well efing hooray. Refreshing Firefox didn't help but deleting "AppData\Roaming\Mozilla" and "AppData\Local\Mozilla" directories did. Don't ask me how I messed up but I definitely did. Well hooray idiot ... you broke it, you fixed it, Universe is at peace one more time and life can go on.

Thank you all for trying to help.

Well efing hooray. Refreshing Firefox didn't help but deleting "AppData\Roaming\Mozilla" and "AppData\Local\Mozilla" directories did. Don't ask me how I messed up but I definitely did. Well hooray idiot ... you broke it, you fixed it, Universe is at peace one more time and life can go on. Thank you all for trying to help.
McCoy
  • Top 10 Contributor
545 solutions 5143 answers

Before you say "Hello" to Google Chrome, would you give this a try :

Type in the address bar about:config and press Enter (promise to be careful, if asked)

Type in the search bar and look for the preference :

network.automatic-ntlm-auth.allow-proxies

and set its value to false

Type in the search bar and look for the preference :

network.negotiate-auth.allow-proxies

and set its value to false

Then close and restart Firefox.

Does that work  ?

Before you say "Hello" to Google Chrome, would you give this a try : Type in the address bar '''about:config''' and press Enter (promise to be careful, if asked) Type in the search bar and look for the preference : '''network.automatic-ntlm-auth.allow-proxies''' and set its value to '''false''' Type in the search bar and look for the preference : '''network.negotiate-auth.allow-proxies''' and set its value to '''false''' Then close and restart Firefox. Does that work ?
McCoy
  • Top 10 Contributor
545 solutions 5143 answers

And while I was typing my post, you found the solution .....

Well done, you  !

And while I was typing my post, you found the solution ..... Well done, you !
FredMcD
  • Top 10 Contributor
4265 solutions 59803 answers

That was very good work. Well done.

That was very good work. Well done.

Question owner

To "McCoy" ... the more I think about it the more it seems to me the startup page was the problem. Why? When I deleted the dirs the Firefox was setup to open the "Firefox startup page" which was presenting proxy authentication screens. I input my credentials and nothing, no bloody pop-up. I go to setup and set the startup page as "blank" which I never did before (usually it is setup to "Google" or our corporate Intranet page, which depends on how I feel or how much I hate working for my company that day when I setup the Firefox, don't ask me why). So after the initial setup I restarted the Firefox. Because the startup page was "blank" no proxy authentication screen showed up during startup. I then browse to Google and proxy authentication page popped-up and after that bloody "Remember my password" pop-up finally decided to present it's ugly face. Hooray. I'm at my flat now so I will test my theory tomorrow. I will delete the proxy authentication and try to recreate the process but with the startup screen setup to Google (or something which requires proxy authentication during startup phase of Firefox).

P.S. When it comes to proxies and the authentication screens in Firefox, I have to setup the config as: "network.auth.force-generic-ntlm" to True "signon.autologin.proxy" to True If I don't do that the bloody proxy authentication screen shows like 5 or 6 times during the startup process.

So what I'm basically saying is, if my theory doesn't work I will try (tomorrow) setting up: "network.automatic-ntlm-auth.allow-proxies" to False "network.negotiate-auth.allow-proxies" to False and I will get back to you with results.

Have a nice day.

To "McCoy" ... the more I think about it the more it seems to me the startup page was the problem. Why? When I deleted the dirs the Firefox was setup to open the "Firefox startup page" which was presenting proxy authentication screens. I input my credentials and nothing, no bloody pop-up. I go to setup and set the startup page as "blank" which I never did before (usually it is setup to "Google" or our corporate Intranet page, which depends on how I feel or how much I hate working for my company that day when I setup the Firefox, don't ask me why). So after the initial setup I restarted the Firefox. Because the startup page was "blank" no proxy authentication screen showed up during startup. I then browse to Google and proxy authentication page popped-up and after that bloody "Remember my password" pop-up finally decided to present it's ugly face. Hooray. I'm at my flat now so I will test my theory tomorrow. I will delete the proxy authentication and try to recreate the process but with the startup screen setup to Google (or something which requires proxy authentication during startup phase of Firefox). P.S. When it comes to proxies and the authentication screens in Firefox, I have to setup the config as: "network.auth.force-generic-ntlm" to True "signon.autologin.proxy" to True If I don't do that the bloody proxy authentication screen shows like 5 or 6 times during the startup process. So what I'm basically saying is, if my theory doesn't work I will try (tomorrow) setting up: "network.automatic-ntlm-auth.allow-proxies" to False "network.negotiate-auth.allow-proxies" to False and I will get back to you with results. Have a nice day.

Modified by toofat