X
Tap here to go to the mobile version of the site.

Support Forum

Firefox keep asking username and password for proxy authentication

Posted

My network is using proxy to get connected to internet. User authenticate to proxy using username and password from Active Directory. I am unable to authenticate to proxy, it keep asking password even I have supplied the correct password. I tested the condition using other browser and it works with Chromium. How should I connect to the proxy ?

Attached the pop-up

My network is using proxy to get connected to internet. User authenticate to proxy using username and password from Active Directory. I am unable to authenticate to proxy, it keep asking password even I have supplied the correct password. I tested the condition using other browser and it works with Chromium. How should I connect to the proxy ? Attached the pop-up
FredMcD
  • Top 10 Contributor
4220 solutions 58911 answers

Helpful Reply

Hello,

In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see How do I create a screenshot of my problem?

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. This will help us to visualize the problem.

Thank you!

Hello, In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see [[How do I create a screenshot of my problem?]] Once you've done this, attach the saved screenshot file to your forum post by clicking the '''Browse...''' button below the ''Post your reply'' box. This will help us to visualize the problem. Thank you!
FredMcD
  • Top 10 Contributor
4220 solutions 58911 answers

Are you clearing the data when the browser closes?

Are you clearing the data when the browser closes?

Helpful Reply

Hi FredMcD,

Thanks for the prompt response, ok these are the env: I am using Mozilla Firefox for Ubuntu 55.0.2 (64bit) Running on Ubuntu 16.04 64bit. My network using proxy with authentication for accessing internet username : csn\firmansyah password : BakeryTower

I have try enter the credential either by system wide or manually in firefox connection settings (advance preference tab)

I have try refresh the firefox by deleting .mozilla directory on my home directory (/home/firmansyah/.mozilla) but still no luck.

I also try googling for the past few days, and there's no similar problem before

Btw I re-attached the image, hope it working now

Hi FredMcD, Thanks for the prompt response, ok these are the env: I am using Mozilla Firefox for Ubuntu 55.0.2 (64bit) Running on Ubuntu 16.04 64bit. My network using proxy with authentication for accessing internet username : csn\firmansyah password : BakeryTower I have try enter the credential either by system wide or manually in firefox connection settings (advance preference tab) I have try refresh the firefox by deleting .mozilla directory on my home directory (/home/firmansyah/.mozilla) but still no luck. I also try googling for the past few days, and there's no similar problem before Btw I re-attached the image, hope it working now

Modified by firmanium

FredMcD
  • Top 10 Contributor
4220 solutions 58911 answers

I called for more help.

https://support.mozilla.org/en-US/kb/update-firefox-latest-version?cache=no Update Firefox to the latest version 55.0.3

I called for more help. https://support.mozilla.org/en-US/kb/update-firefox-latest-version?cache=no Update Firefox to the latest version '''55.0.3'''

Question owner

Currently I am running Firefox 55.0.2 so I have to wait until Canonical release the Ubuntu package update. But meanwhile I have checked the release notes and it seems like nothing related to proxy on the bug fix. I am gonna wait, let see if it's working

Thank you very much

Currently I am running Firefox 55.0.2 so I have to wait until Canonical release the Ubuntu package update. But meanwhile I have checked the release notes and it seems like nothing related to proxy on the bug fix. I am gonna wait, let see if it's working Thank you very much
cor-el
  • Top 10 Contributor
  • Moderator
17412 solutions 157274 answers

You can check this setting:

  • Options/Preferences -> Advanced -> Network: Connection -> Settings:

"Do not prompt for authentication if password is saved" (about:config -> signon.autologin.proxy = true)

You can also look at prefs like these:

network.automatic-ntlm-auth.allow-proxies = false
network.auth.use-sspi = false
network.proxy.share_proxy_settings = false
network.negotiate-auth.allow-proxies = false
You can check this setting: *Options/Preferences -> Advanced -> Network: Connection -> Settings: "Do not prompt for authentication if password is saved" (about:config -> signon.autologin.proxy = true) You can also look at prefs like these: network.automatic-ntlm-auth.allow-proxies = false network.auth.use-sspi = false network.proxy.share_proxy_settings = false network.negotiate-auth.allow-proxies = false

Question owner

Hi cor-el,

Thanks for your help, but it still doesn't work I have re-reset the firefox and test it with your configuration. I have change the config except for "network.auth.use-sspi", it's for Windows OS (http://kb.mozillazine.org/Network.auth.use-sspi#Has_an_effect_in). I am running Ubuntu 16.04 64bit.

Thank you very much

Hi cor-el, Thanks for your help, but it still doesn't work I have re-reset the firefox and test it with your configuration. I have change the config except for "network.auth.use-sspi", it's for Windows OS (http://kb.mozillazine.org/Network.auth.use-sspi#Has_an_effect_in). I am running Ubuntu 16.04 64bit. Thank you very much
adeade11 0 solutions 2 answers

how can i have access to mozproxy ?

how can i have access to mozproxy ?