X
Tap here to go to the mobile version of the site.

Support Forum

Browser console window appears in front of home page when I open FF.

Posted

It just floats there until I close it, button upper left of console. I am not a developer but I followed the instructions to fix this, as posted in here a year ago (almost exactly). The instruction to "right click" is irrelevant ... what to click? there is a list of hundreds of entries, some default, many modified. I haven't modified anything, I swear. Started about a week ago, update before last (last was within last 36 hours).

It just floats there until I close it, button upper left of console. I am not a developer but I followed the instructions to fix this, as posted in here a year ago (almost exactly). The instruction to "right click" is irrelevant ... what to click? there is a list of hundreds of entries, some default, many modified. I haven't modified anything, I swear. Started about a week ago, update before last (last was within last 36 hours).

Modified by candancie

Chosen solution

Hmm, that's strange. Is it the "Browser Console" or the whole Developer Tools panel (which usually is docked to the bottom of the tab but can be set to float separately)?

Two thoughts:

(1) Is there anything strange in your home page setting? Firefox lets you list multiple addresses; I don't know of an address for the console, but it's worth a quick look.

You can check that here:

  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the left column, click Home.

Then on the right side, if you have "Custom URLs" selected, check the URL(s) in the box. A vertical bar (|) separates the text into multiple addresses, for example:

https://www.apple.com/|https://www.mozilla.org/

Anything strange there?

(2) Could any of your add-ons be the culprit?

You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Command+Shift+a (Windows: Ctrl+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions.

Then cast a critical eye over the list on the right side. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything suspicious or that you just do not remember installing or why? If in doubt, disable (or remove).

Any improvement?

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 31.0 r0

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:62.0) Gecko/20100101 Firefox/62.0

More Information

Question owner

GOLDANGIT, WHERE'S THE DELETE?? today I hate the internet

sorry, I meant "button upper left of console."

GOLDANGIT, WHERE'S THE DELETE?? today I hate the internet sorry, I meant "button upper left of console."

Modified by candancie

jscher2000
  • Top 10 Contributor
8640 solutions 70690 answers

Chosen Solution

Hmm, that's strange. Is it the "Browser Console" or the whole Developer Tools panel (which usually is docked to the bottom of the tab but can be set to float separately)?

Two thoughts:

(1) Is there anything strange in your home page setting? Firefox lets you list multiple addresses; I don't know of an address for the console, but it's worth a quick look.

You can check that here:

  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the left column, click Home.

Then on the right side, if you have "Custom URLs" selected, check the URL(s) in the box. A vertical bar (|) separates the text into multiple addresses, for example:

https://www.apple.com/|https://www.mozilla.org/

Anything strange there?

(2) Could any of your add-ons be the culprit?

You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Command+Shift+a (Windows: Ctrl+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions.

Then cast a critical eye over the list on the right side. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything suspicious or that you just do not remember installing or why? If in doubt, disable (or remove).

Any improvement?

Hmm, that's strange. Is it the "Browser Console" or the whole Developer Tools panel (which usually is docked to the bottom of the tab but can be set to float separately)? Two thoughts: (1) Is there anything strange in your home page setting? Firefox lets you list multiple addresses; I don't know of an address for the console, but it's worth a quick look. You can check that here: * Mac: "3-bar" menu button (or Firefox menu) > Preferences * Windows: "3-bar" menu button (or Tools menu) > Options * Linux: "3-bar" menu button (or Edit menu) > Preferences * Any system: type or paste '''about:preferences''' into the address bar and press Enter/Return to load it In the left column, click Home. Then on the right side, if you have "Custom URLs" selected, check the URL(s) in the box. A vertical bar (|) separates the text into multiple addresses, for example: https://www.apple.com/|https://www.mozilla.org/ Anything strange there? (2) Could any of your add-ons be the culprit? You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either: * Command+Shift+a (Windows: Ctrl+Shift+a) * "3-bar" menu button (or Tools menu) > Add-ons * type or paste '''about:addons''' in the address bar and press Enter/Return In the left column of the Add-ons page, click Extensions. Then cast a critical eye over the list on the right side. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything suspicious or that you just do not remember installing or why? If in doubt, disable (or remove). Any improvement?

Question owner

Hi! it is 'BROWSER CONSOLE." I never open anything that says developer because I am afraid to. :D

I have not changed or added anything deliberately ... the only add on I see is Data Selfie and frankly I don't understand THAT; forget why I added it. That was months ago. This floating window is new.

btw I am on Mac OS 10.10.5; the laptop is probably close to 6 years old. Tech suggests updating the OS further would be problematic.

I DID go to preferences. Nothing strange there. My home page is FB. Nothing under custom URLs. A lot is on default settings. I don't use my phone for any of this; it's all laptop.

I will try to get a screen shot tomorrow when I come online. Maybe that will help. I will mention also that since the update when the window appeared, the few games I play are wackadoo on Firefox: WWF and Candy Crush Saga (please don't judge me). I have to go to Safara now and I hate Safari.

Thank you for such a detailed response.

Hi! it is 'BROWSER CONSOLE." I never open anything that says developer because I am afraid to. :D I have not changed or added anything deliberately ... the only add on I see is Data Selfie and frankly I don't understand THAT; forget why I added it. That was months ago. This floating window is new. btw I am on Mac OS 10.10.5; the laptop is probably close to 6 years old. Tech suggests updating the OS further would be problematic. I DID go to preferences. Nothing strange there. My home page is FB. Nothing under custom URLs. A lot is on default settings. I don't use my phone for any of this; it's all laptop. I will try to get a screen shot tomorrow when I come online. Maybe that will help. I will mention also that since the update when the window appeared, the few games I play are wackadoo on Firefox: WWF and Candy Crush Saga (please don't judge me). I have to go to Safara now and I hate Safari. Thank you for such a detailed response.

Modified by candancie

Question owner

Okay, I throw up my hands. I went in, removed my ONE add-on, Data Selfie. Shut browser down, waited a couple, opened up FF again and ... browser console window is gone. *pfft*

Thanks again. Perhaps I will be back. Perhaps not. You rock. Have a good extended sequence of diurnal periods. :D

Okay, I throw up my hands. I went in, removed my ONE add-on, Data Selfie. Shut browser down, waited a couple, opened up FF again and ... browser console window is gone. *pfft* Thanks again. Perhaps I will be back. Perhaps not. You rock. Have a good extended sequence of diurnal periods. :D
jscher2000
  • Top 10 Contributor
8640 solutions 70690 answers

Helpful Reply

I can't say for sure why Data Selfie had that side effect, but maybe it is not fully compatible with Firefox 62. If you can't remember why you have it, you might not need it any more. If you do want to use it again, you could try reaching out to the developer through any available links on the Add-ons site.

I can't say for sure why Data Selfie had that side effect, but maybe it is not fully compatible with Firefox 62. If you can't remember why you have it, you might not need it any more. If you do want to use it again, you could try reaching out to the developer through any available links on the Add-ons site.

Question owner

JScher, today I am again WITHOUT the floating window! All I did was that removal. And just poke around a little, not changing anything. Thanks again for your help, so clearly expressed. Who knows why/what? I keep my online behavior pretty simple but if I need help again with firefox, you are my go-to.

JScher, today I am again WITHOUT the floating window! All I did was that removal. And just poke around a little, not changing anything. Thanks again for your help, so clearly expressed. Who knows why/what? I keep my online behavior pretty simple but if I need help again with firefox, you are my go-to.