X
Tap here to go to the mobile version of the site.

Support Forum

Avast decided to remove the language resource pack (English GB, unsure if correct term), now Firefox boots as a white panel with <window id="main-window" ^

Posted

Hi Guys,

(I'm not too well versed with the intricacies of how Firefox works under the hood, so please bear with).

Yesterday, on opening Firefox, Avast (virus protection software) browser cleanup tool stated that the Language resource pack (this was yesterday, so I'm not sure if that's quite the correct term) was disreputable (2/5 stars). Avast said I should remove it, so I did (yes, I probably should've checked, but I was in a hurry).

Firefox was running perfectly fine before, but now only boots as an unresponsive white panel with <window (i="" <="" ^="" a="" an="" at="" attach="" ball).="" bordered="" box="" but="" doesn't="" id="main-window" image,="" in="" p="" play="" red="" seem="" text="" the="" to="" top.="" uploader="" want="" would=""></window>

Avast states on their website that removing an addon deletes it and the process cannot be undone.

I have tried uninstalling and reinstalling Firefox multiple times (with restarts) with no change, even with the 'remove addons and reset to default' checked.

I can't give you troubleshooting information because Firefox remains an unresponsive white panel - no addons, no toolbars to select 'help' from.

Any ideas? Please let me know if there's any other information you need to help fix this problem, I'd really like my favourite browser back!

Hi Guys, (I'm not too well versed with the intricacies of how Firefox works under the hood, so please bear with). Yesterday, on opening Firefox, Avast (virus protection software) browser cleanup tool stated that the Language resource pack (this was yesterday, so I'm not sure if that's quite the correct term) was disreputable (2/5 stars). Avast said I should remove it, so I did (yes, I probably should've checked, but I was in a hurry). Firefox was running perfectly fine before, but now only boots as an unresponsive white panel with <window id="main-window" ^ in red text in a red bordered box at the top. (I would attach an image, but the uploader doesn't seem to want to play ball). Avast states on their website that removing an addon deletes it and the process cannot be undone. I have tried uninstalling and reinstalling Firefox multiple times (with restarts) with no change, even with the 'remove addons and reset to default' checked. I can't give you troubleshooting information because Firefox remains an unresponsive white panel - no addons, no toolbars to select 'help' from. Any ideas? Please let me know if there's any other information you need to help fix this problem, I'd really like my favourite browser back!
Attached screenshots

Modified by Rawnwyte

Chosen solution

Fixed, but I had to completely nuke Firefox to fix it.

Removed all user data as per the section at the bottom of the support article here: [https://support.mozilla.org/en-US/kb/uninstall-firefox-from-your-computer]

Read this answer in context 0

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/68.0.3440.106 Safari/537.36

More Information

Question owner

Apologies -

Rawnwyte said

<window ^="" a="" at="" blockquote="" bordered="" box="" id="main-window" in="" red="" text="" the="" top<="">


Should read as listed in the title (code seems to even mess with the blockquotes - this text was typed outside the blockquote tags!)

Also managed to upload the images here!

</window>
Apologies - ''Rawnwyte [[#question-1234450|said]]'' <blockquote> <window id="main-window" ^ in red text in a red bordered box at the top</blockquote> Should read as listed in the title (code seems to even mess with the blockquotes - this text was typed outside the blockquote tags!) Also managed to upload the images here!

Modified by Rawnwyte

Chosen Solution

Fixed, but I had to completely nuke Firefox to fix it.

Removed all user data as per the section at the bottom of the support article here: [https://support.mozilla.org/en-US/kb/uninstall-firefox-from-your-computer]

Fixed, but I had to completely nuke Firefox to fix it. Removed all user data as per the section at the bottom of the support article here: [[https://support.mozilla.org/en-US/kb/uninstall-firefox-from-your-computer]]
cor-el
  • Top 10 Contributor
  • Moderator
17530 solutions 158511 answers

Were you using Firefox with (multiple) language packs installed to be able to switch the user interface language?

A language pack you install separately is installed in the profile folder and is selected via a pref named intl.locale.requested, see the about:config page.

If Avast removed a file in the Firefox program folder then this file would have been part of the Firefox installation.

You can find the full version of the current Firefox release (62.0) in all languages and all operating systems here:

Were you using Firefox with (multiple) language packs installed to be able to switch the user interface language? A language pack you install separately is installed in the profile folder and is selected via a pref named intl.locale.requested, see the about:config page. If Avast removed a file in the Firefox program folder then this file would have been part of the Firefox installation. You can find the full version of the current Firefox release (62.0) in all languages and all operating systems here: *https://www.mozilla.org/en-US/firefox/all/ *https://www.mozilla.org/en-US/firefox/62.0/releasenotes/
jscher2000
  • Top 10 Contributor
8763 solutions 71700 answers

Rawnwyte said

Fixed, but I had to completely nuke Firefox to fix it. Removed all user data as per the section at the bottom of the support article here: [https://support.mozilla.org/en-US/kb/uninstall-firefox-from-your-computer]

Please complain to Avast about this.

Also, for anyone reading this in the future, you could try hiding the Firefox folder by renaming it FirefoxOLD rather than completely deleting it. Then you could recover relevant data (see: Recovering important data from an old profile). Of course, if you have other backups, that may not be necessary.

''Rawnwyte [[#answer-1156122|said]]'' <blockquote> Fixed, but I had to completely nuke Firefox to fix it. Removed all user data as per the section at the bottom of the support article here: [[https://support.mozilla.org/en-US/kb/uninstall-firefox-from-your-computer]] </blockquote> Please complain to Avast about this. Also, for anyone reading this in the future, you could try hiding the Firefox folder by renaming it FirefoxOLD rather than completely deleting it. Then you could recover relevant data (see: [[Recovering important data from an old profile]]). Of course, if you have other backups, that may not be necessary.
cor-el
  • Top 10 Contributor
  • Moderator
17530 solutions 158511 answers

Helpful Reply

Note that this can be solved by removing addonStartup.json.lz4 in the profile folder.

Location used for the main profile that keeps your personal data in "AppData\Roaming".

  • C:\Users\<user>\AppData\Roaming\Mozilla\Firefox\Profiles\<profile>\

"AppData" (XP: Application Data; Mac: ~/Library; Linux: ~/.mozilla) is a hidden folder.


  • Bug 1492459 - Avast/AVG deleting language packs rendering the browser unusable

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

Note that this can be solved by removing <b>addonStartup.json.lz4</b> in the profile folder. Location used for the main profile that keeps your personal data in "AppData\Roaming". *C:\Users\&lt;user&gt;\AppData\Roaming\Mozilla\Firefox\Profiles\&lt;profile&gt;\ "AppData" (XP: Application Data; Mac: ~/Library; Linux: ~/.mozilla) is a hidden folder. *http://kb.mozillazine.org/Show_hidden_files_and_folders ----- *[https://bugzilla.mozilla.org/show_bug.cgi?id=1492459 Bug 1492459] - Avast/AVG deleting language packs rendering the browser unusable (<i>please do not comment in bug reports<br>https://bugzilla.mozilla.org/page.cgi?id=etiquette.html</i>)