X
Tap here to go to the mobile version of the site.

Support Forum

I can't update firefox to the latest version. I HAVE to use version 52.9.0 because ANY later version will NOT open a link in a new tab. NOTHING happens.

Posted

I can't update Firefox to the latest version. I HAVE to use version 52.9.0 because ANY later version will NOT open a link in a new tab when I right click mouse "open in new tab." NOTHING happens.

I can't update Firefox to the latest version. I HAVE to use version 52.9.0 because ANY later version will NOT open a link in a new tab when I right click mouse "open in new tab." NOTHING happens.

Chosen solution

Hi vistamandan, the right-click > Open Link in New Tab should work in all versions of Firefox. I reviewed your earlier thread and you were experiencing this strange behavior:

vistamandan said

When I right click the mouse and select "open in new tab" I get an attempt but nothing happens. The tab shows the page for a millisecond, then closes immediately. I tried clicking with the wheel on top of the mouse and the same thing happens.

We suggested reviewing add-ons but I think you might have skipped that step when you found that Firefox 52 ESR was working for you. When you're ready to try again:

Could you test in Firefox's Safe Mode? In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 30.0 r0
  • 5.1.50907.0

Application

  • Firefox 52.9.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0
  • Support URL: https://support.mozilla.org/1/firefox/52.9.0/WINNT/en-US/

Extensions

  • Adaware Ad Block 2.0.2.7 (AdBlockerLavaSoftFF@lavasoft.com)
  • Adblock Plus 3.3.1 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Follow-on Search Telemetry 0.9.6 (followonsearch@mozilla.com)
  • Ghostery – Privacy Ad Blocker 8.2.4 (firefox@ghostery.com)
  • iCloud Bookmarks 2.1.23 (firefoxdav@icloud.com)
  • Print Friendly & PDF 2.2.0 (jid0-YQz0l1jthOIz179ehuitYAOdBEs@jetpack)
  • Restart Browser 1.1 (Restartfirefox@vazextension.com)
  • Save as PDF 1.12 (save-as-pdf-ff@pdfcrowd.com)
  • uBlock Origin 1.16.20 (uBlock0@raymondhill.net)
  • YouTube High Definition 63.1.5 ({7b1bf0b6-a1b9-42b0-b75d-252036438bdc})
  • Activity Stream 2018.04.20.1103-b3b95672 (activity-stream@mozilla.org) (Inactive)
  • AdBlocker Ultimate 2.32 (adblockultimate@adblockultimate.net) (Inactive)
  • Application Update Service Helper 2.0 (aushelper@mozilla.org) (Inactive)
  • Avira Browser Safety 2.6.1.19731 (abs@avira.com) (Inactive)
  • Avira Password Manager 1.5.1.25340 (passwordmanager@avira.com) (Inactive)
  • Firefox Screenshots 30.1.0 (screenshots@mozilla.org) (Inactive)
  • Force PDF Download 0.1.3.9 ({d7f46ca0-899d-11da-a72b-0800200c9a65}) (Inactive)
  • Form Autofill 1.0 (formautofill@mozilla.org) (Inactive)
  • iTube Studio 6.0.0.8 (ISAllmytube@iSkysoft.com) (Inactive)
  • Just Restart! 1.0.5 ({5afc0857-ce93-471c-9a00-b6247890dc1d}) (Inactive)
  • Kee 2.3.19.1 (keefox@chris.tomlinson) (Inactive)
  • PDF Download 3.0.0.2.1-signed.1-signed ({37E4D8EA-8BDA-4831-8EA1-89053939A250}) (Inactive)
  • Photon onboarding 1.0 (onboarding@mozilla.org) (Inactive)
  • Pocket 1.0.5 (firefox@getpocket.com) (Inactive)
  • Popup Blocker Ultimate 9.5 ({60B7679C-BED9-11E5-998D-8526BB8E7F8B}) (Inactive)
  • Restart My Fox 1.1.5 (Restart-My-Fox@8pecxstudios.com) (Inactive)
  • Search image 0.1.3 (searchimage@searchimage.fr) (Inactive)
  • Speed Dial 0.1.6 ({6c3bd1f7-54d6-400f-b074-03b70bab4d71}) (Inactive)
  • Speed Dial 0.9.6.18 ({64161300-e22b-11db-8314-0800200c9a66}) (Inactive)
  • Speed Start 2.1.0 (SStart@Off.JustOff) (Inactive)
  • Tab Preview 0.3.1-signed.1-signed ({1de0de3c-0b5c-4f67-90c6-689623894991}) (Inactive)
  • Tab Scope 1.6.3 (tabscope@xuldev.org) (Inactive)
  • Web Compat 1.1 (webcompat@mozilla.org) (Inactive)
  • Wikipedia Peek 2.7.3 (@wikipedia-peek) (Inactive)
  • YouTube Adblocker 3.0.1 ({72ccf1fd-b3fb-411b-a947-d105d3621cbe}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics 520
  • adapterDescription2:
  • adapterDeviceID: 0x1916
  • adapterDeviceID2:
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 00000000
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • crashGuards: []
  • currentAudioBackend: wasapi
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.22164
  • driverDate: 8-31-2015
  • driverDate2:
  • driverVersion: 10.18.15.4281
  • driverVersion2:
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'available', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'HW_COMPOSITING'}, {u'status': u'available', u'description': u'Direct3D11 Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'D3D11_COMPOSITING'}, {u'status': u'disabled', u'description': u'Direct3D9 Compositing', u'log': [{u'status': u'disabled', u'message': u'Disabled by default', u'type': u'default'}], u'name': u'D3D9_COMPOSITING'}, {u'status': u'available', u'description': u'Direct2D', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'DIRECT2D'}, {u'status': u'available', u'description': u'Direct3D11 hardware ANGLE', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'D3D11_HW_ANGLE'}]}
  • info: {u'ApzWheelInput': 1, u'ApzTouchInput': 1, u'AzureFallbackCanvasBackend': u'cairo', u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'direct2d 1.1', u'AzureContentBackend': u'direct2d 1.1'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: Yes; Using D3D9 API
  • webgl2Renderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 520 Direct3D11 vs_5_0 ps_5_0)
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 520 Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
jscher2000
  • Top 10 Contributor
8635 solutions 70637 answers

Chosen Solution

Hi vistamandan, the right-click > Open Link in New Tab should work in all versions of Firefox. I reviewed your earlier thread and you were experiencing this strange behavior:

vistamandan said

When I right click the mouse and select "open in new tab" I get an attempt but nothing happens. The tab shows the page for a millisecond, then closes immediately. I tried clicking with the wheel on top of the mouse and the same thing happens.

We suggested reviewing add-ons but I think you might have skipped that step when you found that Firefox 52 ESR was working for you. When you're ready to try again:

Could you test in Firefox's Safe Mode? In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

Hi vistamandan, the right-click > Open Link in New Tab should work in all versions of Firefox. I reviewed your earlier thread and you were experiencing this strange behavior: ''vistamandan [https://support.mozilla.org/questions/1223363#answer-1127309 said]'' <blockquote> When I right click the mouse and select "open in new tab" I get an attempt but nothing happens. '''The tab shows the page for a millisecond, then closes immediately.''' I tried clicking with the wheel on top of the mouse and the same thing happens. </blockquote> We suggested reviewing add-ons but I think you might have skipped that step when you found that Firefox 52 ESR was working for you. When you're ready to try again: '''Could you test in Firefox's Safe Mode?''' In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem. ''If Firefox is not running:'' Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.) ''If Firefox is running:'' You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled * (menu bar) Help menu > Restart with Add-ons Disabled and OK the restart. ''Both scenarios:'' A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Any improvement?

Question owner

I started in safe mode and it worked. I then started in regular mode WITHOUT disabling any add-ons and it worked. I have NO idea what changed. I hope it works after another restart of Windows. Thanks. Dan

I started in safe mode and it worked. I then started in regular mode WITHOUT disabling any add-ons and it worked. I have NO idea what changed. I hope it works after another restart of Windows. Thanks. Dan

Question owner

Now I can't have Firefox switch to new tab when opened even though it is selected in OPTIONS.

Now I can't have Firefox switch to new tab when opened even though it is selected in OPTIONS.

Question owner

Now Firefox is doing the same problem as before ?????????

Now Firefox is doing the same problem as before ?????????
jscher2000
  • Top 10 Contributor
8635 solutions 70637 answers

Could you try disabling two out of these three extensions and see whether that helps:

  • Adaware Ad Block
  • Adblock Plus
  • uBlock Origin

You might also try disabling Ghostery.

You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions.

Then cast a critical eye over the list on the right side. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Try just one ad blocker at a time. Also, if there's anything you just do not remember installing or why, disable (or remove) that.

After making the change, reload the page with the links (Ctrl+r) before trying the links again.

Any improvement?

Could you try disabling two out of these three extensions and see whether that helps: * Adaware Ad Block * Adblock Plus * uBlock Origin You might also try disabling Ghostery. You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either: * Ctrl+Shift+a (Mac: Command+Shift+a) * "3-bar" menu button (or Tools menu) > Add-ons * type or paste '''about:addons''' in the address bar and press Enter/Return In the left column of the Add-ons page, click Extensions. Then cast a critical eye over the list on the right side. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Try just one ad blocker at a time. Also, if there's anything you just do not remember installing or why, disable (or remove) that. After making the change, reload the page with the links (Ctrl+r) before trying the links again. Any improvement?