Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Bookmarks toolbar will not show despite doing the right things

  • 17 replies
  • 1 has this problem
  • 57 views
  • Last reply by jscher2000

more options

I have selected the option to show the bookmark toolbar in the right click menu in blank space, and also in the customize window. I have used this many times on its own and in combination with restarting and logging off. The bookmark toolbar will not display. The bookmark toolbar is available through the bookmark menu but I want to see it as a toolbar.

By the way the option to show/hide the menu bar works correctly.

I've disabled all plugins but no improvement.

Yesterday I accepted a Firefox update and it's now on 61.0.2 (64bit)

Today I did a malware scan and it found three PUPs but no improvement after removal.

Please help. Thanks

      • Edit

I have just noticed that the bokmark toolbar shows on a private browsing window but not the normal window.

Modified by Jay364

All Replies (17)

more options

Hi, please can you try this:

Open the 3-bar menu > Help > Troubleshooting Information. That will load a page in your browser, then near the bottom look for Places Database and click on Verify Integrity.

That should run some checks, and there hopefully won't be any errors raised.

Then restart Firefox and see if the toolbar starts working properly again.

Please let us know either way.

more options

Hi

Thanks for your reply. I did as you asked and there appeared to be no errors, however, the bookmark toolbar still does not work.

more options

Hi, please try : uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files , C:\Program Files(x86) & C:\ProgramData Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do :

Reinstall with Current Release Firefox 61.0.2 with a Full Version Installer

Please let us know if this solved your issue or if need further assistance.

more options

Hi Pkshadow Thanks for your suggestion. I will try it. One point to note is the bookmark toolbar shows on a private window but not a normal window. I wonder if there is some odd setting/problem affecting the normal window which is being suppressed by the privacy settings on the private window. Another thing is I have replaced the userchrome.css file to move tabs where they should be (below the address bar) but I have also done that on my work PC which doesn't have the same missing toolbar problem. Thanks for your input. Jay

more options

Try to rename/remove xulstore.json and if present delete localstore.rdf in the Firefox profile folder with Firefox closed.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

more options

It is a Extension I would think or your Security Software scanner which is what please ??

You also have a lot of errors in your Video Card Drivers, you should reinstall or uninstall and update with a full installer : adapterDescription: Intel(R) HD Graphics 4600 adapterDescription2: NVIDIA GeForce GT 740M driverDate: 4-4-2016 driverDate2: 5-17-2017

Please Turn off Hardware Acceleration and Test: Copy/Paste about:preferences to the Address Bar and Enter. Go down the page to Performance, Remove Check Mark Use Recommended Performance Settings then remove the check mark in Hardware Acceleration.

Clean your cache :

Clean cookies :

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)
more options

Jay364 said

I have replaced the userchrome.css file to move tabs where they should be (below the address bar) but I have also done that on my work PC which doesn't have the same missing toolbar problem.

Could you test in Firefox's Safe Mode? In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

more options

As an easy quick test I restarted in safe mode and there was no bookmark toolbar menu in either normal or private window. Restarting in normal mode toolbar menu is in private but not in normal.

more options

I also use Tor browser (as you know based on Firefox) and the bookmarks toolbar displays correctly there popu;ated with my Firefox bookmarks. This problem I believe is caused by a Firefox update.

more options

Jay364, could you attach a screenshot of the toolbars when in Customise Mode.

Also, if you go to "Show All Bookmarks" (ctrl-shift-B), can you confirm there are bookmarks still listed in the "Bookmarks Toolbar" folder?

more options

Thanks Standard8. Yes the bookmarks are there and set to display. Just not actually displaying.

more options

Try to reset this pref on the about:config page via the right-click context menu to the default value to reset the toolbar customization.

  • browser.uiCustomization.state

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

more options

Thanks cor-el. I tried resetting browser.uiCustomization.state to default but it would not stick on default. I removed the userchrome.scc file and the tabs moved back to the top but the bookmark toolbar did not appear. I did it several time in different orders but it was still no good and browser.uiCustomization.state would not retain its default setting.

more options

Do you have a userChrome.css or some other item that puts the tabs below the urlbar as per that screenshot?

I would suggest temporarily undoing that and seeing if that helps or not.

Although safe mode should have tested that. For safe mode, if you didn't do it, then you might need to go to the three-bar menu -> Library -> Bookmarks -> Bookmarking Tools -> Show Bookmarks Toolbar.

more options

It is quite normal that Firefox creates a new browser.uiCustomization.state pref that shows as modified when you reset this pref. This pref store the current toolbar setup in JSON format. There is also some toolbar data in xulstore.json. If resetting of either these files doesn't have effect then there might be a problem with the places.sqlite database.

more options

I have the same exact issue, yesterday it was working perfectly, today bookmarks bar only visible in private mode. Safe mode didn't solve, deleting places.sqlite database didn't work, I am one step closer to go back to chrome unfortunately...

more options

Hi shevapippo, some Firefox 62 users with similar symptoms reported that they see the Bookmarks Toolbar briefly at startup (even in a regular window) but then it blinks off.

Some of those users reported that they were using the setting to restore their previous session at startup. Turning that setting OFF, exiting and restarting Firefox once (and manually restoring the session from the menu), then turning the setting back on, somehow resolved the Bookmarks Toolbar issue for them. You could try it.