X
Tap here to go to the mobile version of the site.
An updated version of Firefox is available to address the issues with Add-ons disabled or fail to install on Firefox. You can download the update for your OS here: https://www.mozilla.org/firefox/new/ For Known Issues and Workarounds, please check out the update at https://support.mozilla.org/kb/add-ons-disabled-or-fail-to-install-firefox

Support Forum

Bookmarks toolbar will not show despite doing the right things

Posted

I have selected the option to show the bookmark toolbar in the right click menu in blank space, and also in the customize window. I have used this many times on its own and in combination with restarting and logging off. The bookmark toolbar will not display. The bookmark toolbar is available through the bookmark menu but I want to see it as a toolbar.

By the way the option to show/hide the menu bar works correctly.

I've disabled all plugins but no improvement.

Yesterday I accepted a Firefox update and it's now on 61.0.2 (64bit)

Today I did a malware scan and it found three PUPs but no improvement after removal.

Please help. Thanks

      • Edit

I have just noticed that the bokmark toolbar shows on a private browsing window but not the normal window.

I have selected the option to show the bookmark toolbar in the right click menu in blank space, and also in the customize window. I have used this many times on its own and in combination with restarting and logging off. The bookmark toolbar will not display. The bookmark toolbar is available through the bookmark menu but I want to see it as a toolbar. By the way the option to show/hide the menu bar works correctly. I've disabled all plugins but no improvement. Yesterday I accepted a Firefox update and it's now on 61.0.2 (64bit) Today I did a malware scan and it found three PUPs but no improvement after removal. Please help. Thanks ***Edit I have just noticed that the bokmark toolbar shows on a private browsing window but not the normal window.

Modified by Jay364

Additional System Details

Installed Plug-ins

  • Shockwave Flash 30.0 r0

Application

  • Firefox 61.0.2
  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0
  • Support URL: https://support.mozilla.org/1/firefox/61.0.2/WINNT/en-GB/

Extensions

  • Adblock Plus 3.2 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}) (Inactive)
  • AdBlocker for YouTube™ 0.2.9 (jid1-q4sG8pYhq8KGHs@jetpack) (Inactive)
  • DuckDuckGo Privacy Essentials 2018.8.9 (jid1-ZAdIEUB7XOzOJw@jetpack) (Inactive)
  • Flash Video Downloader 16.1.1 (artur.dubovoy@gmail.com) (Inactive)
  • HTTPS Everywhere 2018.6.21 (https-everywhere@eff.org) (Inactive)
  • iCloud Bookmarks 2.1.23 (firefoxdav@icloud.com) (Inactive)
  • New Tab Override 14.1.0 (newtaboverride@agenedia.com) (Inactive)
  • The Camelizer 2.9.7 (izer@camelcamelcamel.com) (Inactive)
  • ThinkVantage Password Manager 4.60 ({F74D5734-46F5-4B16-96F0-1E7FBF41B750}) (Inactive)
  • uBlock Origin 1.16.16 (uBlock0@raymondhill.net) (Inactive)
  • YouTube mp3 Downloader 1.2 ({3d1fbee0-687c-4032-9815-0f4519252d44}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics 4600
  • adapterDescription2: NVIDIA GeForce GT 740M
  • adapterDeviceID: 0x0416
  • adapterDeviceID2: 0x1292
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32
  • adapterDrivers2: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterRAM: Unknown
  • adapterRAM2: 2048
  • adapterSubsysID: 502a17aa
  • adapterSubsysID2: 502a17aa
  • adapterVendorID: 0x8086
  • adapterVendorID2: 0x10de
  • contentUsesTiling: False
  • crashGuards: [{u'prefName': u'gfx.crash-guard.status.d3d11layers', u'type': u'd3d11layers'}]
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'blockedDriver']
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.22164
  • driverDate: 4-4-2016
  • driverDate2: 5-17-2017
  • driverVersion: 10.18.10.4425
  • driverVersion2: 22.21.13.8233
  • featureLog: {u'fallbacks': [{u'message': u'Unsupported by driver', u'name': u'NO_CONSTANT_BUFFER_OFFSETTING'}], u'features': [{u'status': u'available', u'description': u'Compositing', u'name': u'HW_COMPOSITING', u'log': [{u'status': u'available', u'type': u'default'}]}, {u'status': u'available', u'description': u'Direct3D11 Compositing', u'name': u'D3D11_COMPOSITING', u'log': [{u'status': u'available', u'type': u'default'}]}, {u'status': u'blacklisted', u'description': u'Direct2D', u'name': u'DIRECT2D', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'blacklisted', u'message': u'#BLOCKLIST_FEATURE_FAILURE_BUG_1432610', u'type': u'env'}]}, {u'status': u'available', u'description': u'Direct3D11 hardware ANGLE', u'name': u'D3D11_HW_ANGLE', u'log': [{u'status': u'available', u'type': u'default'}]}, {u'status': u'available', u'description': u'GPU Process', u'name': u'GPU_PROCESS', u'log': [{u'status': u'available', u'type': u'default'}]}, {u'status': u'unavailable', u'description': u'WebRender', u'name': u'WEBRENDER', u'log': [{u'status': u'opt-in', u'message': u'WebRender is an opt-in feature', u'type': u'default'}, {u'status': u'unavailable', u'message': u"Build doesn't include WebRender", u'type': u'runtime'}]}, {u'status': u'available', u'description': u'Off Main Thread Painting', u'name': u'OMTP', u'log': [{u'status': u'available', u'type': u'default'}]}, {u'status': u'available', u'description': u'Advanced Layers', u'name': u'ADVANCED_LAYERS', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'available', u'message': u'Enabled for Windows 7 via user-preference', u'type': u'user'}]}]}
  • info: {u'AzureContentBackend (UI Process)': u'skia', u'AzureCanvasBackend (UI Process)': u'skia', u'ApzWheelInput': 1, u'ApzDragInput': 1, u'ApzKeyboardInput': 1, u'AzureFallbackCanvasBackend (UI Process)': u'cairo', u'ApzAutoscrollInput': 1, u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'skia', u'AzureContentBackend': u'skia'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • offMainThreadPaintEnabled: True
  • offMainThreadPaintWorkerCount: 3
  • usesTiling: False
  • webgl1DriverExtensions: GL_ANGLE_client_arrays GL_ANGLE_depth_texture GL_ANGLE_framebuffer_blit GL_ANGLE_framebuffer_multisample GL_ANGLE_instanced_arrays GL_ANGLE_lossy_etc_decode GL_ANGLE_pack_reverse_row_order GL_ANGLE_program_cache_control GL_ANGLE_request_extension GL_ANGLE_robust_client_memory GL_ANGLE_texture_compression_dxt3 GL_ANGLE_texture_compression_dxt5 GL_ANGLE_texture_usage GL_ANGLE_translated_shader_source GL_CHROMIUM_bind_generates_resource GL_CHROMIUM_bind_uniform_location GL_CHROMIUM_color_buffer_float_rgb GL_CHROMIUM_color_buffer_float_rgba GL_CHROMIUM_copy_compressed_texture GL_CHROMIUM_copy_texture GL_CHROMIUM_sync_query GL_EXT_blend_minmax GL_EXT_color_buffer_half_float GL_EXT_debug_marker GL_EXT_discard_framebuffer GL_EXT_disjoint_timer_query GL_EXT_draw_buffers GL_EXT_frag_depth GL_EXT_map_buffer_range GL_EXT_occlusion_query_boolean GL_EXT_read_format_bgra GL_EXT_robustness GL_EXT_sRGB GL_EXT_shader_texture_lod GL_EXT_texture_compression_dxt1 GL_EXT_texture_compression_s3tc_srgb GL_EXT_texture_filter_anisotropic GL_EXT_texture_format_BGRA8888 GL_EXT_texture_rg GL_EXT_texture_storage GL_EXT_unpack_subimage GL_KHR_debug GL_NV_EGL_stream_consumer_external GL_NV_fence GL_NV_pack_subimage GL_NV_pixel_buffer_object GL_OES_EGL_image GL_OES_EGL_image_external GL_OES_compressed_ETC1_RGB8_texture GL_OES_depth32 GL_OES_element_index_uint GL_OES_get_program_binary GL_OES_mapbuffer GL_OES_packed_depth_stencil GL_OES_rgb8_rgba8 GL_OES_standard_derivatives GL_OES_surfaceless_context GL_OES_texture_float GL_OES_texture_float_linear GL_OES_texture_half_float GL_OES_texture_half_float_linear GL_OES_texture_npot GL_OES_vertex_array_object
  • webgl1Extensions: ANGLE_instanced_arrays EXT_blend_minmax EXT_color_buffer_half_float EXT_frag_depth EXT_sRGB EXT_shader_texture_lod EXT_texture_filter_anisotropic EXT_disjoint_timer_query OES_element_index_uint OES_standard_derivatives OES_texture_float OES_texture_float_linear OES_texture_half_float OES_texture_half_float_linear OES_vertex_array_object WEBGL_color_buffer_float WEBGL_compressed_texture_s3tc WEBGL_compressed_texture_s3tc_srgb WEBGL_debug_renderer_info WEBGL_debug_shaders WEBGL_depth_texture WEBGL_draw_buffers WEBGL_lose_context
  • webgl1Renderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 4600 Direct3D11 vs_5_0 ps_5_0)
  • webgl1Version: OpenGL ES 2.0 (ANGLE 2.1.0.fcbca0e873c3)
  • webgl1WSIInfo: EGL_VENDOR: Google Inc. (adapter LUID: 0000000000010018) EGL_VERSION: 1.4 (ANGLE 2.1.0.fcbca0e873c3) EGL_EXTENSIONS: EGL_EXT_create_context_robustness EGL_ANGLE_d3d_share_handle_client_buffer EGL_ANGLE_d3d_texture_client_buffer EGL_ANGLE_surface_d3d_texture_2d_share_handle EGL_ANGLE_query_surface_pointer EGL_ANGLE_window_fixed_size EGL_ANGLE_keyed_mutex EGL_ANGLE_surface_orientation EGL_NV_post_sub_buffer EGL_KHR_create_context EGL_EXT_device_query EGL_KHR_image EGL_KHR_image_base EGL_KHR_gl_texture_2D_image EGL_KHR_gl_texture_cubemap_image EGL_KHR_gl_renderbuffer_image EGL_KHR_get_all_proc_addresses EGL_KHR_stream EGL_KHR_stream_consumer_gltexture EGL_NV_stream_consumer_gltexture_yuv EGL_ANGLE_flexible_surface_compatibility EGL_ANGLE_stream_producer_d3d_texture EGL_ANGLE_create_context_webgl_compatibility EGL_CHROMIUM_create_context_bind_generates_resource EGL_EXT_pixel_format_float EGL_KHR_surfaceless_context EGL_ANGLE_display_texture_share_group EGL_ANGLE_create_context_client_arrays EGL_ANGLE_program_cache_control EGL_ANGLE_robust_resource_initialization EGL_EXTENSIONS(nullptr): EGL_EXT_client_extensions EGL_EXT_platform_base EGL_EXT_platform_device EGL_ANGLE_platform_angle EGL_ANGLE_platform_angle_d3d EGL_ANGLE_device_creation EGL_ANGLE_device_creation_d3d11 EGL_ANGLE_experimental_present_path EGL_KHR_client_get_all_proc_addresses
  • webgl2DriverExtensions: GL_ANGLE_client_arrays GL_ANGLE_depth_texture GL_ANGLE_framebuffer_blit GL_ANGLE_framebuffer_multisample GL_ANGLE_instanced_arrays GL_ANGLE_lossy_etc_decode GL_ANGLE_multiview GL_ANGLE_pack_reverse_row_order GL_ANGLE_program_cache_control GL_ANGLE_request_extension GL_ANGLE_robust_client_memory GL_ANGLE_texture_compression_dxt3 GL_ANGLE_texture_compression_dxt5 GL_ANGLE_texture_usage GL_ANGLE_translated_shader_source GL_CHROMIUM_bind_generates_resource GL_CHROMIUM_bind_uniform_location GL_CHROMIUM_color_buffer_float_rgb GL_CHROMIUM_color_buffer_float_rgba GL_CHROMIUM_copy_compressed_texture GL_CHROMIUM_copy_texture GL_CHROMIUM_sync_query GL_EXT_blend_minmax GL_EXT_color_buffer_float GL_EXT_color_buffer_half_float GL_EXT_debug_marker GL_EXT_discard_framebuffer GL_EXT_disjoint_timer_query GL_EXT_draw_buffers GL_EXT_frag_depth GL_EXT_map_buffer_range GL_EXT_occlusion_query_boolean GL_EXT_read_format_bgra GL_EXT_robustness GL_EXT_sRGB GL_EXT_shader_texture_lod GL_EXT_texture_compression_dxt1 GL_EXT_texture_compression_s3tc_srgb GL_EXT_texture_filter_anisotropic GL_EXT_texture_format_BGRA8888 GL_EXT_texture_norm16 GL_EXT_texture_rg GL_EXT_texture_storage GL_EXT_unpack_subimage GL_KHR_debug GL_NV_EGL_stream_consumer_external GL_NV_fence GL_NV_pack_subimage GL_NV_pixel_buffer_object GL_OES_EGL_image GL_OES_EGL_image_external GL_OES_EGL_image_external_essl3 GL_OES_compressed_ETC1_RGB8_texture GL_OES_depth32 GL_OES_element_index_uint GL_OES_get_program_binary GL_OES_mapbuffer GL_OES_packed_depth_stencil GL_OES_rgb8_rgba8 GL_OES_standard_derivatives GL_OES_surfaceless_context GL_OES_texture_float GL_OES_texture_float_linear GL_OES_texture_half_float GL_OES_texture_half_float_linear GL_OES_texture_npot GL_OES_vertex_array_object
  • webgl2Extensions: EXT_color_buffer_float EXT_texture_filter_anisotropic EXT_disjoint_timer_query OES_texture_float_linear WEBGL_compressed_texture_s3tc WEBGL_compressed_texture_s3tc_srgb WEBGL_debug_renderer_info WEBGL_debug_shaders WEBGL_lose_context
  • webgl2Renderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 4600 Direct3D11 vs_5_0 ps_5_0)
  • webgl2Version: OpenGL ES 3.0 (ANGLE 2.1.0.fcbca0e873c3)
  • webgl2WSIInfo: EGL_VENDOR: Google Inc. (adapter LUID: 0000000000010018) EGL_VERSION: 1.4 (ANGLE 2.1.0.fcbca0e873c3) EGL_EXTENSIONS: EGL_EXT_create_context_robustness EGL_ANGLE_d3d_share_handle_client_buffer EGL_ANGLE_d3d_texture_client_buffer EGL_ANGLE_surface_d3d_texture_2d_share_handle EGL_ANGLE_query_surface_pointer EGL_ANGLE_window_fixed_size EGL_ANGLE_keyed_mutex EGL_ANGLE_surface_orientation EGL_NV_post_sub_buffer EGL_KHR_create_context EGL_EXT_device_query EGL_KHR_image EGL_KHR_image_base EGL_KHR_gl_texture_2D_image EGL_KHR_gl_texture_cubemap_image EGL_KHR_gl_renderbuffer_image EGL_KHR_get_all_proc_addresses EGL_KHR_stream EGL_KHR_stream_consumer_gltexture EGL_NV_stream_consumer_gltexture_yuv EGL_ANGLE_flexible_surface_compatibility EGL_ANGLE_stream_producer_d3d_texture EGL_ANGLE_create_context_webgl_compatibility EGL_CHROMIUM_create_context_bind_generates_resource EGL_EXT_pixel_format_float EGL_KHR_surfaceless_context EGL_ANGLE_display_texture_share_group EGL_ANGLE_create_context_client_arrays EGL_ANGLE_program_cache_control EGL_ANGLE_robust_resource_initialization EGL_EXTENSIONS(nullptr): EGL_EXT_client_extensions EGL_EXT_platform_base EGL_EXT_platform_device EGL_ANGLE_platform_angle EGL_ANGLE_platform_angle_d3d EGL_ANGLE_device_creation EGL_ANGLE_device_creation_d3d11 EGL_ANGLE_experimental_present_path EGL_KHR_client_get_all_proc_addresses
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11
  • windowUsingAdvancedLayers: True

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
Standard8 30 solutions 166 answers

Hi, please can you try this:

Open the 3-bar menu > Help > Troubleshooting Information. That will load a page in your browser, then near the bottom look for Places Database and click on Verify Integrity.

That should run some checks, and there hopefully won't be any errors raised.

Then restart Firefox and see if the toolbar starts working properly again.

Please let us know either way.

Hi, please can you try this: Open the 3-bar menu > Help > Troubleshooting Information. That will load a page in your browser, then near the bottom look for Places Database and click on Verify Integrity. That should run some checks, and there hopefully won't be any errors raised. Then restart Firefox and see if the toolbar starts working properly again. Please let us know either way.

Question owner

Hi

Thanks for your reply. I did as you asked and there appeared to be no errors, however, the bookmark toolbar still does not work.

Hi Thanks for your reply. I did as you asked and there appeared to be no errors, however, the bookmark toolbar still does not work.
Pkshadow 1072 solutions 14836 answers

Hi, please try : uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files , C:\Program Files(x86) & C:\ProgramData Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do :

Reinstall with Current Release Firefox 61.0.2 with a Full Version Installer

Please let us know if this solved your issue or if need further assistance.

Hi, please try : uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files , C:\Program Files(x86) & C:\ProgramData Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do : *https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles *https://support.mozilla.org/en-US/kb/export-firefox-bookmarks-to-backup-or-transfer Reinstall with Current Release Firefox 61.0.2 with a Full Version Installer *https://www.mozilla.org/firefox/all/ Please let us know if this solved your issue or if need further assistance.

Question owner

Hi Pkshadow Thanks for your suggestion. I will try it. One point to note is the bookmark toolbar shows on a private window but not a normal window. I wonder if there is some odd setting/problem affecting the normal window which is being suppressed by the privacy settings on the private window. Another thing is I have replaced the userchrome.css file to move tabs where they should be (below the address bar) but I have also done that on my work PC which doesn't have the same missing toolbar problem. Thanks for your input. Jay

Hi Pkshadow Thanks for your suggestion. I will try it. One point to note is the bookmark toolbar shows on a private window but not a normal window. I wonder if there is some odd setting/problem affecting the normal window which is being suppressed by the privacy settings on the private window. Another thing is I have replaced the userchrome.css file to move tabs where they should be (below the address bar) but I have also done that on my work PC which doesn't have the same missing toolbar problem. Thanks for your input. Jay
cor-el
  • Top 10 Contributor
  • Moderator
17084 solutions 154305 answers

Try to rename/remove xulstore.json and if present delete localstore.rdf in the Firefox profile folder with Firefox closed.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

Try to rename/remove xulstore.json and if present delete localstore.rdf in the Firefox profile folder with Firefox closed. You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the <b>about:profiles</b> page. *Help -> Troubleshooting Information -> Profile Directory:<br>Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder *http://kb.mozillazine.org/Profile_folder_-_Firefox
Pkshadow 1072 solutions 14836 answers

It is a Extension I would think or your Security Software scanner which is what please ??

You also have a lot of errors in your Video Card Drivers, you should reinstall or uninstall and update with a full installer : adapterDescription: Intel(R) HD Graphics 4600 adapterDescription2: NVIDIA GeForce GT 740M driverDate: 4-4-2016 driverDate2: 5-17-2017

Please Turn off Hardware Acceleration and Test: Copy/Paste about:preferences to the Address Bar and Enter. Go down the page to Performance, Remove Check Mark Use Recommended Performance Settings then remove the check mark in Hardware Acceleration.

Clean your cache :

Clean cookies :

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)
It is a Extension I would think or your Security Software scanner which is what please ?? You also have a lot of errors in your Video Card Drivers, you should reinstall or uninstall and update with a full installer : adapterDescription: Intel(R) HD Graphics 4600 adapterDescription2: NVIDIA GeForce GT 740M driverDate: 4-4-2016 driverDate2: 5-17-2017 Please Turn off Hardware Acceleration and Test: Copy/Paste about:preferences to the Address Bar and Enter. Go down the page to Performance, Remove Check Mark Use Recommended Performance Settings then remove the check mark in Hardware Acceleration. Clean your cache : *https://support.mozilla.org/en-US/kb/how-clear-firefox-cache Clean cookies : *https://support.mozilla.org/en-US/kb/delete-cookies-remove-info-websites-stored You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files. *hold down the Shift key and left-click the Reload button *press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux) *press "Command + Shift + R" (Mac)
jscher2000
  • Top 10 Contributor
8314 solutions 68040 answers

Jay364 said

I have replaced the userchrome.css file to move tabs where they should be (below the address bar) but I have also done that on my work PC which doesn't have the same missing toolbar problem.

Could you test in Firefox's Safe Mode? In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

''Jay364 [[#answer-1146797|said]]'' <blockquote> I have replaced the userchrome.css file to move tabs where they should be (below the address bar) but I have also done that on my work PC which doesn't have the same missing toolbar problem. </blockquote> Could you test in Firefox's Safe Mode? In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem. ''If Firefox is not running:'' Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.) ''If Firefox is running:'' You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled * (menu bar) Help menu > Restart with Add-ons Disabled and OK the restart. ''Both scenarios:'' A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Any improvement?

Question owner

As an easy quick test I restarted in safe mode and there was no bookmark toolbar menu in either normal or private window. Restarting in normal mode toolbar menu is in private but not in normal.

As an easy quick test I restarted in safe mode and there was no bookmark toolbar menu in either normal or private window. Restarting in normal mode toolbar menu is in private but not in normal.

Question owner

I also use Tor browser (as you know based on Firefox) and the bookmarks toolbar displays correctly there popu;ated with my Firefox bookmarks. This problem I believe is caused by a Firefox update.

I also use Tor browser (as you know based on Firefox) and the bookmarks toolbar displays correctly there popu;ated with my Firefox bookmarks. This problem I believe is caused by a Firefox update.
Standard8 30 solutions 166 answers

Jay364, could you attach a screenshot of the toolbars when in Customise Mode.

Also, if you go to "Show All Bookmarks" (ctrl-shift-B), can you confirm there are bookmarks still listed in the "Bookmarks Toolbar" folder?

Jay364, could you attach a screenshot of the toolbars when in Customise Mode. Also, if you go to "Show All Bookmarks" (ctrl-shift-B), can you confirm there are bookmarks still listed in the "Bookmarks Toolbar" folder?

Question owner

Thanks Standard8. Yes the bookmarks are there and set to display. Just not actually displaying.

Thanks Standard8. Yes the bookmarks are there and set to display. Just not actually displaying.
cor-el
  • Top 10 Contributor
  • Moderator
17084 solutions 154305 answers

Try to reset this pref on the about:config page via the right-click context menu to the default value to reset the toolbar customization.

  • browser.uiCustomization.state

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Try to reset this pref on the <b>about:config</b> page via the right-click context menu to the default value to reset the toolbar customization. *browser.uiCustomization.state You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. *http://kb.mozillazine.org/about:config

Question owner

Thanks cor-el. I tried resetting browser.uiCustomization.state to default but it would not stick on default. I removed the userchrome.scc file and the tabs moved back to the top but the bookmark toolbar did not appear. I did it several time in different orders but it was still no good and browser.uiCustomization.state would not retain its default setting.

Thanks cor-el. I tried resetting browser.uiCustomization.state to default but it would not stick on default. I removed the userchrome.scc file and the tabs moved back to the top but the bookmark toolbar did not appear. I did it several time in different orders but it was still no good and browser.uiCustomization.state would not retain its default setting.
Standard8 30 solutions 166 answers

Do you have a userChrome.css or some other item that puts the tabs below the urlbar as per that screenshot?

I would suggest temporarily undoing that and seeing if that helps or not.

Although safe mode should have tested that. For safe mode, if you didn't do it, then you might need to go to the three-bar menu -> Library -> Bookmarks -> Bookmarking Tools -> Show Bookmarks Toolbar.

Do you have a userChrome.css or some other item that puts the tabs below the urlbar as per that screenshot? I would suggest temporarily undoing that and seeing if that helps or not. Although safe mode should have tested that. For safe mode, if you didn't do it, then you might need to go to the three-bar menu -> Library -> Bookmarks -> Bookmarking Tools -> Show Bookmarks Toolbar.
cor-el
  • Top 10 Contributor
  • Moderator
17084 solutions 154305 answers

It is quite normal that Firefox creates a new browser.uiCustomization.state pref that shows as modified when you reset this pref. This pref store the current toolbar setup in JSON format. There is also some toolbar data in xulstore.json. If resetting of either these files doesn't have effect then there might be a problem with the places.sqlite database.

It is quite normal that Firefox creates a new browser.uiCustomization.state pref that shows as modified when you reset this pref. This pref store the current toolbar setup in JSON format. There is also some toolbar data in xulstore.json. If resetting of either these files doesn't have effect then there might be a problem with the places.sqlite database.
shevapippo 0 solutions 1 answers

I have the same exact issue, yesterday it was working perfectly, today bookmarks bar only visible in private mode. Safe mode didn't solve, deleting places.sqlite database didn't work, I am one step closer to go back to chrome unfortunately...

I have the same exact issue, yesterday it was working perfectly, today bookmarks bar only visible in private mode. Safe mode didn't solve, deleting places.sqlite database didn't work, I am one step closer to go back to chrome unfortunately...
jscher2000
  • Top 10 Contributor
8314 solutions 68040 answers

Hi shevapippo, some Firefox 62 users with similar symptoms reported that they see the Bookmarks Toolbar briefly at startup (even in a regular window) but then it blinks off.

Some of those users reported that they were using the setting to restore their previous session at startup. Turning that setting OFF, exiting and restarting Firefox once (and manually restoring the session from the menu), then turning the setting back on, somehow resolved the Bookmarks Toolbar issue for them. You could try it.

Hi shevapippo, some Firefox 62 users with similar symptoms reported that they see the Bookmarks Toolbar briefly at startup (even in a regular window) but then it blinks off. Some of those users reported that they were using the setting to restore their previous session at startup. Turning that setting OFF, exiting and restarting Firefox once (and manually restoring the session from the menu), then turning the setting back on, somehow resolved the Bookmarks Toolbar issue for them. You could try it.