X
Tap here to go to the mobile version of the site.

Support Forum

I don't want search results highlighted when I do a search

Posted

When I do a search on firefox, the results that show up are highlighted. This just started recently. I don't want the results to be highlighted. How do I disable this feature?

When I do a search on firefox, the results that show up are highlighted. This just started recently. I don't want the results to be highlighted. How do I disable this feature?
jscher2000
  • Top 10 Contributor
8837 solutions 72222 answers

Hi OhioFirefoxUser, do you mean on the search results page, or when you use Find (Ctrl+f) to search within the page?

For search engine results, this may be an option provided by the search site. Is it the site you've always used -- and it made a change -- or did your search results site get switched? For reference, just in case: Change your default search settings in Firefox.

For Find-in-page, check the Find bar for the "Highlight All" button and click that to switch it off (if it's on).

Hi OhioFirefoxUser, do you mean on the search results page, or when you use Find (Ctrl+f) to search within the page? For search engine results, this may be an option provided by the search site. Is it the site you've always used -- and it made a change -- or did your search results site get switched? ''For reference, just in case:'' [[Change your default search settings in Firefox]]. For Find-in-page, check the Find bar for the "Highlight All" button and click that to switch it off (if it's on).
cor-el
  • Top 10 Contributor
  • Moderator
17679 solutions 159921 answers

Note that the Find bar has find settings for "Highlight All" and "Whole Words" and "Match Case" that are hidden when you use Quick Find. So open the Find bar via Ctrl+F to inspect these choices.

Related prefs as found on the about:config page.

  • findbar.entireword = false
  • findbar.highlightAll = false
  • accessibility.typeaheadfind.casesensitive = 0
Note that the Find bar has find settings for "Highlight All" and "Whole Words" and "Match Case" that are <u>hidden</u> when you use Quick Find. So open the Find bar via Ctrl+F to inspect these choices. Related prefs as found on the <b>about:config</b> page. *findbar.entireword = false *findbar.highlightAll = false *accessibility.typeaheadfind.casesensitive = 0

Question owner

Thanks guys, but...Huh? I'm lost. I can't find what you guys are talking about. Let me explain... When I type in a subject in the search bar next to the url bar, the results come up on another page. With me so far? On the results page are links to the search results I requested. The names of the links are highlighted in green with a checkmark to the left of the link. I don't want link highlighted anymore. This started a couple days ago when I refreshed firefox and it's annoying. How can I stop this from happening.

Thanks guys, but...Huh? I'm lost. I can't find what you guys are talking about. Let me explain... When I type in a subject in the search bar next to the url bar, the results come up on another page. With me so far? On the results page are links to the search results I requested. The names of the links are highlighted in green with a checkmark to the left of the link. I don't want link highlighted anymore. This started a couple days ago when I refreshed firefox and it's annoying. How can I stop this from happening.
cor-el
  • Top 10 Contributor
  • Moderator
17679 solutions 159921 answers

Ok, what I wrote above doesn't apply because your question is about using a search engine results page.

What search engine do you use?

Can you attach a screenshot?

Ok, what I wrote above doesn't apply because your question is about using a search engine results page. What search engine do you use? Can you attach a screenshot? *https://support.mozilla.org/en-US/kb/how-do-i-create-screenshot-my-problem *use a compressed image type like PNG or JPG to save the screenshot
jscher2000
  • Top 10 Contributor
8837 solutions 72222 answers

OhioFirefoxUser said

On the results page are links to the search results I requested. The names of the links are highlighted in green with a checkmark to the left of the link. I don't want link highlighted anymore. This started a couple days ago when I refreshed firefox and it's annoying.

Hmm, normally when you Refresh Firefox, your search engine results will return to being on Google. I don't think Google uses those design elements.

Could you copy/paste the address of your results page into a reply? Please search for something general (not personal). For example, if a search for firefox goes to DuckDuckGo, the address usually looks like this:

https://duckduckgo.com/?q=firefox&t=ffsb&ia=web

''OhioFirefoxUser [[#answer-1140409|said]]'' <blockquote> On the results page are links to the search results I requested. The names of the links are highlighted in green with a checkmark to the left of the link. I don't want link highlighted anymore. This started a couple days ago when I refreshed firefox and it's annoying. </blockquote> Hmm, normally when you Refresh Firefox, your search engine results will return to being on Google. I don't think Google uses those design elements. Could you copy/paste the address of your results page into a reply? Please search for something general (not personal). For example, if a search for ''firefox'' goes to DuckDuckGo, the address usually looks like this: https://duckduckgo.com/?q=firefox&t=ffsb&ia=web
jscher2000
  • Top 10 Contributor
8837 solutions 72222 answers

Another thought: some add-ons mark links as safe or bad, so green could indicate safe. You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions.

Then cast a critical eye over the list on the right side. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything here that relates to security or link reputation? If in doubt, try its Options button to see whether you can turn that off, or disable it.

Any improvement?

Another thought: some add-ons mark links as safe or bad, so green could indicate safe. You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either: * Ctrl+Shift+a (Mac: Command+Shift+a) * "3-bar" menu button (or Tools menu) > Add-ons * type or paste '''about:addons''' in the address bar and press Enter/Return In the left column of the Add-ons page, click Extensions. Then cast a critical eye over the list on the right side. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything here that relates to security or link reputation? If in doubt, try its Options button to see whether you can turn that off, or disable it. Any improvement?

Question owner

https://screenshots.firefox.com/T7htxIZn68ne2oQ2/search.yahoo.com

Above you should see a screenshot. I was using google as my search but now I'm using yahoo. Both sites are doing the highlighting. jscher2000...I did what you suggested but I don't see anything related to extensions that do highlighting.

Thanks again. Hope this helps

https://screenshots.firefox.com/T7htxIZn68ne2oQ2/search.yahoo.com Above you should see a screenshot. I was using google as my search but now I'm using yahoo. Both sites are doing the highlighting. jscher2000...I did what you suggested but I don't see anything related to extensions that do highlighting. Thanks again. Hope this helps
user633449 1539 solutions 10745 answers

Can you please post a complete list of your extensions? They likely won't explicitly be called "search engine highlighter" or something.

Can you please post a complete list of your extensions? They likely won't explicitly be called "search engine highlighter" or something.

Question owner

Yahoo homepage is the only extension I have that might cause this, but I don't think that is it. I have some other extensions but I'm sure they're not causing this problem.

Yahoo homepage is the only extension I have that might cause this, but I don't think that is it. I have some other extensions but I'm sure they're not causing this problem.
user633449 1539 solutions 10745 answers

That seems pretty relevant, try disabling it

That seems pretty relevant, try disabling it

Question owner

I disabled Yahoo homepage but the search results are still highlighted.

I disabled Yahoo homepage but the search results are still highlighted.
jscher2000
  • Top 10 Contributor
8837 solutions 72222 answers

It's either an extension, or an intermediary process (e.g., security software "man in the middle" filter), or that's not the normal Yahoo.

Could you copy/paste the address of the results page into a reply? For example, on Yahoo, when I search firefox I get this address:

https://search.yahoo.com/search?p=firefox&fr=yfp-t&fp=1&toggle=1&cop=mss&ei=UTF-8

Also, could you test in Firefox's Safe Mode? In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

It's either an extension, or an intermediary process (e.g., security software "man in the middle" filter), or that's not the normal Yahoo. Could you copy/paste the address of the results page into a reply? For example, on Yahoo, when I search ''firefox'' I get this address: https://search.yahoo.com/search?p=firefox&fr=yfp-t&fp=1&toggle=1&cop=mss&ei=UTF-8 Also, could you test in Firefox's Safe Mode? In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem. ''If Firefox is not running:'' Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.) ''If Firefox is running:'' You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled * (menu bar) Help menu > Restart with Add-ons Disabled and OK the restart. ''Both scenarios:'' A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Any improvement?

Question owner

Here's the link you requested:

https://search.yahoo.com/search?fr=opensearch&p=firefox&b=1

When I tried to restart in safe mode using your method, I did NOT get the option to 'start in safe mode'. All I got was an option to 'disable all add-ons and restart'. I have not tried to restart in safe mode yet.

Here's the link you requested: https://search.yahoo.com/search?fr=opensearch&p=firefox&b=1 When I tried to restart in safe mode using your method, I did NOT get the option to 'start in safe mode'. All I got was an option to 'disable all add-ons and restart'. I have not tried to restart in safe mode yet.
jscher2000
  • Top 10 Contributor
8837 solutions 72222 answers

Your link looks like a normal search results page link for Yahoo. I don't see any indication that it's a specially secured page.

OhioFirefoxUser said

When I tried to restart in safe mode using your method, I did NOT get the option to 'start in safe mode'. All I got was an option to 'disable all add-ons and restart'. I have not tried to restart in safe mode yet.

That's okay, that's what I meant by "approve the restart."

Your link looks like a normal search results page link for Yahoo. I don't see any indication that it's a specially secured page. ''OhioFirefoxUser [[#answer-1141282|said]]'' <blockquote> When I tried to restart in safe mode using your method, I did NOT get the option to 'start in safe mode'. All I got was an option to 'disable all add-ons and restart'. I have not tried to restart in safe mode yet. </blockquote> That's okay, that's what I meant by "approve the restart."