Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Twitter. The Media could not be Played.

  • 3 replies
  • 2 have this problem
  • 6811 views
  • Last reply by Chorlton

more options

Some time this week [?] things went wrong. Last Firefox update was to 61.0+linuxmint1+sylvia on 13/07/18 and included update of the flash-plugin.

Elsewhere I have found mention of... https://www.youtube.com/html5/ which informs me under "What does this browser support?" that my browser supports all of the six items listed.

I also have the Chromium Browser installed which reports the same but has no problems playing media on Twitter. Last update was 17/07/18 and at the same time chromium-codecs-ffmpeg-extra was updated.

I run NoScript uBlockOrigin and PrivacyBadger in Firefox but switching them off has no effect.

What else might I try?

Thanks.

Chosen solution

Hi, thanks for the replies. Apologies for the late response.

It turns out it was my fault or Twitters or... Anyway when freshly started the media playback works but I have been deactivating old Twitter accounts and after doing so that is when the playback stops working.

I can only guess that Twitter is setting some sort of cookie that causes it to kill the playback. If I restart Firefox then playback is active again.

Read this answer in context 👍 0

All Replies (3)

more options

Hi, Try Firefox Safe Mode to TEST & see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

more options
more options

Chosen Solution

Hi, thanks for the replies. Apologies for the late response.

It turns out it was my fault or Twitters or... Anyway when freshly started the media playback works but I have been deactivating old Twitter accounts and after doing so that is when the playback stops working.

I can only guess that Twitter is setting some sort of cookie that causes it to kill the playback. If I restart Firefox then playback is active again.