Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox download, library and menu buttons not working sice last update

  • 6 replies
  • 1 has this problem
  • 545 views
  • Last reply by michali

more options

I'm running Firefox 61 on up-to-date Kubuntu system. After the recent update, the buttons in upper right corner - for Download, Library and Menu are not working properly. After clicking them, nothing happens. Surprisingly, if I afterwards click below them, the actions (for example opening the downloaded item) happens. So the window is there, but invisible.

The bookmark button works fine.

Chosen solution

Do not try the generic try a Refresh suggestion as that is not going to help with this.

michali said

I'm running Firefox 61 on up-to-date Kubuntu system. . . So the window is there, but invisible.

A number of people using Firefox on KDE desktop on Ubuntu and Mint for example has had this issue.

/questions/1225327 rhuffman said

I changed the KDE rendering backend to xrender and it works again!
/questions/1226305

Read this answer in context 👍 0

All Replies (6)

more options

This is how it looks like, even after clicking any of the mentioned buttons.

more options

Hi, where are you getting your install from as that maybe the problem when they put it together wrong. Can try and use one from here :

Or try doing a Refresh : Note that this does more than uninstalling and re-installing does. Normal uninstalling does not remove some preferences which may have become corrupt. Please Refresh but do this 1st:

then

TEST.......

more options

Pkshadow said

Hi, where are you getting your install from as that maybe the problem when they put it together wrong.

He posted here with an Ubuntu build of Firefox 61.0.

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:61.0) Gecko/20100101 Firefox/61.0

more options

The default Kubuntu repository.

more options

Chosen Solution

Do not try the generic try a Refresh suggestion as that is not going to help with this.

michali said

I'm running Firefox 61 on up-to-date Kubuntu system. . . So the window is there, but invisible.

A number of people using Firefox on KDE desktop on Ubuntu and Mint for example has had this issue.

/questions/1225327 rhuffman said

I changed the KDE rendering backend to xrender and it works again!
/questions/1226305

Modified by James

more options

Thank you. Changing to xrender works for me.

However, this is a workaround - I recommend still treating it as a bug which needs to be solved for everyone.