Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox uses jfif instead of jpg in web picture downloads. Windows 10

  • 4 replies
  • 2 have this problem
  • 5154 views
  • Last reply by Endarion

more options

Pictures/clipart from websites are suddenly being saved as jfif instead of jpg. There seems to be no alternatives available when choosing "save image as..." Problem does not occur with Chrome. How do address this issue in Firefox?

Chosen solution

Hi, please : uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files , C:\Program Files(x86) & C:\ProgramData Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do :

Reinstall with Current Release Firefox 61.0.1 with a Full Version Installer

Please let us know if this solved your issue or if need further assistance.

Read this answer in context 👍 0

All Replies (4)

more options

Chosen Solution

Hi, please : uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files , C:\Program Files(x86) & C:\ProgramData Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do :

Reinstall with Current Release Firefox 61.0.1 with a Full Version Installer

Please let us know if this solved your issue or if need further assistance.

more options

having this problem the above solution did not fix it help please

Modified by Endarion

more options

You can inspect the MIME database key with the registry editor (regedit.exe) and do a search for that MIME type (file extension) via Ctrl+F. Be cautious with editing the registry as there is NO UNDO possible: all changes are applied immediately. You can export key(s) in the registry editor before making changes. You can check specific file extension keys (e.g. .jpg) in the registry with the registry editor.

  • HKEY_CLASSES_ROOT\.xxx

You can check a possibly linked MIME type in the MIME Database registry key.

  • HKEY_CLASSES_ROOT\MIME\Database\Content Type\
more options

cor-el said

You can inspect the MIME database key with the registry editor (regedit.exe) and do a search for that MIME type (file extension) via Ctrl+F. Be cautious with editing the registry as there is NO UNDO possible: all changes are applied immediately. You can export key(s) in the registry editor before making changes. You can check specific file extension keys (e.g. .jpg) in the registry with the registry editor.
  • HKEY_CLASSES_ROOT\.xxx
You can check a possibly linked MIME type in the MIME Database registry key.
  • HKEY_CLASSES_ROOT\MIME\Database\Content Type\


this fixed it, hope it won't cause other problem in future tho..