Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Frequent random pauses / micro hangs

  • 4 replies
  • 2 have this problem
  • 1681 views
  • Last reply by dahak777

more options

Lately I have been getting a lot of random hangs and freezes/pauses is the best I can describe it. For example, I will open a page, start to scroll, it will pause, and then waits, and resumes. Does not matter if scrolling or not. Sometimes it will pause even when opening a tab or site, even going into the options menu They last about 2-5 seconds and they happen pretty much all the time. I cannot seem to find a reason why.

Tried safe-mode firefox Tried refresh firefox Tried with no addons Tried with fresh Firefox profile as its a new laptop and a fresh install, I had even formatted and re-installed windows and it still doing it Tried 32-bit, tried 64-bit firefox, even tried some of the nightly builds and same thing. random hangs/pauses Tried turning down the number of processes, tried turning off hardware acceleration

Tried to see if there was anything with process explorer, and process monitor but and seem to see anything there either

Chrome, IE, Edge all work fine as well, seem to be isolate ot just firefox

Chosen solution

ok, thanks. please see if the following steps fix the performance problem: go to the firefox menu ≡ > options > privacy & security panel and under permissions check the setting to prevent accessibility services from accessing your browser. then restart firefox once...

Read this answer in context 👍 1

All Replies (4)

more options

hi dahak777, thanks for reporting this. could you capture a performance profile while the problem is happening as explained in https://developer.mozilla.org/en-US/docs/Mozilla/Performance/Reporting_a_Performance_Problem and share the url to the profile with us?

more options

Here is the link

It did about half a dozen times while I had it running. It did it again just before I ended

more options

Chosen Solution

ok, thanks. please see if the following steps fix the performance problem: go to the firefox menu ≡ > options > privacy & security panel and under permissions check the setting to prevent accessibility services from accessing your browser. then restart firefox once...

more options

It looks like that may have fixed it. I will have to try to see if I notice it again tomorrow as later in the day I get used to it doing it, so I am expecting it more.

EDIT --- It looks like turning off access to the accessibility options has resolved the problem. I have not seen it at all this morning and I was heavily switching between tabs and searching and would have noticed it if it as still an issue

Modified by dahak777