Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do you block images?

  • 2 replies
  • 1 has this problem
  • 8461 views
  • Last reply by ncrudup

more options

Hello, Is there a way to block images on Firefox for desktop computers? I noticed that on Firefox for mobile there is a Data Saver in the Advanced section of the settings menu that blocks images.

Hello, Is there a way to block images on Firefox for desktop computers? I noticed that on Firefox for mobile there is a Data Saver in the Advanced section of the settings menu that blocks images.

Chosen solution

You can disable images on the about:config page :

Type about:config in the address bar and press Enter (accept the risk, if asked) Type in the search bar : permissions.default.image and set its value to 2

Then close and restart Firefox.

Also see : http://www.tech-recipes.com/rx/64881/how-to-disable-images-in-firefox/

Note : If you want to disable the loading of images per site : Click on the Page Info icon (little i in a circle at the left end of the address bar) - click on the little black arrow, then on 'More Information'. Under the Permissions tab, scroll down to 'Load images' - uncheck 'Use Default' and check 'Block'.

Read this answer in context 👍 1

All Replies (2)

more options

Chosen Solution

You can disable images on the about:config page :

Type about:config in the address bar and press Enter (accept the risk, if asked) Type in the search bar : permissions.default.image and set its value to 2

Then close and restart Firefox.

Also see : http://www.tech-recipes.com/rx/64881/how-to-disable-images-in-firefox/

Note : If you want to disable the loading of images per site : Click on the Page Info icon (little i in a circle at the left end of the address bar) - click on the little black arrow, then on 'More Information'. Under the Permissions tab, scroll down to 'Load images' - uncheck 'Use Default' and check 'Block'.

more options

Thank you for your response.