Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

My menu settings does not open nor my add-ons work. Im on Firefox 61.0.1 (64-bit) on Linux mint 18.3 KDE

  • 4 replies
  • 2 have this problem
  • 468 views
  • Last reply by James

more options

My mozilla Menu settings (3 line bars) won't work nor my add-ons. I did a major upgrade on my pc the past days

Chosen solution

ale_110 said

Hi Welsey, I reinstalled firefox 61* and firefox 60* as well installed it through the main repository. Unfortunately the problem persisted. Do you have other solution?

Recently another poster using Firefox while using KDE on Ubuntu 16.04.1 had a invisible menus issue and was able to fix it.

https://support.mozilla.org/en-US/questions/1225327 rhuffman said

I changed the KDE rendering backend to xrender and it works again!
Read this answer in context 👍 0

All Replies (4)

more options

Certain Firefox problems can be solved by performing a Clean reinstall. This means you remove your Firefox program files and then reinstall Firefox. This process does not remove your Firefox profile data (such as bookmarks and passwords), since that information is stored in a different location.

To do a clean reinstall of Firefox, please follow these steps: Note: You might want to print these steps or view them in another browser.

  1. Download the latest Desktop version of Firefox from mozilla.org (or choose the download for your operating system and language from this page) and save the setup file to your computer.
  2. After the download finishes, close all Firefox windows (or open the Firefox menu New Fx Menu and click the close button Close 29 ).
  3. Delete the Firefox installation folder, which is located in one of these locations, by default:
    • Windows:
      • C:\Program Files\Mozilla Firefox
      • C:\Program Files (x86)\Mozilla Firefox
    • Mac: Delete Firefox from the Applications folder.
    • Linux: If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it - see Install Firefox on Linux. If you downloaded and installed the binary package from the Firefox download page, simply remove the folder firefox in your home directory.
  4. Now, go ahead and reinstall Firefox:
    1. Double-click the downloaded installation file and go through the steps of the installation wizard.
    2. Once the wizard is finished, choose to directly open Firefox after clicking the Finish button.

More information about reinstalling Firefox can be found here.

WARNING: Do not use a third party uninstaller as part of this process. Doing so could permanently delete your Firefox profile data, including but not limited to, extensions, cache, cookies, bookmarks, personal settings and saved passwords. These cannot be easily recovered unless they have been backed up to an external device! See Back up and restore information in Firefox profiles.

Please report back to say if this helped you!

Thank you.

more options

Hi Welsey, I reinstalled firefox 61* and firefox 60* as well installed it through the main repository. Unfortunately the problem persisted. Do you have other solution?

more options

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

more options

Chosen Solution

ale_110 said

Hi Welsey, I reinstalled firefox 61* and firefox 60* as well installed it through the main repository. Unfortunately the problem persisted. Do you have other solution?

Recently another poster using Firefox while using KDE on Ubuntu 16.04.1 had a invisible menus issue and was able to fix it.

https://support.mozilla.org/en-US/questions/1225327 rhuffman said

I changed the KDE rendering backend to xrender and it works again!

Modified by James