Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

firefox very slow load when bring to front

  • 1 reply
  • 1 has this problem
  • 8 views
  • Last reply by Shadow110

more options

my c drive very busy, virtual memory on a different physical drive that is only slightly busy, out of sleep or idle. memory usage at about 30%, cpu usage very low, virtual memory drive light some flickering, c drive light solid (indicating heavy usage) it's been like this many months multiple updates and still the same. only firefox slow from idle on this pc, other apps slow only when low on ram.

my c drive very busy, virtual memory on a different physical drive that is only slightly busy, out of sleep or idle. memory usage at about 30%, cpu usage very low, virtual memory drive light some flickering, c drive light solid (indicating heavy usage) it's been like this many months multiple updates and still the same. only firefox slow from idle on this pc, other apps slow only when low on ram.

All Replies (1)

more options

Separate Security Issue, please update your Flash 27.0 r0 by removing it with this tool : https://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html Reinstall with Flash Player Version: 30.0.0.113 Current Version https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, . . . .) Note: Other software is offered in the download. <Windows Only>

Hi, Next time might want to get the Full Version Installer and install to the other drive what will of course : https://www.mozilla.org/firefox/all/

To be Checked and turned off unless needed for accessibility : Please : go to the Firefox 3 Bar Menu --> Options --> Privacy & Security panel and under Permissions check (put a tick in the box) the setting to Prevent Accessibility Services from accessing your browser.

Might want to start here and check to make sure : https://www.adlice.com/download/roguekiller/ use Portable

Multi-Processor Support : Go to the 3 Bar Menu then Options --> General --> Performance and untick everything. change the recommended size lower then see how it runs. Note: 1 = No Multiprocessor = slow again. Try 2 Restart Firefox after making these changes please. Note : Hardware Acceleration is for Video Card, Monitor to see if remain off or to turn back on.

If not interested in sessions or if are use recommended or 3x's it like I did: https://www.servethehome.com/firefox-is-eating-your-ssd-here-is-how-to-fix-it/

Please let us know if this solved your issue or if need further assistance.