X
Tap here to go to the mobile version of the site.

Support Forum

Secure Connection Failed: Error code: SSL_ERROR_RX_RECORD_TOO_LONG

Posted

Firefox 61.0 (64 bit) Windows 7 Home Premium Avast Free Version 18.5.2342 No Proxy

When accessing Google from Firefox, the above error code is displayed each time. Firefox was reset but the issue remains and only with Firefox.

What is the fix?

Firefox 61.0 (64 bit) Windows 7 Home Premium Avast Free Version 18.5.2342 No Proxy When accessing Google from Firefox, the above error code is displayed each time. Firefox was reset but the issue remains and only with Firefox. What is the fix?

Modified by Buddy2014

Additional System Details

Installed Plug-ins

  • Shockwave Flash 30.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0

More Information

philipp
  • Top 25 Contributor
  • Moderator
5280 solutions 23327 answers

thanks for reporting the problem, so far we have heard about this from avast/avg users whose security software is meddling with encrypted connections. firefox 61 introduced the better security protocol tls 1.3 & apparently avast can't cope with that yet.

as a workaround, please try to disable the scanning of https connections as described in https://support.mozilla.org/en-US/kb/secure-connection-failed-error-message#w_avast-and-avg-security-products

thanks for reporting the problem, so far we have heard about this from avast/avg users whose security software is meddling with encrypted connections. firefox 61 introduced the better security protocol tls 1.3 & apparently avast can't cope with that yet. as a workaround, please try to disable the scanning of https connections as described in https://support.mozilla.org/en-US/kb/secure-connection-failed-error-message#w_avast-and-avg-security-products

Question owner

Philipp:

Yes, I should have mentioned that I am using the latest free version of Avast.

I am not going to tamper with any of the workarounds that you suggested. Instead, I posted this issue in the Avast forum so I will wait for them to offer a solution.

Philipp: Yes, I should have mentioned that I am using the latest free version of Avast. I am not going to tamper with any of the workarounds that you suggested. Instead, I posted this issue in the Avast forum so I will wait for them to offer a solution.

Modified by Buddy2014