X
Tap here to go to the mobile version of the site.

Support Forum

Firefox keeps crashing... mostly on Facebook. Gah! Your tab just crashed

Posted

So as the question states I keep getting the 'Gah! Your tab just crashed' I've used FF since day one and never had this problem. This is a fresh install on a fresh windows 7 install with my data folder copied over from other pc. Everything worked perfectly there.

At first this was happening on every page... especially major ones like Amazon, You Tube etc. Now it seems pretty much just centered on Facebook.

I tried this since I saw it mentioned many times for this issue. browser.tabs.remote.autostart = false browser.tabs.remote.autostart.2 = false

I just did the first one as the second is not in my about:config list. All this did was make FF crash on Facebook instead of just giving me the Gah page.

I've been dealing with this for days now and its frustrating as hell. BTW: ZERO problems on Chrome so its nothing on my computer.

So as the question states I keep getting the 'Gah! Your tab just crashed' I've used FF since day one and never had this problem. This is a fresh install on a fresh windows 7 install with my data folder copied over from other pc. Everything worked perfectly there. At first this was happening on every page... especially major ones like Amazon, You Tube etc. Now it seems pretty much just centered on Facebook. I tried this since I saw it mentioned many times for this issue. browser.tabs.remote.autostart = false browser.tabs.remote.autostart.2 = false I just did the first one as the second is not in my about:config list. All this did was make FF crash on Facebook instead of just giving me the Gah page. I've been dealing with this for days now and its frustrating as hell. BTW: ZERO problems on Chrome so its nothing on my computer.

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0

More Information

philipp
  • Top 25 Contributor
  • Moderator
5322 solutions 23502 answers

hello, could you provide your latest few submitted crash reports? please enter about:crashes into the location bar, copy the latest few report ids from there starting with bp- & paste them here into a forum reply. this will give us a better understanding what may be triggering those crashes.

hello, could you provide your latest few submitted crash reports? please enter '''about:crashes''' into the location bar, copy the latest few report ids from there starting with '''bp-''' & paste them here into a forum reply. this will give us a better understanding what may be triggering those crashes.

Question owner

Here you go. Just made a fresh one. Facebook lasted about 3 seconds.

Just to mention after I made my post I completely uninstalled and completely deleted all the info in my FF folder then reinstalled FF. Tried again without importing any of my old data just to see if something was an issue there. But it didn't work. So back running with my original data again.

bp-8949e8a3-58d0-4bdd-9650-cbfa40180627

Here you go. Just made a fresh one. Facebook lasted about 3 seconds. Just to mention after I made my post I completely uninstalled and completely deleted all the info in my FF folder then reinstalled FF. Tried again without importing any of my old data just to see if something was an issue there. But it didn't work. So back running with my original data again. bp-8949e8a3-58d0-4bdd-9650-cbfa40180627
philipp
  • Top 25 Contributor
  • Moderator
5322 solutions 23502 answers

thanks, it looks like malwarebytes anti-exploit plays a role in this crash - you might want to disable it or look into its settings...

thanks, it looks like malwarebytes anti-exploit plays a role in this crash - you might want to disable it or look into its settings...

Question owner

I shut down Malwarebytes.... rebooted FF. Same issue :-(

I shut down Malwarebytes.... rebooted FF. Same issue :-(
philipp
  • Top 25 Contributor
  • Moderator
5322 solutions 23502 answers

can you please include the report's id that happened without mbae, thnx...

can you please include the report's id that happened without mbae, thnx...

Question owner

0b25a193-9aba-4b63-9991-e4adb85ddbff

0b25a193-9aba-4b63-9991-e4adb85ddbff

Question owner

bp-f5502f0c-9f5a-4a34-b0e2-fa5140180627

bp-f5502f0c-9f5a-4a34-b0e2-fa5140180627
philipp
  • Top 25 Contributor
  • Moderator
5322 solutions 23502 answers

thanks, unfortunately this does still show involvement of malwarebytes anti-exploit. if shutting it off alone isn't enough please try totally uninstalling it once for testing purposes.

thanks, unfortunately this does still show involvement of malwarebytes anti-exploit. if shutting it off alone isn't enough please try totally uninstalling it once for testing purposes.

Question owner

Well, I've never looked at these before but I assumed you meant lines 13 and 14 under the 'Crashing Thread (64), Name: MediaPlayback #1' area.... mbae64.dll...

These are not listed in the new crash log.... it ends with msmpeg2vdec.dll

What indicates malwarebytes?

Well, I've never looked at these before but I assumed you meant lines 13 and 14 under the 'Crashing Thread (64), Name: MediaPlayback #1' area.... mbae64.dll... These are not listed in the new crash log.... it ends with msmpeg2vdec.dll What indicates malwarebytes?

Question owner

As a side note I've ran MWB and Norton together for years with Firefox... These problems just started with my new build.

As a side note I've ran MWB and Norton together for years with Firefox... These problems just started with my new build.
philipp
  • Top 25 Contributor
  • Moderator
5322 solutions 23502 answers

if you click on show other threads or the modules tab "mbae64.dll" is still there. i'm not a 100% sure that it is the root of the crash, but it's certainly worth testing how firefox is behaving without it...

if you click on show other threads or the modules tab "mbae64.dll" is still there. i'm not a 100% sure that it is the root of the crash, but it's certainly worth testing how firefox is behaving without it...

Question owner

Doh! Didn't even notice all the tabs on top. I have to head out for a couple hours so I'll have to continue on this later and try what you said. In the mean time if you think of anything else it could be please let me know... Like I said I've been using them together at least 5 years with no issues... but you never know.

Thanks.

Doh! Didn't even notice all the tabs on top. I have to head out for a couple hours so I'll have to continue on this later and try what you said. In the mean time if you think of anything else it could be please let me know... Like I said I've been using them together at least 5 years with no issues... but you never know. Thanks.

Question owner

Can you see if this worked. I shut down malwarebytes. Disabled startup in msconfig Rebooted

Same problem in FF bp-3c4255ab-badc-43b8-8e0e-77de60180627

Trying to avoid uninstalling MB if I don't have to.

Thanks.

Can you see if this worked. I shut down malwarebytes. Disabled startup in msconfig Rebooted Same problem in FF bp-3c4255ab-badc-43b8-8e0e-77de60180627 Trying to avoid uninstalling MB if I don't have to. Thanks.
philipp
  • Top 25 Contributor
  • Moderator
5322 solutions 23502 answers

does the facebook tab still crash when you make this configuration change?

enter about:config into the firefox address bar (confirm the info message in case it shows up) & search for the preference named media.wmf.enabled. double-click it and change its value to false.

does the facebook tab still crash when you make this configuration change? enter '''about:config''' into the firefox address bar (confirm the info message in case it shows up) & search for the preference named '''media.wmf.enabled'''. double-click it and change its value to '''false'''.

Question owner

philipp said

does the facebook tab still crash when you make this configuration change? enter about:config into the firefox address bar (confirm the info message in case it shows up) & search for the preference named media.wmf.enabled. double-click it and change its value to false.

I was just about to post another crash log when your post came... because YouTube can be troublesome with this as well.

That seems to have fixed the situation! THANK YOU!!

Just out of curiosity can you tell me what that setting actually does?

''philipp [[#answer-1127437|said]]'' <blockquote> does the facebook tab still crash when you make this configuration change? enter '''about:config''' into the firefox address bar (confirm the info message in case it shows up) & search for the preference named '''media.wmf.enabled'''. double-click it and change its value to '''false'''. </blockquote> I was just about to post another crash log when your post came... because YouTube can be troublesome with this as well. That seems to have fixed the situation! THANK YOU!! Just out of curiosity can you tell me what that setting actually does?
philipp
  • Top 25 Contributor
  • Moderator
5322 solutions 23502 answers

this preference disables firefox handing over media content to the "windows media foundation" part of the operating system for playback, because firefox itself is lacking the decoding support for some non-royalty free formats like h.264. so having this pref disabled in general might lead to problems playing back some form of media contents on the web.

i don't entirely understand in which way your crashes where triggered, but you could try switching back media.wmf.enabled to its default and instead playing around with those other prefs to see if one of them also would solve the issue:

  • media.wmf.dxva.d3d11.enabled
  • media.wmf.dxva.enabled
  • media.wmf.low-latency.enabled
  • media.wmf.use-nv12-format
  • media.wmf.vp9.enabled
this preference disables firefox handing over media content to the "windows media foundation" part of the operating system for playback, because firefox itself is lacking the decoding support for some non-royalty free formats like h.264. so having this pref disabled in general might lead to problems playing back some form of media contents on the web. i don't entirely understand in which way your crashes where triggered, but you could try switching back media.wmf.enabled to its default and instead playing around with those other prefs to see if one of them also would solve the issue: * media.wmf.dxva.d3d11.enabled * media.wmf.dxva.enabled * media.wmf.low-latency.enabled * media.wmf.use-nv12-format * media.wmf.vp9.enabled