Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to fix crackling sound on youtube livestreams

  • 10 replies
  • 1 has this problem
  • 6657 views
  • Last reply by Cri1654

more options

I only have this problem on firefox. On chrome all livestreams are fine, but on firefox there is this crackling noise that is driving me crazy. Everytime i have to open chrome and firefox just for a music livestream. I've already tried everything but the issue is still here. Can someone help me solve this?

Chosen solution

It could be your soundcard. Is it realtek? You could try updating those drivers.

Read this answer in context 👍 0

All Replies (10)

more options

Hi, please Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

more options

I've alredy tried this and my problem didn't solve. Any other solution?

more options

How was your FF update or installed?

more options

I installed it manually from mozilla's site.

more options

Hi, when you come to the forum it would have been great to have known you had already tried Safe Mode. Please give full details next time please and with anything asked of you here.

uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files , C:\Program Files(x86) & C:\ProgramData Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do :

Reinstall with Current Release Firefox 61.0.0 with a Full Version Installer

Please let us know if this solved your issue or if need further assistance.

more options

Hello, sorry for the late responde. Unfortunately that didn't solve my issue and the annoying sound is still on the youtube livestreams. Any other solutions?

more options

So you removed and delete any traces of FF and reinstalled FF and the problem exists? This would indicate driver issues or driver conflicts with another software and isn't a FF Browser caused.

more options

The thing is that it does not happen in chrome and only happens in firefox. It's so strange. I don't really wanna mess with my drivers, because the last time i did that i had to replace my hard drive.

more options

Chosen Solution

It could be your soundcard. Is it realtek? You could try updating those drivers.

more options

I just updated my realtek audio drivers and the problem seems to be gone! I didn't wanna mess with the drivers anymore but that was actually the solution