Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Search from navigation bar doesn't work

  • 13 replies
  • 1 has this problem
  • 188 views
  • Last reply by cor-el

more options

I'm unable to search from the navigation bar anymore. Instead of it automatically searching using my selected search engine it tries to resolve whatever I type as an actual URL. I've tried switching the search engine in settings but that doesn't work either.

I uninstalled firefox and reinstalled it but the problem was still there. I also tried to launch in safe mode with no change.

Any help would be great! Thanks!

Chosen solution

jimbobway200 said

So i looked up the value for keyword.enabled in about:config and it's listed as false and that the status is "locked" I don't see an option to change this (makes sense since it's locked)... any ideas on what could be "locking" this setting?

Are you in a managed environment where an IT department might control settings on your Firefox? If not, please check in these locations (varies for 32-bit / 64-bit):

C:\Program Files\Mozilla Firefox\defaults\pref
C:\Program Files (x86)\Mozilla Firefox\defaults\pref

Any files other than channel-prefs.js are suspicious. Remove them to a neutral location for further analysis at your leisure; but do not double-click any script files, as Windows may execute them as system scripts.

Read this answer in context 👍 0

All Replies (13)

more options

Where are you talking "navigation bar" is at?

more options

Hi jimbobway200, here's how it normally works:

  • if you start typing, Firefox may show a matching site suggestion in the bar; if you press Enter at that point, Firefox will load that address
  • if you start typing and there's no "autofill" match, then Firefox should display at the top of the drop-down what's going to happen when you press Enter:
    • for a query matching the pattern text.text -- Firefox will try to load it as a web address
    • for a query matching the pattern text text -- or having other characters illegal in a domain name -- Firefox will send it to your default search engine
    • for a query matching the pattern text -- Firefox will send it to your default search engine and the check whether it could be a valid local domain (e.g., intranet)

If Firefox never sends any of your address bar queries to search, could you check this setting:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste keyw and pause while the list is filtered

(3) If the keyword.enabled preference is bolded and "modified" or "user set" to false, double-click it to restore the default value of true

more options
more options

Separate Security Issue, please update your Flash 29.0 r0 Flash Player Version: 30.0.0.113 Current Version https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, . . . .) Note: Other software is offered in the download. <Windows Only>

more options

Pkshadow, not sure if that was supposed to correct it or if it was general guidance but that didn't correct it.

jscher2000, I'm referring to the text text scenario where Firefox should send it to my default search engine. On a different computer that has firefox working as expected it shows up with what I'm typing with Google at the front (indicating that it's going to search google for that string once I hit enter. On my non-working computer it simply says visit next to anything I type if it doesn't match any website I've visited before. So i looked up the value for keyword.enabled in about:config and it's listed as false and that the status is "locked" I don't see an option to change this (makes sense since it's locked)... any ideas on what could be "locking" this setting?

more options

Chosen Solution

jimbobway200 said

So i looked up the value for keyword.enabled in about:config and it's listed as false and that the status is "locked" I don't see an option to change this (makes sense since it's locked)... any ideas on what could be "locking" this setting?

Are you in a managed environment where an IT department might control settings on your Firefox? If not, please check in these locations (varies for 32-bit / 64-bit):

C:\Program Files\Mozilla Firefox\defaults\pref
C:\Program Files (x86)\Mozilla Firefox\defaults\pref

Any files other than channel-prefs.js are suspicious. Remove them to a neutral location for further analysis at your leisure; but do not double-click any script files, as Windows may execute them as system scripts.

more options
more options

There was a autoconfig.js file there which pointed to a mozilla.cfg file. In that config file there was a line disabling the keyword.enabled feature. I commented out this line, restarted firefox, and it worked! Thank you so much!

more options

That could have been part of a malware bundle which sought to force a particular search engine via unwanted extension. Hopefully you got rid of any other parts, too.

more options

Can you post the full content of your mozilla.cfg file?

Normally the mozilla.cfg file and the autoconfig.js file shouldn't be there unless you or your IT department have added it.

more options

Looks like my mozilla.cfg was put there by my IT department due to security policies in place I'm won't be posting the file. The keyword.enabled feature got re-enabled so I'm guessing there is a background process on my system that monitors this. I'll reach out to my IT department regarding this. Thanks!

more options

If your IT doesn't want data accidentally sent to search, one workaround is to re-add the classic search bar to your toolbar. See: Search with the Firefox address bar.

more options

You can enable the search bar on the Navigation Toolbar via "Options/Preferences -> Search" if this bar is currently not visible as a possible workaround or drag the search bar from the Customize palette to the Navigation Toolbar overflow area (>>) if you aren't using it that often.