X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Default Search Engine setting for Location Bar not being invoked

Posted

Have set default search engine for Location bar to Google but it doesn't work - always seems to use Yahoo (which I don't want). Have tried clearing history to make sure that no previous Yahoo searches get picked up (searching Bookmarks and History) but every time I type something in the Locator bar that implies a Search -- Yahoo comes up. Note that I my default Search Engine in the Search Bar is Google and it DOES work . I've gone so far as to remove Yahoo from the list of alternate search engines in that Bar too.

Additional System Details

This happened

Every time Firefox opened

This started when...

Shortly after I decided to clear my cache (and history too, I think)

Installed Plug-ins

  • ActiveTouch General Plugin Container Version 103
  • ActiveTouch General Plugin Container Version 105
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Default Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.1"
  • 12.0.1.609
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealJukebox Netscape Plugin
  • Shockwave Flash 10.1 r102
  • Adobe Shockwave for Director Netscape plug-in, version 11.5.9.615
  • iTunes Detector Plug-in
  • Picasa plugin
  • Next Generation Java Plug-in 1.6.0_22 for Mozilla browsers
  • 4.0.50524.0
  • Google Updater pluginhttp://pack.google.com/
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12

More Information

Note that I've done a search on this issue before and followed the suggestion for re-setting default engine to Google (about:config, etc.) and yes.. Yahoo WAS the default engine .. but I reset it to Google and have checked it since to ensure that it hasn't changed to Yahoo. It's still Google but Yahoo is what gets invoked, regardless.

risen 0 solutions 2 answers

I ran into this post when googling for the reason why I was getting this problem as well. It turns out that in my case McAfee has designated Yahoo as it's "safe search" engine and re-writes Yahoo as the default search engine to pop up when you type something into the URL bar.

I found this explantion on fixing it, but am clueless how to replace it with a google search string. ( http://www.ghacks.net/2008/04/20/change-the-firefox-location-bar-search-engine/ )

Changing it to google btw makes McAfee pop up and say I have selected a non secure search option and whether I want to change it back.

risen 0 solutions 2 answers

Helpful Reply

http://www.google.co.uk/search?q=

Thats the google URL to input in the field to put it back to google as a default.

phalturam 0 solutions 1 answers

Helpful Reply

Yahoo toolbar has perhaps taken over your browser. To change the default search engine for location bar,

Type in location bar - about:config Search using filter - keyword.URL Replace the yahoo address with - http://www.google.com/search?q=