X
Tap here to go to the mobile version of the site.

Support Forum

Firefox freezes when opening web links

Posted

When attempting to open links in a new tab with the middle mouse button (MMB), Firefox freezes for a few seconds before going on with loading the webpage. Occasionally this happens also when searching for something through the address bar. Following suggestions on similar topics on the forums, I tried starting Firefox in safe mode, but the problem persists. In fact, after starting in safe mode, an additional problem appeared: after trying to re-load the tabs from my last session, Firefox froze on each and every one until the page had loaded completely. To emphasize and make the problems as clear as possible:

-Firefox freezes for a second or two when opening ordinary web links in a new tab.

-Firefox freezes for a second or two when searching something through the address bar.

-After starting Firefox in safe mode, opening links freezes Firefox until the webpage is completely loaded.

When attempting to open links in a new tab with the middle mouse button (MMB), Firefox freezes for a few seconds before going on with loading the webpage. Occasionally this happens also when searching for something through the address bar. Following suggestions on similar topics on the forums, I tried starting Firefox in safe mode, but the problem persists. In fact, after starting in safe mode, an additional problem appeared: after trying to re-load the tabs from my last session, Firefox froze on each and every one until the page had loaded completely. To emphasize and make the problems as clear as possible: -Firefox freezes for a second or two when opening ordinary web links in a new tab. -Firefox freezes for a second or two when searching something through the address bar. -After starting Firefox in safe mode, opening links freezes Firefox until the webpage is completely loaded.

Modified by xedative

Chosen solution

My graphics card is a GeForce GTX 760. I check its drivers regularly and the updates are damn near automatic. Still, a forced re-installation of the newest drivers appears to have solved, or at least eased the problem. Thank you.

Read this answer in context 0

Additional System Details

Installed Plug-ins

Greasemonkey; Token signing; Adblock Plus; convert2mp3.net Online Video Converter 3.5

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0

More Information

WestEnd 60 solutions 5387 answers

If you have a 3 button mouse you should check for driver updates before using it as that could be also the cause of the lag response as well. Most mouse are 2 buttons for Windows 3 buttons mouse were more common for CAD/CAE/CAM applications only.

If you have a 3 button mouse you should check for driver updates before using it as that could be also the cause of the lag response as well. Most mouse are 2 buttons for Windows 3 buttons mouse were more common for CAD/CAE/CAM applications only.

Question owner

My mouse is using the latest drivers and has not had an update recently.

Also, most modern mice use at least three buttons, if not five, complete with browser back and browser forward functions. I'm not sure what decade your suggestion is from.

My mouse is using the latest drivers and has not had an update recently. Also, most modern mice use at least three buttons, if not five, complete with '''browser back''' and '''browser forward''' functions. I'm not sure what decade your suggestion is from.

Modified by xedative

FredMcD
  • Top 10 Contributor
4258 solutions 59626 answers
[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there? https://support.mozilla.org/kb/Firefox+is+already+running+but+is+not+responding https://support.mozilla.org/en-US/kb/firefox-slow-how-make-it-faster https://support.mozilla.org/en-US/kb/firefox-uses-too-many-cpu-resources-how-fix https://support.mozilla.org/en-US/kb/firefox-uses-too-much-memory-ram https://support.mozilla.org/en-US/kb/firefox-hangs-or-not-responding

Question owner

FredMcD said

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

As my original post said, I already tried starting Firefox in Safe Mode. The problem persists with an additional twist:

-After starting Firefox in safe mode, opening links freezes Firefox until the webpage is completely loaded.
''FredMcD [[#answer-1120275|said]]'' <blockquote> [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there? </blockquote> As my original post said, I already tried starting Firefox in Safe Mode. The problem persists with an additional twist: <blockquote> -After starting Firefox in safe mode, opening links freezes Firefox until the webpage is completely loaded. </blockquote>
Shadow110 1072 solutions 14836 answers

Please try this : uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files , C:\Program Files(x86) & C:\ProgramData Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do :

Reinstall with Current Release Firefox 60.0.2 with a Full Version Installer

Please let us know if this solved your issue or if need further assistance.

Please try this : uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files , C:\Program Files(x86) & C:\ProgramData Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do : *https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles *https://support.mozilla.org/en-US/kb/export-firefox-bookmarks-to-backup-or-transfer Reinstall with Current Release Firefox 60.0.2 with a Full Version Installer *https://www.mozilla.org/firefox/all/ Please let us know if this solved your issue or if need further assistance.

Question owner

Pkshadow said

Please try this : uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files , C:\Program Files(x86) & C:\ProgramData Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do : Reinstall with Current Release Firefox 60.0.2 with a Full Version Installer Please let us know if this solved your issue or if need further assistance.

Your suggestion seems to have fixed the problem, Pkshadow. Thank you tons.

EDIT: I'm unfortunately forced to take back the thanks, because the problem appears to still persist. It is, however, seemingly a little milder. While freezes upon opening links happened every 4 times out of 5, it is now closer to 1 or 2 times out of 5.

''Pkshadow [[#answer-1120303|said]]'' <blockquote> Please try this : uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files , C:\Program Files(x86) & C:\ProgramData Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do : *https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles *https://support.mozilla.org/en-US/kb/export-firefox-bookmarks-to-backup-or-transfer Reinstall with Current Release Firefox 60.0.2 with a Full Version Installer *https://www.mozilla.org/firefox/all/ Please let us know if this solved your issue or if need further assistance. </blockquote> Your suggestion seems to have fixed the problem, Pkshadow. Thank you tons. EDIT: I'm unfortunately forced to take back the thanks, because the problem appears to still persist. It is, however, seemingly a little milder. While freezes upon opening links happened every 4 times out of 5, it is now closer to 1 or 2 times out of 5.

Modified by xedative

Shadow110 1072 solutions 14836 answers

Hi, no need to blockquote everything : https://www.w3schools.com/tags/tag_blockquote.asp

To be Checked and turned off unless needed for accessibility : Please : go to the Firefox 3 Bar Menu --> Options --> Privacy & Security panel and under Permissions check (put a tick in the box) the setting to Prevent Accessibility Services from accessing your browser.

Multi-Processor Support : Go to the 3 Bar Menu then Options --> General --> Performance and untick everything. change the recommended size lower then see how it runs. Note: 1 = No Multiprocessor = slow again. Try 2 Restart Firefox after making these changes please. Note : Hardware Acceleration is for Video Card, Monitor to see if remain off or to turn back on.

Please let us know if this solved your issue or if need further assistance.

Hi, no need to blockquote everything : https://www.w3schools.com/tags/tag_blockquote.asp '''''To be Checked and turned off unless needed for accessibility : ''''' Please : go to the Firefox 3 Bar Menu --> Options --> Privacy & Security panel and under Permissions check (put a tick in the box) the setting to Prevent Accessibility Services from accessing your browser. '''''Multi-Processor Support : ''''' Go to the 3 Bar Menu then Options --> General --> Performance and untick everything. change the recommended size lower then see how it runs. Note: 1 = No Multiprocessor = slow again. Try 2 Restart Firefox after making these changes please. Note : Hardware Acceleration is for Video Card, Monitor to see if remain off or to turn back on. Please let us know if this solved your issue or if need further assistance.

Question owner

Prevent Accessibility Services has been checked. I also tried Multi-Processor support at various levels (including above the recommended 4) with no luck. Hardware Acceleration is kept on, this PC was built as very graphics-heavy. Temporary freezing when opening links (usually in a new tab) still persists.

Prevent Accessibility Services has been checked. I also tried Multi-Processor support at various levels (including ''above'' the recommended 4) with no luck. Hardware Acceleration is kept on, this PC was built as very graphics-heavy. Temporary freezing when opening links (usually in a new tab) still persists.

Modified by xedative

Shadow110 1072 solutions 14836 answers

No info came regarding your Video Card Drivers. Usually when send info to Mozilla is turned on can see what shape they are in if any errors.

If built for graphics then I would hope you can Install a new version from scratch and not just update. If not reinstall a full version installer of what ever card it is. Mine is AMD so get updates Monthly.

See if that helps as corrupted drivers can do a lot of weird stuff that would not think to look at them for.

No info came regarding your Video Card Drivers. Usually when send info to Mozilla is turned on can see what shape they are in if any errors. If built for graphics then I would hope you can Install a new version from scratch and not just update. If not reinstall a full version installer of what ever card it is. Mine is AMD so get updates Monthly. See if that helps as corrupted drivers can do a lot of weird stuff that would not think to look at them for.

Chosen Solution

My graphics card is a GeForce GTX 760. I check its drivers regularly and the updates are damn near automatic. Still, a forced re-installation of the newest drivers appears to have solved, or at least eased the problem. Thank you.

My graphics card is a GeForce GTX 760. I check its drivers regularly and the updates are damn near automatic. Still, a forced re-installation of the newest drivers appears to have solved, or at least eased the problem. Thank you.