X
Tap here to go to the mobile version of the site.

Support Forum

Stalling on page loading high ping on speedtest servers

Posted

Hello, Not sure what is wrong with firefox lately but since 60 release it is not the old good fox. Page loading is stalling, when I go to check my speed with firefox I;m getting high latency: Download speed 94.26 Mbps Upload speed 5.40 Mbps Ping 179 ms

Results from chrome:

Download speed 97.55 Mbps Upload speed 5.48 Mbps Ping 10 ms

I repeated this a few times and every time same results.

Not sure why firefox is stalling on page loading, and why is it giving high ping on speedtest servers. I can not measure speeed on speedtest.net. it is giving all kinds of errors even in safe mode, and when I manage to load it it gives very high ping, but everything is working fine in chrome and edge. I can not use another browser because I;m using firefox for years, switched after mozzila (R.I.P.) SO can you please fix this? I;m open to any suggestions.

Hello, Not sure what is wrong with firefox lately but since 60 release it is not the old good fox. Page loading is stalling, when I go to check my speed with firefox I;m getting high latency: Download speed 94.26 Mbps Upload speed 5.40 Mbps Ping 179 ms Results from chrome: Download speed 97.55 Mbps Upload speed 5.48 Mbps Ping 10 ms I repeated this a few times and every time same results. Not sure why firefox is stalling on page loading, and why is it giving high ping on speedtest servers. I can not measure speeed on speedtest.net. it is giving all kinds of errors even in safe mode, and when I manage to load it it gives very high ping, but everything is working fine in chrome and edge. I can not use another browser because I;m using firefox for years, switched after mozzila (R.I.P.) SO can you please fix this? I;m open to any suggestions.

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0

More Information

FredMcD
  • Top 10 Contributor
4271 solutions 59904 answers

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?

Question owner

Yes. As I said even in safe mode.

Yes. As I said even in safe mode.
FredMcD
  • Top 10 Contributor
4271 solutions 59904 answers

Start your Computer in safe mode with network support. Then start Firefox. Try Secure websites. Is the problem still there?

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia

Start your '''Computer''' in safe mode with network support. Then start Firefox. Try '''Secure''' websites. Is the problem still there? http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia
teiebra 0 solutions 4 answers

I have got the same issue with windows 10 and 61.0.2 (64 bit) I also have slowness in loading pages. Same also with fast.com (beyond speedtest.net as described at the beginning). Tried with no success also with a new empty profile and safe mode. I have had the same issue 3 months ago and solved by a a fresh installation on windows 10. But I cannot reistall every 3 minths only because firefox works badly. It is a pity, as Firefix is my favorite browser!

I have got the same issue with windows 10 and 61.0.2 (64 bit) I also have slowness in loading pages. Same also with fast.com (beyond speedtest.net as described at the beginning). Tried with no success also with a new empty profile and safe mode. I have had the same issue 3 months ago and solved by a a fresh installation on windows 10. But I cannot reistall every 3 minths only because firefox works badly. It is a pity, as Firefix is my favorite browser!
teiebra 0 solutions 4 answers

Still me .... Cannot realised what's happened, but the issue has disappeared .... Now Firefox gives results alligned with Chrome: ping time reported by now less than 10 ms (earlier it was at least 80 ms).

My feeling is that there was somthing wrong the way Firexox interfaces with Wi-Fi, Buy so far, nothing I can investigate more

Still me .... Cannot realised what's happened, but the issue has disappeared .... Now Firefox gives results alligned with Chrome: ping time reported by now less than 10 ms (earlier it was at least 80 ms). My feeling is that there was somthing wrong the way Firexox interfaces with Wi-Fi, Buy so far, nothing I can investigate more