Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox crashes

  • 4 replies
  • 1 has this problem
  • 80 views
  • Last reply by AlexMPH

more options

Firefox started crashing yesterday or today, at first when browsing to specific sites (plex.tv desktop app, bringatrailer.com), later on more frequently, even in safe mode

Chosen solution

Yes. Having TRR enabled (DNS-over-HTTPS) could be causing this issue https://www.ghacks.net/2018/04/02/configure-dns-over-https-in-firefox/

What is the value of this pref on the about:config page? Try to disable (0) this feature or try a lower value if it is currently 3

  • network.trr.mode = 0
Read this answer in context 👍 1

All Replies (4)

more options

Here is some additional info:

bp-127b52d3-55bd-4d1f-92d8-6daca0180521
bp-1805a8f0-5c13-420e-acf1-c8ad90180521
bp-91ede479-f9e9-471e-98e0-fe90e0180521
bp-83daa021-1e1b-4e84-aae4-90e870180521
bp-b8377116-e4e1-44fb-a8bf-7534e0180521
bp-9e5207bd-35e1-4f28-b37a-9a5dd1180520

(I got these after I had figured out that firefox crashes in safe mode when the Mozilla Crash Reporter is still running...)

Modified by cor-el

more options

FYI, I just remembered that I have enabled DNS over HTTPS recently - could this be linked? It seemed to work fine at first...

more options

Chosen Solution

Yes. Having TRR enabled (DNS-over-HTTPS) could be causing this issue https://www.ghacks.net/2018/04/02/configure-dns-over-https-in-firefox/

What is the value of this pref on the about:config page? Try to disable (0) this feature or try a lower value if it is currently 3

  • network.trr.mode = 0
more options

cor-el said

Yes. Having TRR enabled (DNS-over-HTTPS) could be causing this issue https://www.ghacks.net/2018/04/02/configure-dns-over-https-in-firefox/ What is the value of this pref on the about:config page? Try to disable (0) this feature or try a lower value if it is currently 3
  • network.trr.mode = 0

Hi cor-el,

This works! Value was at 2. Does this mean that DoH is still in alpha/beta phase for now? I used the link you provided when setting up DoH a couple of days ago.

Thanks a lot!!

Modified by AlexMPH