X
Tap here to go to the mobile version of the site.

Support Forum

Firefox starts only in windows 7 safe mode

Posted

Try use firefox safe mode, try reinstall, try a new profile, nothing works, still crashing at startup. I was using Firefox x86 before and ok. Problem started with x64 install. Sorry for possible english errors.

Try use firefox safe mode, try reinstall, try a new profile, nothing works, still crashing at startup. I was using Firefox x86 before and ok. Problem started with x64 install. Sorry for possible english errors.

Chosen solution

Well, finally I got the bad guy ... and now seems obvious. I use Comodo as firewall. My choice is because, as far as I know, Comodo uses its own network driver, not the Windows driver as many firewalls do. That way, I feel a little less hostage from Microsoft. Therefore, disable the security software in the Comodo case is not enough, uninstalling is required. Done that, problem solved. The X86 version of Firefox working well messed me up. Note: I have not tried a new Comodo setup yet. Thanks for attention !!!

Read this answer in context 0

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/66.0.3359.139 Safari/537.36

More Information

FredMcD
  • Top 10 Contributor
4269 solutions 59845 answers

When a computer is started in Safe Mode, only system programs are running. This means one of the other programs on your system is the issue.

Try disabling your protection programs as a test.

When a computer is started in Safe Mode, only system programs are running. This means one of the other programs on your system is the issue. Try disabling your protection programs as a test.

Question owner

Thanks by the Help ! I know that many drivers are not loaded in safe mode and I've already disabled my first suspects ... firewall and antivirus, but no luck. So I'm still trying to find the guilty. I wish I had another suspect... I'ts difficult to disable some software.

Thanks by the Help ! I know that many drivers are not loaded in safe mode and I've already disabled my first suspects ... firewall and antivirus, but no luck. So I'm still trying to find the guilty. I wish I had another suspect... I'ts difficult to disable some software.
FredMcD
  • Top 10 Contributor
4269 solutions 59845 answers

ronaldows said

still crashing at startup

In the address bar, type about:crashes<enter>. Note: If any reports do not have BP- in front of the numbers/letters, click it to submit them.

The crash report is several pages of data. We need the report numbers to see the whole report.

Using your mouse, mark the most recent 7 - 10 crash reports, and copy them. Now go to the reply box and paste them in.

aboutcrashesFx29

For more help on crash reports, see; https://support.mozilla.org/en-US/kb/firefox-crashes-asking-support

''ronaldows [[#question-1215916|said]]'' <blockquote> still crashing at startup </blockquote> In the address bar, type '''about:crashes'''<enter>. '''Note: ''' If any reports do not have '''BP-''' in front of the numbers/letters, click it to submit them. '''The crash report is several pages of data. We ''' '''need the report numbers to see the whole report. ''' Using your mouse, '''mark''' the '''most recent 7 - 10''' crash reports, and copy them. Now go to the reply box and paste them in. ;[[Image:aboutcrashesFx29|width=500]] For more help on crash reports, see; https://support.mozilla.org/en-US/kb/firefox-crashes-asking-support

Chosen Solution

Well, finally I got the bad guy ... and now seems obvious. I use Comodo as firewall. My choice is because, as far as I know, Comodo uses its own network driver, not the Windows driver as many firewalls do. That way, I feel a little less hostage from Microsoft. Therefore, disable the security software in the Comodo case is not enough, uninstalling is required. Done that, problem solved. The X86 version of Firefox working well messed me up. Note: I have not tried a new Comodo setup yet. Thanks for attention !!!

Well, finally I got the bad guy ... and now seems obvious. I use Comodo as firewall. My choice is because, as far as I know, Comodo uses its own network driver, not the Windows driver as many firewalls do. That way, I feel a little less hostage from Microsoft. Therefore, disable the security software in the Comodo case is not enough, uninstalling is required. Done that, problem solved. The X86 version of Firefox working well messed me up. Note: I have not tried a new Comodo setup yet. Thanks for attention !!!
FredMcD
  • Top 10 Contributor
4269 solutions 59845 answers

That was very good work. Well done. Please flag your last post as Solved Problem so others will know.

You should contact Comodo support on this.

That was very good work. Well done. Please flag your last post as '''Solved Problem''' so others will know. You should contact Comodo support on this.