X
Tap here to go to the mobile version of the site.

Support Forum

This thread was closed and archived. Please ask a new question if you need help.

I want to change the visited link color only but not the text and background colurs

Posted

The default color purple for 'Visited links' is too close to the default blue for 'Unvisited links' and the difference is visible on my screen only at certain angles and certain intensities of ambient light. Changing the 'Visited links' color takes effect only when 'Override the colors specified by the page with your selections above' is set to 'Always'. But then the colors for 'Text', 'Background' and 'Unvisited links' are also changed, which results also in pictures not being shown. How can I change to color of 'Visited links' only, without changing anything else?

The default color purple for 'Visited links' is too close to the default blue for 'Unvisited links' and the difference is visible on my screen only at certain angles and certain intensities of ambient light. Changing the 'Visited links' color takes effect only when 'Override the colors specified by the page with your selections above' is set to 'Always'. But then the colors for 'Text', 'Background' and 'Unvisited links' are also changed, which results also in pictures not being shown. How can I change to color of 'Visited links' only, without changing anything else?
FredMcD
  • Top 10 Contributor
4271 solutions 59919 answers

There are/were add-ons that could do that for you.

Type about:preferences#content<enter> in the address bar. [v56+] Type about:preferences#general<enter> in the address bar.

Across from fonts and colors, press the Colors button.

There are/were add-ons that could do that for you. Type '''about:preferences#content'''<enter> in the address bar. [v56+] Type '''about:preferences#general'''<enter> in the address bar. Across from '''fonts and colors, ''' press the '''Colors''' button.

Helpful Reply

Thanks for volunteering your support. However, there are several issues with your answer: 1. Why would Firefox users need add-ons to change something as fundamental and basic as the color of a 'Visited link'? 2. Are these add-ons available or are they not? 3. If they are available, which ones are they and how do I find them? 4. You tell me to type about:preferences#content<enter> or about:preferences#general<enter> in the address bar. But that just leads me to the settings page, where the inconsistency lies. What do you want me to do with that information? 5. What do you mean with "Across from". I've been exploring the 'Colors' options for a long time and found out that they didn't work, before posting the question on the Forum.

Thanks for volunteering your support. However, there are several issues with your answer: 1. Why would Firefox users need add-ons to change something as fundamental and basic as the color of a 'Visited link'? 2. Are these add-ons available or are they not? 3. If they are available, which ones are they and how do I find them? 4. You tell me to type about:preferences#content<enter> or about:preferences#general<enter> in the address bar. But that just leads me to the settings page, where the inconsistency lies. What do you want me to do with that information? 5. What do you mean with "Across from". I've been exploring the 'Colors' options for a long time and found out that they didn't work, before posting the question on the Forum.
FredMcD
  • Top 10 Contributor
4271 solutions 59919 answers

Rouke1 said

1. Why would Firefox users need add-ons to change something as fundamental and basic as the color of a 'Visited link'?

Add-ons can be used, but there is a setting available within Firefox.

2. Are these add-ons available or are they not?

I don't know for sure. I am still using v54 to keep my add-ons working.

3. If they are available, which ones are they and how do I find them?

You will have to look for yourself. Others may be able to help on that.

4. You tell me to type about:preferences#content<enter> or about:preferences#general<enter> in the address bar. But that just leads me to the settings page, where the inconsistency lies. What do you want me to do with that information?

5. What do you mean with "Across from". I've been exploring the 'Colors' options for a long time and found out that they didn't work, before posting the question on the Forum.

Look for fonts and colors, then press the Colors button to the right. Are you saying this is not working?

''Rouke1 [[#answer-1105818|said]]'' <blockquote> 1. Why would Firefox users need add-ons to change something as fundamental and basic as the color of a 'Visited link'? </blockquote> Add-ons can be used, but there is a setting available within Firefox. <blockquote> 2. Are these add-ons available or are they not? </blockquote> I don't know for sure. I am still using v54 to keep my add-ons working. <blockquote> 3. If they are available, which ones are they and how do I find them? </blockquote> You will have to look for yourself. Others may be able to help on that. <blockquote> 4. You tell me to type about:preferences#content<enter> or about:preferences#general<enter> in the address bar. But that just leads me to the settings page, where the inconsistency lies. What do you want me to do with that information? <br><br> 5. What do you mean with "Across from". I've been exploring the 'Colors' options for a long time and found out that they didn't work, before posting the question on the Forum. </blockquote> Look for '''fonts and colors''', then press the '''Colors''' button to the right. Are you saying this is not working?
cor-el
  • Top 10 Contributor
  • Moderator
17580 solutions 159070 answers

You would have to use code in userContent.css to only change the visited link color.

Add code to the userContent.css file.


:visited {color:#rrggbb !important;}

You need to create the chrome folder (lowercase) in the <xxxxxxxx>.default profile folder if this folder doesn't exist.

  • use a plain text editor (Windows: Notepad; Mac: Textedit) to create a (new) userContent.css file in the chrome folder (file name is case sensitive)
  • paste the code in the userContent.css file in the editor window

If you are on Windows:

  • make sure you select "All files" and not "Text files" when you save the file via "Save file as" in the text editor as userContent.css

Otherwise Windows may add a hidden .txt file extension and you end up with a not working userContent.css.txt file.

  • make sure you do not have a double .css.css file extension (userContent.css.css) if it is still not working

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

You would have to use code in userContent.css to only change the visited link color. Add code to the <b>userContent.css</b> file. *http://kb.mozillazine.org/userContent.css <hr> <pre><nowiki>:visited {color:#rrggbb !important;}</nowiki></pre> <hr> You need to create the <b>chrome</b> folder (lowercase) in the <xxxxxxxx>.default profile folder if this folder doesn't exist. *use a plain text editor (Windows: Notepad; Mac: Textedit) to create a (new) <b>userContent.css</b> file in the <i>chrome</i> folder (file name is case sensitive) *paste the code in the userContent.css file in the editor window If you are on Windows: *make sure you select "All files" and not "Text files" when you save the file via "Save file as" in the text editor as userContent.css Otherwise Windows may add a hidden <i>.txt</i> file extension and you end up with a not working <i>userContent.css.txt</i> file. *make sure you do not have a double <i>.css.css</i> file extension (userContent.css.css) if it is still not working You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the <b>about:profiles</b> page. *Help -> Troubleshooting Information -> Profile Directory:<br>Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder *http://kb.mozillazine.org/Profile_folder_-_Firefox
Lola 0 solutions 3 answers

I tried all but the adding code to fix the colors and they do not work. I have also gotten the add-ons offered for this and again, they don't work. I'm not comfortable adding code.

I hope Firefox fixes this for the next update.

I tried all but the adding code to fix the colors and they do not work. I have also gotten the add-ons offered for this and again, they don't work. I'm not comfortable adding code. I hope Firefox fixes this for the next update.
cor-el
  • Top 10 Contributor
  • Moderator
17580 solutions 159070 answers

Note that you would have to substitute #rrggbb with your preferred visited color if you would want to try the userContent.css solution.

:visited {color:#rrggbb !important;}

https://addons.mozilla.org/firefox/addon/color-picker-live/

Note that you would have to substitute #rrggbb with your preferred visited color if you would want to try the userContent.css solution. :visited {color:#rrggbb !important;} ---- https://addons.mozilla.org/firefox/addon/color-picker-live/
jscher2000
  • Top 10 Contributor
8796 solutions 71953 answers

Hi Lola, I think these default link colors have been the same since the 1990s, so it seems to be a tradition that is unlikely to change.

What happened when you changed the default link color on the Options/Preferences page? What color did you choose?

Note that sites can override these colors, so this would only affect sites that do not set their own link colors.

Hi Lola, I think these default link colors have been the same since the 1990s, so it seems to be a tradition that is unlikely to change. What happened when you changed the default link color on the Options/Preferences page? What color did you choose? <img src="https://prod-cdn.sumo.mozilla.net/uploads/images/2018-07-29-10-38-15-6713c6.png" width="500"> Note that sites can override these colors, so this would only affect sites that do not set their own link colors.
Lola 0 solutions 3 answers

Thanks. Jscher2000, I tried a variety of colors, shades, etc. Nothing worked. Now the visited sites are the same color as the unvisited sites. :-(

Thanks. Jscher2000, I tried a variety of colors, shades, etc. Nothing worked. Now the visited sites are the same color as the unvisited sites. :-(
jscher2000
  • Top 10 Contributor
8796 solutions 71953 answers

Lola said

Thanks. Jscher2000, I tried a variety of colors, shades, etc. Nothing worked. Now the visited sites are the same color as the unvisited sites. :-(

There are a few websites that do that, but Firefox should not normally do that. If the color boxes are not working as expected, you can try editing two preferences directly:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste visited and pause while the list is filtered

(3) If the layout.css.visited_links_enabled preference is bolded and "modified" or "user set" to false, double-click it to restore the default value of true

(4) Double-click the browser.visited_color preference to display a dialog where you can enter the desired value. For example, for dark red visited links, type or paste

#900

then click OK. At any point, you can restore the built-in value by right-clicking this preference and choosing Reset.

''Lola [[#answer-1138252|said]]'' <blockquote> Thanks. Jscher2000, I tried a variety of colors, shades, etc. Nothing worked. Now the visited sites are the same color as the unvisited sites. :-( </blockquote> There are a few websites that do that, but Firefox should not normally do that. If the color boxes are not working as expected, you can try editing two preferences directly: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''visited''' and pause while the list is filtered (3) If the '''layout.css.visited_links_enabled''' preference is bolded and "modified" or "user set" to false, double-click it to restore the default value of true (4) Double-click the '''browser.visited_color''' preference to display a dialog where you can enter the desired value. For example, for dark red visited links, type or paste #900 then click OK. At any point, you can restore the built-in value by right-clicking this preference and choosing Reset.
Lola 0 solutions 3 answers

Hi jscher2000!

Thank you so much. I don't have the confidence to go into about:config. The risk of me doing it incorrectly is too great. Thank you, again.

Hi jscher2000! Thank you so much. I don't have the confidence to go into about:config. The risk of me doing it incorrectly is too great. Thank you, again.
tjsepka1 0 solutions 13 answers

jscher2000 said

Lola said
Thanks. Jscher2000, I tried a variety of colors, shades, etc. Nothing worked. Now the visited sites are the same color as the unvisited sites. :-(

There are a few websites that do that, but Firefox should not normally do that. If the color boxes are not working as expected, you can try editing two preferences directly:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste visited and pause while the list is filtered

(3) If the layout.css.visited_links_enabled preference is bolded and "modified" or "user set" to false, double-click it to restore the default value of true

(4) Double-click the browser.visited_color preference to display a dialog where you can enter the desired value. For example, for dark red visited links, type or paste

#900

then click OK. At any point, you can restore the built-in value by right-clicking this preference and choosing Reset.


I have had this problem for a long time and the this answer does not work for FF Quantum v61.0.2 (64-bit). I might have gotten it to work with earlier FF versions through Add-ons or Extensions, but I don't remember, and replacement extensions in Quantum are sparse. Seems the extension / add-on developers aren't around anymore, or aren't much interested in supporting Quantum.

''jscher2000 [[#answer-1138457|said]]'' <blockquote> ''Lola [[#answer-1138252|said]]'' <blockquote> Thanks. Jscher2000, I tried a variety of colors, shades, etc. Nothing worked. Now the visited sites are the same color as the unvisited sites. :-( </blockquote> There are a few websites that do that, but Firefox should not normally do that. If the color boxes are not working as expected, you can try editing two preferences directly: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''visited''' and pause while the list is filtered (3) If the '''layout.css.visited_links_enabled''' preference is bolded and "modified" or "user set" to false, double-click it to restore the default value of true (4) Double-click the '''browser.visited_color''' preference to display a dialog where you can enter the desired value. For example, for dark red visited links, type or paste #900 then click OK. At any point, you can restore the built-in value by right-clicking this preference and choosing Reset. </blockquote> I have had this problem for a long time and the this answer does not work for FF Quantum v61.0.2 (64-bit). I might have gotten it to work with earlier FF versions through Add-ons or Extensions, but I don't remember, and replacement extensions in Quantum are sparse. Seems the extension / add-on developers aren't around anymore, or aren't much interested in supporting Quantum.
jscher2000
  • Top 10 Contributor
8796 solutions 71953 answers

Hi tjsepka1, Firefox uses the link and visited color settings UNLESS the site overrides them with different colors. If that is not the pattern you notice, what is the problem you see? For example, all links appear unvisited on all sites, all links are different colors from the ones you selected on all sites, etc.

Hi tjsepka1, Firefox uses the link and visited color settings UNLESS the site overrides them with different colors. If that is not the pattern you notice, what is the problem you see? For example, all links appear unvisited on all sites, all links are different colors from the ones you selected on all sites, etc.
tjsepka1 0 solutions 13 answers

My current settings (under Preferences) are "Never" override the colors specified by the page with your selections above.

The color of visited and un-visited links is the same (dark purple?).

I have browser.visited_color status modified, #009900. My understanding from other searches on this topic is that this should override the setting specified through Prefreences.

I haven't modified any CSS files.

My current settings (under Preferences) are "Never" override the colors specified by the page with your selections above. The color of visited and un-visited links is the same (dark purple?). I have browser.visited_color status modified, #009900. My understanding from other searches on this topic is that this should override the setting specified through Prefreences. I haven't modified any CSS files.
jscher2000
  • Top 10 Contributor
8796 solutions 71953 answers

Hi tjsepka1, the color on the Options/Preferences page and the color set through about:config should match. The Options/Preferences page has a grid of particular colors, so you have more flexibility if you use the about:config page, but ultimately, whether they work or not isn't affected by how you set the color. The key factor is whether the page overrides these default settings with its own style rules.

Since you have a new thread going, let's continue there: https://support.mozilla.org/questions/1231343

Hi tjsepka1, the color on the Options/Preferences page and the color set through about:config should match. The Options/Preferences page has a grid of particular colors, so you have more flexibility if you use the about:config page, but ultimately, whether they work or not isn't affected by how you set the color. The key factor is whether the page overrides these default settings with its own style rules. Since you have a new thread going, let's continue there: https://support.mozilla.org/questions/1231343