Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

My Bookmarks Toolbar shows my History

  • 3 replies
  • 1 has this problem
  • 19 views
  • Last reply by cor-el

more options

Every page I have visited shows in my Bookmarks Toolbar, and can't be deleted. Show All Bookmarks shows nothing.

I have set Options -> History to Remember Nothing, yet Firefox remembers everything and displays it in the Bookmarks Toolbar. How do I clear this and stop it from adding new pages?

Chosen solution

If "Verify Integrity" on the "Help -> Troubleshooting Information" (about:support) page cannot repair places.sqlite then remove all places.sqlite files in the Firefox profile folder. Firefox will rebuild places.sqlite and restore the bookmarks from a recent JSON backup in the bookmarkbackups folder.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

Read this answer in context 👍 0

All Replies (3)

more options

Hello,

In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see How do I create a screenshot of my problem?

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. This will help us to visualize the problem.

Thank you!

more options

Hi Panskeptic,

You can check for problems with the places.sqlite database (bookmarks and history) in the Firefox profile folder :

Either type in the address bar about:support or :

3-bar menu (or 'Tools') => Help ( next to the ? ) => Troubleshooting Information' and scroll down to 'Places Database' => 'Verify Integrity'

more options

Chosen Solution

If "Verify Integrity" on the "Help -> Troubleshooting Information" (about:support) page cannot repair places.sqlite then remove all places.sqlite files in the Firefox profile folder. Firefox will rebuild places.sqlite and restore the bookmarks from a recent JSON backup in the bookmarkbackups folder.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.