Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox no longer respects browser.fixup.alternate.enabled

  • 7 replies
  • 1 has this problem
  • 893 views
  • Last reply by randomanon

more options

After updating to Firefox 59.0.2 from Firefox 57.0, the browser now ignores browser.fixup.alternate.enabled. A similar issue seems to be happening in other versions of Firefox, according to previous questions.

Chosen solution

jscher2000 said

The top line of the autocomplete drop-down should indicate what will happen if you press Enter or click the Go button with the current contents of the address bar. If Firefox starts showing a previously visited address as soon as you start typing, before you type a period, that's usually due to autofill which suggests top level site addresses in the address bar. There's a setting to disable that. If the problem occurs with text that contains a period and no spaces (like window.open), Firefox will always check whether they are domain names before searching. A workaround is to type an apostrophe at the beginning so Firefox knows it is not a valid URL. This screenshot illustrates what I'm getting at:

Thanks for the suggestion, the use of an apostrophe to make Firefox recognize something is not a url should help.

Some other notes, should the problem happen in the future: No suggestions appeared in the url bar, and Firefox was automatically adding .com or .net to whatever was typed, despite no periods being entered.

The following about:config preferences were disabled:

  1. browser.fixup.alternate.enabled
  2. browser.urlbar.suggest.bookmark
  3. browser.urlbar.suggest.history
  4. browser.urlbar.suggest.openpage
  5. browser.urlbar.suggest.searches
  6. browser.urlbar.autoFill
  7. browser.urlbar.autocomplete.enabled
Read this answer in context 👍 0

All Replies (7)

more options

randomanon said

After updating to Firefox 59.0.2 from Firefox 57.0, the browser now ignores browser.fixup.alternate.enabled. A similar issue seems to be happening in other versions of Firefox, according to previous questions.

Hi,

Could you be a bit more specific, please  ?

In what way does Firefox ignore that preference  ?

more options

The fixup only works for http and not for other protocols including https.

more options

Enigma said

randomanon said
After updating to Firefox 59.0.2 from Firefox 57.0, the browser now ignores browser.fixup.alternate.enabled. A similar issue seems to be happening in other versions of Firefox, according to previous questions.

Hi,

Could you be a bit more specific, please  ?

In what way does Firefox ignore that preference  ?

Although browser.fixup.alternate.enabled was set to false, Firefox was still predicting URLs by adding www. and .com/.net at random to keywords typed in the address bar after pressing enter.

Modified by randomanon

more options

randomanon said

Although browser.fixup.alternate.enabled was set to false, Firefox was still predicting URLs by adding www. and .com/.net at random to keywords typed in the address bar after pressing enter.

Thank you for clarifying that  !

Now that you've read cor-el's post, you know why, right  ?

more options

When they say the fixup only works for http and not https, does it mean the browser will continue predicting for https urls, regardless of settings, or does it mean the browser only autocorrects to http urls?

If what they said meant the former, what would be a solution that prevents url prediction for all protocols?

more options

The top line of the autocomplete drop-down should indicate what will happen if you press Enter or click the Go button with the current contents of the address bar. If Firefox starts showing a previously visited address as soon as you start typing, before you type a period, that's usually due to autofill which suggests top level site addresses in the address bar. There's a setting to disable that.

If the problem occurs with text that contains a period and no spaces (like window.open), Firefox will always check whether they are domain names before searching. A workaround is to type an apostrophe at the beginning so Firefox knows it is not a valid URL.

This screenshot illustrates what I'm getting at:

more options

Chosen Solution

jscher2000 said

The top line of the autocomplete drop-down should indicate what will happen if you press Enter or click the Go button with the current contents of the address bar. If Firefox starts showing a previously visited address as soon as you start typing, before you type a period, that's usually due to autofill which suggests top level site addresses in the address bar. There's a setting to disable that. If the problem occurs with text that contains a period and no spaces (like window.open), Firefox will always check whether they are domain names before searching. A workaround is to type an apostrophe at the beginning so Firefox knows it is not a valid URL. This screenshot illustrates what I'm getting at:

Thanks for the suggestion, the use of an apostrophe to make Firefox recognize something is not a url should help.

Some other notes, should the problem happen in the future: No suggestions appeared in the url bar, and Firefox was automatically adding .com or .net to whatever was typed, despite no periods being entered.

The following about:config preferences were disabled:

  1. browser.fixup.alternate.enabled
  2. browser.urlbar.suggest.bookmark
  3. browser.urlbar.suggest.history
  4. browser.urlbar.suggest.openpage
  5. browser.urlbar.suggest.searches
  6. browser.urlbar.autoFill
  7. browser.urlbar.autocomplete.enabled