X
Tap here to go to the mobile version of the site.

Support Forum

How can I copy multiple links for the Media tab of the Page Info window?

Posted

If I open the Page Info window and go to the Media tab I can see many links for the assets of a given page. And I can select multiple items. However, I cannot seem to copy these items to clipboard as the "copy" option is greyed out on the context menu. I'd simply like to copy that list of links to a text editor. How can this be done and why am not not able to copy these links?

If I open the Page Info window and go to the Media tab I can see many links for the assets of a given page. And I can select multiple items. However, I cannot seem to copy these items to clipboard as the "copy" option is greyed out on the context menu. I'd simply like to copy that list of links to a text editor. How can this be done and why am not not able to copy these links?

Additional System Details

Installed Plug-ins

  • Shockwave Flash 25.0 r0

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:58.0) Gecko/20100101 Firefox/58.0

More Information

Shadow110 1072 solutions 14836 answers

Hi, There are many programs and websites you can not use the mouse for. Have you tried using keyboard commands ?

Copy = CTRL+C Paste = CTRL+P https://support.mozilla.org/en-US/kb/keyboard-shortcuts-perform-firefox-tasks-quickly

Please let us know if this solved your issue or if need further assistance.

Hi, There are many programs and websites you can not use the mouse for. Have you tried using keyboard commands ? Copy = CTRL+C Paste = CTRL+P https://support.mozilla.org/en-US/kb/keyboard-shortcuts-perform-firefox-tasks-quickly Please let us know if this solved your issue or if need further assistance.

Question owner

Pkshadow said

Have you tried using keyboard commands ?

Yes, I have. It doesn't work for me. The "copy" menu item is greyed out everywhere and that includes the edit menu and it's relative keyboard shortcut ⌘C

Not sure if it's specific to OS X but for what it's worth I am on 10.11.6 and Firefox 58.0.2

''Pkshadow [[#answer-1087974|said]]'' <blockquote>Have you tried using keyboard commands ?</blockquote> Yes, I have. It doesn't work for me. The "copy" menu item is greyed out everywhere and that includes the edit menu and it's relative keyboard shortcut ⌘C Not sure if it's specific to OS X but for what it's worth I am on 10.11.6 and Firefox 58.0.2

Modified by billynoah

cor-el
  • Top 10 Contributor
  • Moderator
17760 solutions 160620 answers

Copy in the right-click context menu is still enabled and works for me if I select multiple items in "Tools -> Page Info -> Media".

I see "Select All" and "Copy" in the context menu on Linux and both are enabled and not grayed.

Copy in the right-click context menu is still enabled and works for me if I select multiple items in "Tools -> Page Info -> Media". I see "Select All" and "Copy" in the context menu on Linux and both are enabled and not grayed.

Question owner

Unfortunately not for me... see screenshots.

What operating system and firefox version are you using?

Unfortunately not for me... see screenshots. What operating system and firefox version are you using?
cor-el
  • Top 10 Contributor
  • Moderator
17760 solutions 160620 answers

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
Start Firefox in <u>Safe Mode</u> to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem. *switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance *do NOT click the "Refresh Firefox" button on the Safe Mode start window *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems

Question owner

Thanks cor-el. I switched theme to default and restarted in safe mode but unfortunately it had no affect.

Thanks cor-el. I switched theme to default and restarted in safe mode but unfortunately it had no affect.

Question owner

Hi - unless anyone has a definitive answer or workaround I'm going to assume this is a bug and file a bug report. So far nothing suggested here works.

Hi - unless anyone has a definitive answer or workaround I'm going to assume this is a bug and file a bug report. So far nothing suggested here works.
Happy112 561 solutions 5694 answers

billynoah said

Hi - unless anyone has a definitive answer or workaround I'm going to assume this is a bug and file a bug report. So far nothing suggested here works.

Call me stubborn, but have you actually tried what Pkshadow suggested :

Press Ctrl + C to copy and Ctrl + V to paste (and ignore that greyed out tooltip)  ?

''billynoah [[#answer-1098501|said]]'' <blockquote> Hi - unless anyone has a definitive answer or workaround I'm going to assume this is a bug and file a bug report. So far nothing suggested here works. </blockquote> Call me stubborn, but have you actually tried what Pkshadow suggested : Press Ctrl + C to copy and Ctrl + V to paste (and ignore that greyed out tooltip) ?

Question owner

Ok you're stubborn. And apparently didn't read my earlier response... here it is in a screenshot if that helps.

Also, please note the question details specify I am using OS X which does not use CTRL-C but instead uses CMD-C. A minor detail I know but the fact that this is the second response suggesting I use key commands that don't work in my operating system coupled with the fact that I am being asked to repeat things I have already posted leaves me wondering about the effectiveness of this support forum.

Bug has been reported: https://bugzilla.mozilla.org/show_bug.cgi?id=1452537

Ok you're stubborn. And apparently didn't read my earlier response... here it is in a screenshot if that helps. Also, please note the question details specify I am using OS X which does not use CTRL-C but instead uses CMD-C. A minor detail I know but the fact that this is the second response suggesting I use key commands that don't work in my operating system coupled with the fact that I am being asked to repeat things I have already posted leaves me wondering about the effectiveness of this support forum. Bug has been reported: https://bugzilla.mozilla.org/show_bug.cgi?id=1452537

Modified by billynoah

Happy112 561 solutions 5694 answers

Not only am I stubborn - I am ignorant as well, cause I had no idea that on Mac 'Ctrl + C' = 'Cmd + C' ......

Please accept my apologies.

Good for you to file a bug report though.

Not only am I stubborn - I am ignorant as well, cause I had no idea that on Mac 'Ctrl + C' = 'Cmd + C' ...... Please accept my apologies. Good for you to file a bug report though.

Question owner

Lol, well sorry if that sounded unappreciative. Thanks for making an effort - May I ask - can you confirm that it actually does still work in your setup? I just went and tried another machine running Firefox 48 on a much older version of OS X and it didn't work there either. Wondering if it's only broken on a Mac but works fine on WIndows.

Lol, well sorry if that sounded unappreciative. Thanks for making an effort - May I ask - can you confirm that it actually does still work in your setup? I just went and tried another machine running Firefox 48 on a much older version of OS X and it didn't work there either. Wondering if it's only broken on a Mac but works fine on WIndows.
Happy112 561 solutions 5694 answers

Just did billynoah said

Lol, well sorry if that sounded unappreciative.

I totally deserved it - I always get mad at others when the don't read everything that has been posted earlier in the thread. Pot => Kettle .....

May I ask - can you confirm that it actually does still work in your setup?

Just went to the Media tab (only took a quick peek under that tab before) and get no option to copy and paste, only to 'Save as', which I did (saved the entries to my Downloads folder).

Just did ''billynoah [[#answer-1098507|said]]'' <blockquote> Lol, well sorry if that sounded unappreciative. </blockquote> I totally deserved it - I always get mad at others when the don't read everything that has been posted earlier in the thread. Pot => Kettle ..... <blockquote> May I ask - can you confirm that it actually does still work in your setup? </blockquote> Just went to the Media tab (only took a quick peek under that tab before) and get no option to copy and paste, only to 'Save as', which I did (saved the entries to my Downloads folder).

Modified by Happy112

Question owner

Ok thanks. Yeah, in most scenarios when I visit that window it's so I can quickly audit which assets are not being served over SSL when an https page is showing the dreaded broken lock. Occasionally there are hundreds of things in this tab and it would be great to be able to peruse the list in a regular text editor - hence my desire to copy and paste. There are other ways to get this data but in this tab is presented so concisely that it's really the ideal tool for the job. Just falls a bit short since I can't copy it.

Ok thanks. Yeah, in most scenarios when I visit that window it's so I can quickly audit which assets are ''not'' being served over SSL when an https page is showing the dreaded broken lock. Occasionally there are hundreds of things in this tab and it would be great to be able to peruse the list in a regular text editor - hence my desire to copy and paste. There are other ways to get this data but in this tab is presented so concisely that it's really the ideal tool for the job. Just falls a bit short since I can't copy it.
Happy112 561 solutions 5694 answers

Update - and again I owe you an apology :

I just went back to the Media tab - thought that the fact that I don't see that option to copy doesn't mean that it can't be done. So, I highlighted an entry, pressed Ctrl + C (Cmd + C for you) - opened a Word document, pressed Ctrl + V ........ et voilà  !

Update - and again I owe you an apology : I just went back to the Media tab - thought that the fact that I don't see that option to copy doesn't mean that it can't be done. So, I highlighted an entry, pressed Ctrl + C (Cmd + C for you) - opened a Word document, pressed Ctrl + V ........ et voilà !