X
Tap here to go to the mobile version of the site.
An updated version of Firefox is available to address the issues with Add-ons disabled or fail to install on Firefox. You can download the update for your OS here: https://www.mozilla.org/firefox/new/ For Known Issues and Workarounds, please check out the update at https://support.mozilla.org/kb/add-ons-disabled-or-fail-to-install-firefox

Support Forum

How can I disable Notification prompts?

Posted

I don't recall when it first started, but about every page I visit now prompts me whether to allow notifications, is there a way to get rid of this process? Could not find anything that worked in the previous thread.

I don't recall when it first started, but about every page I visit now prompts me whether to allow notifications, is there a way to get rid of this process? Could not find anything that worked in the previous thread.

Chosen solution

Hi,

Would you please try this :

Type in the address bar about:config (press Enter) (promise to be careful, if asked)

Type in the search bar and look for the preference :

dom.webnotifications.enabled

And set its value to false

Then close and restart Firefox.


Firefox 59 will be released in less than a week, and then it will even be
better .....

See :

https://www.ghacks.net/2018/01/07/firefox-59-ui-options-to-block-notifications-microphone-camera-and-location/


There is of course also the possibility to block notifications per site  :

Page Info : click on the little 'i' in a circle at the left end of the
address bar => More Information Under the Permissions tab scroll down to :

'Receive Notifications' - uncheck 'Use Default' and check 'Block'.

Also see : https://support.mozilla.org/en-US/kb/push-notifications-firefox?as=u&utm_source=inproduct

Read this answer in context 3

Additional System Details

Installed Plug-ins

  • Shockwave Flash 27.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0

More Information

Happy112 561 solutions 5694 answers

Chosen Solution

Hi,

Would you please try this :

Type in the address bar about:config (press Enter) (promise to be careful, if asked)

Type in the search bar and look for the preference :

dom.webnotifications.enabled

And set its value to false

Then close and restart Firefox.


Firefox 59 will be released in less than a week, and then it will even be
better .....

See :

https://www.ghacks.net/2018/01/07/firefox-59-ui-options-to-block-notifications-microphone-camera-and-location/


There is of course also the possibility to block notifications per site  :

Page Info : click on the little 'i' in a circle at the left end of the
address bar => More Information Under the Permissions tab scroll down to :

'Receive Notifications' - uncheck 'Use Default' and check 'Block'.

Also see : https://support.mozilla.org/en-US/kb/push-notifications-firefox?as=u&utm_source=inproduct

Hi, Would you please try this : Type in the address bar '''about:config''' (press Enter) (promise to be careful, if asked) Type in the search bar and look for the preference : '''dom.webnotifications.enabled''' And set its value to '''false''' Then close and restart Firefox. --------------------------------------------------------------------------------------------------------- Firefox 59 will be released in less than a week, and then it will even be <BR>better ..... See : https://www.ghacks.net/2018/01/07/firefox-59-ui-options-to-block-notifications-microphone-camera-and-location/ ---------------------------------------------------------------------------------------------------------- There is of course also the possibility to block notifications per site : Page Info : click on the little 'i' in a circle at the left end of the <BR>address bar => More Information Under the Permissions tab scroll down to : 'Receive Notifications' - uncheck 'Use Default' and check 'Block'. Also see : https://support.mozilla.org/en-US/kb/push-notifications-firefox?as=u&utm_source=inproduct