Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

website showing up in Italian

  • 12 replies
  • 1 has this problem
  • 19 views
  • Last reply by Happy112

more options

This website. http://support.creative.com/scripts/getProd.aspx?id=21402 is only showing in Italian and I can't change it to English. All other browsers display the page in English except Firefox

This website. http://support.creative.com/scripts/getProd.aspx?id=21402 is only showing in Italian and I can't change it to English. All other browsers display the page in English except Firefox

Chosen solution

He takes a bow throwing roses to the crowd, feeling like a master dose of stupid. That should have been the first thing I checked instead of the last.

Read this answer in context 👍 0

All Replies (12)

more options

Hi,

You will probably already have done this ( but just in case) - at the bottom of this page, under 'Change Country / Region' => Worldwide :

https://www.creative.com/language.aspx?sDestURL=/support/&selectcr=3

more options

That doesn't work. It will switch it to US but then going to the sound card in question and then clicking on driver download link takes it right back to displaying in Italian. I think it must be the website page itself not liking Firefox cause that exact same link I posted in any other browser will display it in English. And yes I view everything in English only. Did you try the link I posted yourself in FIrefox (58.0.2)?

Modified by user6600

more options

Mike89 said

Did you try the link I posted yourself in FIrefox (58.0.2)?

Yes, that was the first thing I did, and my IP address made it display in the language of the country where I currently am (which is not English).

So I switched country/region settings and that worked for me.

Have you tried to contact their support  ?

https://uk.creative.com/contactus/

or :

https://us.creative.com/contactus/

more options

I will contact them. Weird it only happens in Firefox and this happened after some previous Firefox updates cause that link used to work right previously in Firefox (I check that link from time to time to see if there are any updates for my sound card). The same link in Chrome, Edge or PaleMoon displays properly in English. I even tried changing the Country at the top and after I changed it, I got an unable to connect message. Pretty strange.

more options

I had tried that link in Edge - did not display in English for me either, so I changed country at the top of that page, just like I did using Firefox.

I too got that 'unable to connect' a couple of times. Weird indeed.

This hasn't happened to me with other websites (yet - knock on wood), so I guess it's something on their side - unless somebody proves me wrong and comes up with the perfect solution.

Sorry I couldn't be more helpful .....

more options

Couldn't let it go just yet and I was thinking :

If you're not in Italy, but in the US or UK - would you check your IP address  ?

https://whatismyipaddress.com/

As that website (and I tried most of their pages) displays in the language that is spoken in the country where I'm currently located, I'm thinking that it uses the IP adress.

(Just a wild guess)

more options

If that was the case then all browsers would display the same location wise. It's just Firefox that has this issue with that page. I think Firefox changed something in one of their updates that is not playing nice with that page cause I didn't have this issue with previous versions of Firefox until now.

more options

Well I just went in and removed the cookies for creative and guess what, the page is now displaying properly. Looks like it was a stuck cookie. Jeez

more options

Mike89 said

If that was the case then all browsers would display the same location wise. It's just Firefox that has this issue with that page.

Well, like I said : it was only a wild guess, as it displays in a different language for me on both Firefox and Edge. But for you it's only the case with Firefox - weird.

I'm sure that somebody else will come to your rescue - sorry I haven't been much help ......  :(

more options

Mike89 said

Well I just went in and removed the cookies for creative and guess what, the page is now displaying properly. Looks like it was a stuck cookie. Jeez

You posted this while I was writing my reply - and : Yay  ! What a
surprise  ! I bet that's a huge relief .....

Well done, you - round of applause  !

Would you be a dear and mark own last post as Chosen Solution  ?

more options

Chosen Solution

He takes a bow throwing roses to the crowd, feeling like a master dose of stupid. That should have been the first thing I checked instead of the last.

more options

Mike89 said

He takes a bow throwing roses to the crowd, feeling like a master dose of stupid. That should have been the first thing I checked instead of the last.

No, no, no !!! I am the Queen of Stupid  !!! You came to us for advice, and what did I give you   ? A major pain in the toosh ..... You did a great job  !!!