X
Tap here to go to the mobile version of the site.

Support Forum

cookies no longer seem to work for me in FireFox.

Posted

My proxy application server running under FireFox no longer is supporting cookies. The same script runs on Chrome fine.

http://www.scriptbasic.org/home/echo

What changed?

My proxy application server running under FireFox no longer is supporting cookies. The same script runs on Chrome fine. http://www.scriptbasic.org/home/echo What changed?

Chosen solution

Thanks for the suggestion which has resulted in it now working. The SERVER time wasn't synced to Internet time and was off. It now seems to work fine.

Strange that Chrome worked with the time offset difference.

Thanks everyone for your help resolving this!

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 28.0 r0

Application

  • User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:58.0) Gecko/20100101 Firefox/58.0

More Information

Tomatoshadow2 20 solutions 242 answers

Do you have Firefox set to delete your cookies upon closing?

Do you have Firefox set to delete your cookies upon closing?
jscher2000
  • Top 10 Contributor
8783 solutions 71823 answers

My Firefox receives:

cookie1=1; path=/;expires=Mon, 26-Feb-18 6:11:38 GMT;
cookie2=2; path=/;expires=Mon, 26-Feb-18 6:11:38 GMT;
cookie3=3; path=/;expires=Mon, 26-Feb-18 6:11:38 GMT;

The cookies are not recognized in Firefox 58.0.2 or in Firefox 52esr.

Can you get rid of the line breaks and the trailing semicolon (at the very end)?

https://developer.mozilla.org/docs/Web/HTTP/Headers/Set-Cookie

My Firefox receives: <pre>cookie1=1; path=/;expires=Mon, 26-Feb-18 6:11:38 GMT; cookie2=2; path=/;expires=Mon, 26-Feb-18 6:11:38 GMT; cookie3=3; path=/;expires=Mon, 26-Feb-18 6:11:38 GMT; </pre> The cookies are not recognized in Firefox 58.0.2 or in Firefox 52esr. Can you get rid of the line breaks and the trailing semicolon (at the very end)? https://developer.mozilla.org/docs/Web/HTTP/Headers/Set-Cookie

Modified by jscher2000

jscher2000
  • Top 10 Contributor
8783 solutions 71823 answers

I have the same behavior in Chrome as in Firefox. (The cookies are undefined on reload.)

I have the same behavior in Chrome as in Firefox. (The cookies are undefined on reload.)

Question owner

You have to resubmit the echo page within 10 seconds or the cookies expire. As mentioned, it works fine in Chrome.

You have to resubmit the echo page within 10 seconds or the cookies expire. As mentioned, it works fine in Chrome.

Question owner

There was a note about cookies in the docs that 'secure' is no longer supported with http. I have the secure argument set to 'false'.

There was a note about cookies in the docs that 'secure' is no longer supported with http. I have the secure argument set to 'false'.
jscher2000
  • Top 10 Contributor
8783 solutions 71823 answers

This seems fine: https://www.jeffersonscher.com/res/setcookie.php

When I compare the expiration times, yours are different from mine.

oatmeal=raisin; expires=Mon, 26-Feb-2018 07:51:46 GMT; Max-Age=10; path=/
chocolatechip=semisweet; expires=Mon, 26-Feb-2018 07:51:46 GMT; Max-Age=10; path=/

cookie1=1; path=/;expires=Mon, 26-Feb-18 7:50:2 GMT;
cookie2=2; path=/;expires=Mon, 26-Feb-18 7:50:2 GMT;
cookie3=3; path=/;expires=Mon, 26-Feb-18 7:50:2 GMT;

Your script is sending a two-digit year and the times are not padded out with zeroes.

Perhaps these are treated as expired on arrival?

This seems fine: https://www.jeffersonscher.com/res/setcookie.php When I compare the expiration times, yours are different from mine. <pre>oatmeal=raisin; expires=Mon, 26-Feb-2018 07:51:46 GMT; Max-Age=10; path=/ chocolatechip=semisweet; expires=Mon, 26-Feb-2018 07:51:46 GMT; Max-Age=10; path=/ cookie1=1; path=/;expires=Mon, 26-Feb-18 7:50:2 GMT; cookie2=2; path=/;expires=Mon, 26-Feb-18 7:50:2 GMT; cookie3=3; path=/;expires=Mon, 26-Feb-18 7:50:2 GMT; </pre> Your script is sending a two-digit year and the times are not padded out with zeroes. Perhaps these are treated as expired on arrival?

Question owner

Good catch and idea but it didn't fix the problem. :-(

PRINT FormatDate("expires=WDN, 0D-MON-YEAR 0h:0m:0s GMT;",GMTIME),"\n"

expires=Mon, 26-Feb-2018 10:51:01 GMT;

If you can recheck the Script BASIC 'echo' script again and confirm your now seeing tasty cookies. ;-)

Positive Note: The change didn't break Chrome running the script.

Good catch and idea but it didn't fix the problem. :-( PRINT FormatDate("expires=WDN, 0D-MON-YEAR 0h:0m:0s GMT;",GMTIME),"\n" expires=Mon, 26-Feb-2018 10:51:01 GMT; If you can recheck the Script BASIC 'echo' script again and confirm your now seeing tasty cookies. ;-) Positive Note: The change didn't break Chrome running the script.

Question owner

Oops! That should have been a 0H for 24 hour format. Corrected on the server. Still no joy.

PRINT FormatDate("expires=WDN, 0D-MON-YEAR 0H:0m:0s GMT;",GMTIME),"\n"

expires=Mon, 26-Feb-2018 23:04:30 GMT;

Oops! That should have been a 0H for 24 hour format. Corrected on the server. Still no joy. PRINT FormatDate("expires=WDN, 0D-MON-YEAR 0H:0m:0s GMT;",GMTIME),"\n" expires=Mon, 26-Feb-2018 23:04:30 GMT;
jscher2000
  • Top 10 Contributor
8783 solutions 71823 answers

These look sensible:

cookie1=1; path=/;expires=Mon, 26-Feb-2018 23:35:48 GMT;
cookie2=2; path=/;expires=Mon, 26-Feb-2018 23:35:48 GMT;
cookie3=3; path=/;expires=Mon, 26-Feb-2018 23:35:48 GMT;

Perhaps it's a clock issue? My local time according to the Web Console is:

var d=new Date(); d.toUTCString();
"Mon, 26 Feb 2018 23:36:55 GMT"

What puzzles me is why Chrome is sending them:

cookie1=1; path=/;expires=Mon, 26-Feb-2018 23:49:53 GMT;
cookie2=2; path=/;expires=Mon, 26-Feb-2018 23:49:53 GMT;
cookie3=3; path=/;expires=Mon, 26-Feb-2018 23:49:53 GMT;
var d=new Date(); d.toUTCString();
"Mon, 26 Feb 2018 23:51:19 GMT"

Seems Chrome set the expiration to 13 seconds after page load (attached screenshot). Odd.

For what it's worth, Internet Explorer 11 behaves like Firefox.

These look sensible: <pre>cookie1=1; path=/;expires=Mon, 26-Feb-2018 23:35:48 GMT; cookie2=2; path=/;expires=Mon, 26-Feb-2018 23:35:48 GMT; cookie3=3; path=/;expires=Mon, 26-Feb-2018 23:35:48 GMT; </pre> Perhaps it's a clock issue? My local time according to the Web Console is: <pre>var d=new Date(); d.toUTCString(); "Mon, 26 Feb 2018 23:36:55 GMT" </pre> What puzzles me is why Chrome is sending them: <pre>cookie1=1; path=/;expires=Mon, 26-Feb-2018 23:49:53 GMT; cookie2=2; path=/;expires=Mon, 26-Feb-2018 23:49:53 GMT; cookie3=3; path=/;expires=Mon, 26-Feb-2018 23:49:53 GMT; </pre> <pre>var d=new Date(); d.toUTCString(); "Mon, 26 Feb 2018 23:51:19 GMT" </pre> Seems Chrome set the expiration to 13 seconds after page load (attached screenshot). Odd. For what it's worth, Internet Explorer 11 behaves like Firefox.

Question owner

It hasn't been long ago that Firefox worked fine with this script. I was setting up a new server and noticed the echo program wasn't sending cookies in my default browser. (Firefox) I went to my Google Chrome backup to try, sure enough everything seemed fine. I'm a Linux guy so testing this with Explorer wasn't high on my list.

Anyone have an idea why the cookies are crumbling?

It hasn't been long ago that Firefox worked fine with this script. I was setting up a new server and noticed the echo program wasn't sending cookies in my default browser. (Firefox) I went to my Google Chrome backup to try, sure enough everything seemed fine. I'm a Linux guy so testing this with Explorer wasn't high on my list. Anyone have an idea why the cookies are crumbling?

Modified by ScriptBASIC

jscher2000
  • Top 10 Contributor
8783 solutions 71823 answers

Can you adjust the time on your server so it's not always behind the time on my PC? I think that might help.

https://www.timeanddate.com/ ("City" can be set to UTC)

Can you adjust the time on your server so it's not always behind the time on my PC? I think that might help. https://www.timeanddate.com/ ("City" can be set to UTC)

Question owner

My time is set via the internet. I assume with and atomic clock.

Chrome dev tools seems to see the cookies as well.

My time is set via the internet. I assume with and atomic clock. Chrome dev tools seems to see the cookies as well.

Question owner

If this was a 'time' issue, why is Chrome working as expected?

Is Mozilla aware of this SetCookie issue?

How are people setting cookies in Fiirefox now?

If this was a 'time' issue, why is Chrome working as expected? Is Mozilla aware of this SetCookie issue? How are people setting cookies in Fiirefox now?
jscher2000
  • Top 10 Contributor
8783 solutions 71823 answers

Your page is still serving me expired cookies. I don't know why Chrome extends their expiration time. Maybe they have a documented explanation for that somewhere.

Did this page work for you in Firefox?

https://www.jeffersonscher.com/res/setcookie.php

Your page is still serving me expired cookies. I don't know why Chrome extends their expiration time. Maybe they have a documented explanation for that somewhere. Did this page work for you in Firefox? https://www.jeffersonscher.com/res/setcookie.php

Question owner

Your test PHP page is returning cookies fine.

I'll try setting the expire for 60 seconds instead of 10 and see if that helps.

Thanks for helping me out with this!

Your test PHP page is returning cookies fine. I'll try setting the expire for 60 seconds instead of 10 and see if that helps. Thanks for helping me out with this!
cor-el
  • Top 10 Contributor
  • Moderator
17566 solutions 158879 answers

Helpful Reply

You can check the HTTP response headers in the Network Monitor to see that the time on the server is off for a few minutes.

You can check the HTTP response headers in the Network Monitor to see that the time on the server is off for a few minutes. *https://developer.mozilla.org/en/Tools/Network_Monitor

Chosen Solution

Thanks for the suggestion which has resulted in it now working. The SERVER time wasn't synced to Internet time and was off. It now seems to work fine.

Strange that Chrome worked with the time offset difference.

Thanks everyone for your help resolving this!

Thanks for the suggestion which has resulted in it now working. The SERVER time wasn't synced to Internet time and was off. It now seems to work fine. Strange that Chrome worked with the time offset difference. Thanks everyone for your help resolving this!